summaryrefslogtreecommitdiffstats
path: root/abs/core/imlib2
diff options
context:
space:
mode:
authorJames Meyer <James.meyer@operamail.com>2008-10-02 03:19:12 (GMT)
committerJames Meyer <James.meyer@operamail.com>2008-10-02 03:19:12 (GMT)
commit0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a (patch)
treec0aa2c0b53c317be87eacfcb77b63f53f1f415e7 /abs/core/imlib2
downloadlinhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.zip
linhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.tar.gz
linhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.tar.bz2
initial import
Diffstat (limited to 'abs/core/imlib2')
-rw-r--r--abs/core/imlib2/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/abs/core/imlib2/PKGBUILD b/abs/core/imlib2/PKGBUILD
new file mode 100644
index 0000000..1fd9f74
--- /dev/null
+++ b/abs/core/imlib2/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id: PKGBUILD 2921 2008-06-15 20:14:02Z eric $
+# Maintainer: arjan <arjan@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+pkgname=imlib2
+pkgver=1.4.1
+pkgrel=1
+pkgdesc="Imlib2 is the successor to Imlib. It is NOT a newer version -- Imlib 2 can be installed alongside Imlib 1.x"
+arch=(i686 x86_64)
+url="http://sourceforge.net/projects/enlightenment"
+license=('BSD')
+depends=('libtiff' 'giflib' 'bzip2' 'freetype2' 'libxext' 'libpng' 'libid3tag')
+options=('!libtool')
+source=(http://downloads.sourceforge.net/sourceforge/enlightenment/$pkgname-$pkgver.tar.gz)
+md5sums=('16a3d885e523303be794282c0ed90841')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+
+ # Enable x86 MMX optimizations for i686 (32-bit assembler code not compatible with x86_64)
+ [ "${CARCH}" = "i686" ] && EXTRAOPTS="--disable-mmx"
+ # Disable AMD64 optimizations due to bug in assembler code
+ [ "${CARCH}" = "x86_64" ] && EXTRAOPTS="--disable-amd64"
+
+ ./configure --prefix=/usr --sysconfdir=/etc/imlib2 --x-libraries=/usr/lib $EXTRAOPTS
+ make || return 1
+ make DESTDIR=$startdir/pkg install
+ install -D -m644 COPYING $startdir/pkg/usr/share/licenses/$pkgname/LICENSE.txt
+}