summaryrefslogtreecommitdiffstats
path: root/abs/core/iproute2/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2016-01-28 22:10:21 (GMT)
committerBritney Fransen <brfransen@gmail.com>2016-01-28 22:10:21 (GMT)
commitaabf8dad99ceae0d0f58d8cc43f88e0198f97ce8 (patch)
treed5ea84b2546ae5ead69029e87565bccbbdf6c27e /abs/core/iproute2/PKGBUILD
parented53e91449ab21a84f101ecfca43411775e50d42 (diff)
downloadlinhes_pkgbuild-aabf8dad99ceae0d0f58d8cc43f88e0198f97ce8.zip
linhes_pkgbuild-aabf8dad99ceae0d0f58d8cc43f88e0198f97ce8.tar.gz
linhes_pkgbuild-aabf8dad99ceae0d0f58d8cc43f88e0198f97ce8.tar.bz2
iproute2: update to 4.1.1
Diffstat (limited to 'abs/core/iproute2/PKGBUILD')
-rw-r--r--abs/core/iproute2/PKGBUILD37
1 files changed, 20 insertions, 17 deletions
diff --git a/abs/core/iproute2/PKGBUILD b/abs/core/iproute2/PKGBUILD
index e1f1683..4a6bcc0 100644
--- a/abs/core/iproute2/PKGBUILD
+++ b/abs/core/iproute2/PKGBUILD
@@ -3,14 +3,14 @@
# Contributor: Judd Vinet <jvinet@zeroflux.org>
pkgname=iproute2
-pkgver=3.17.0
+pkgver=4.1.1
pkgrel=1
pkgdesc="IP Routing Utilities"
arch=('i686' 'x86_64')
license=('GPL2')
url="http://www.linuxfoundation.org/collaborate/workgroups/networking/iproute2"
depends=('glibc' 'iptables')
-makedepends=('linux-atm' 'git')
+makedepends=('linux-atm')
optdepends=('linux-atm: ATM support')
groups=('base')
provides=('iproute')
@@ -19,44 +19,47 @@ replaces=('iproute')
options=('staticlibs' '!makeflags')
backup=('etc/iproute2/ematch_map' 'etc/iproute2/rt_dsfield' 'etc/iproute2/rt_protos' \
'etc/iproute2/rt_realms' 'etc/iproute2/rt_scopes' 'etc/iproute2/rt_tables')
-#source=(http://www.kernel.org/pub/linux/utils/net/$pkgname/$pkgname-$pkgver.tar.xz
-source=(git://git.kernel.org/pub/scm/linux/kernel/git/shemminger/iproute2.git#tag=v$pkgver
+validpgpkeys=('9F6FC345B05BE7E766B83C8F80A77F6095CDE47E') # Stephen Hemminger
+source=("http://www.kernel.org/pub/linux/utils/net/${pkgname}/${pkgname}-${pkgver}.tar."{xz,sign}
iproute2-fhs.patch
unwanted-link-help.patch)
-sha1sums=('SKIP'
- '35b8cf2dc94b73eccad427235c07596146cd6f6c'
+sha1sums=('750c17e720b43041c23fed7b8cf0118c0e841036'
+ 'SKIP'
+ '2dc6d8f1a2495a0d51eaa303dcc78ecc0c477935'
'3b1335f4025f657f388fbf4e5a740871e3129c2a')
prepare() {
- cd "$srcdir/$pkgname"
+ cd "${srcdir}/${pkgname}-${pkgver}"
# set correct fhs structure
- patch -Np1 -i "$srcdir/iproute2-fhs.patch"
+ patch -Np1 -i "${srcdir}/iproute2-fhs.patch"
# allow operations on links called "h", "he", "hel", "help"
- patch -Np1 -i "$srcdir/unwanted-link-help.patch"
+ patch -Np1 -i "${srcdir}/unwanted-link-help.patch"
# do not treat warnings as errors
sed -i 's/-Werror//' Makefile
+
}
build() {
- cd "$srcdir/$pkgname"
+ cd "${srcdir}/${pkgname}-${pkgver}"
./configure
make
}
package() {
- cd "$srcdir/$pkgname"
+ cd "${srcdir}/${pkgname}-${pkgver}"
- make DESTDIR="$pkgdir" install
+ make DESTDIR="${pkgdir}" install
# libnetlink isn't installed, install it FS#19385
- install -Dm644 include/libnetlink.h "$pkgdir/usr/include/libnetlink.h"
- install -Dm644 lib/libnetlink.a "$pkgdir/usr/lib/libnetlink.a"
+ install -Dm644 include/libnetlink.h "${pkgdir}/usr/include/libnetlink.h"
+ install -Dm644 lib/libnetlink.a "${pkgdir}/usr/lib/libnetlink.a"
+
+ # move binaries
+ cd "${pkgdir}"
+ mv sbin usr/bin
- # usrmove
- cd "$pkgdir"
- mv usr/sbin usr/bin
}