summaryrefslogtreecommitdiffstats
path: root/abs/core/iproute2/iproute2-fhs.patch
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2017-02-07 22:08:11 (GMT)
committerBritney Fransen <brfransen@gmail.com>2017-02-07 22:08:11 (GMT)
commit39eaadf76d1ea3f7fa86b7060526552ad09843a6 (patch)
treedc06a37219c9be0601c68ab3951d5600a0d846d4 /abs/core/iproute2/iproute2-fhs.patch
parent792a17285080b806afe1749af4598ecfa845ab15 (diff)
downloadlinhes_pkgbuild-39eaadf76d1ea3f7fa86b7060526552ad09843a6.zip
linhes_pkgbuild-39eaadf76d1ea3f7fa86b7060526552ad09843a6.tar.gz
linhes_pkgbuild-39eaadf76d1ea3f7fa86b7060526552ad09843a6.tar.bz2
iproute2: update to 4.9.0
Diffstat (limited to 'abs/core/iproute2/iproute2-fhs.patch')
-rw-r--r--abs/core/iproute2/iproute2-fhs.patch87
1 files changed, 0 insertions, 87 deletions
diff --git a/abs/core/iproute2/iproute2-fhs.patch b/abs/core/iproute2/iproute2-fhs.patch
deleted file mode 100644
index f632b64..0000000
--- a/abs/core/iproute2/iproute2-fhs.patch
+++ /dev/null
@@ -1,87 +0,0 @@
-diff --git a/Makefile b/Makefile
-index 67176be..6549447 100644
---- a/Makefile
-+++ b/Makefile
-@@ -13,7 +13,7 @@ DBM_INCLUDE:=$(DESTDIR)/usr/include
-
- SHARED_LIBS = y
-
--DEFINES= -DRESOLVE_HOSTNAMES -DLIBDIR=\"$(LIBDIR)\"
-+DEFINES= -DRESOLVE_HOSTNAMES -DLIBDIR=\"$(LIBDIR)\" -DDATADIR=\"$(DATADIR)\"
- ifneq ($(SHARED_LIBS),y)
- DEFINES+= -DNO_SHARED_LIBS
- endif
-diff --git a/netem/Makefile b/netem/Makefile
-index e52e125..5b4d283 100644
---- a/netem/Makefile
-+++ b/netem/Makefile
-@@ -20,9 +20,9 @@ stats: stats.c
- $(HOSTCC) $(CCOPTS) -I../include -o $@ $@.c -lm
-
- install: all
-- mkdir -p $(DESTDIR)$(LIBDIR)/tc
-+ mkdir -p $(DESTDIR)$(DATADIR)/tc
- for i in $(DISTDATA); \
-- do install -m 644 $$i $(DESTDIR)$(LIBDIR)/tc; \
-+ do install -m 644 $$i $(DESTDIR)$(DATADIR)/tc; \
- done
-
- clean:
-diff --git a/tc/q_netem.c b/tc/q_netem.c
-index cd990a0..7d4e71f 100644
---- a/tc/q_netem.c
-+++ b/tc/q_netem.c
-@@ -113,7 +113,7 @@ static int get_distribution(const char *type, __s16 *data, int maxdata)
- char *line = NULL;
- char name[128];
-
-- snprintf(name, sizeof(name), "%s/%s.dist", get_tc_lib(), type);
-+ snprintf(name, sizeof(name), "%s/%s.dist", get_tc_datadir(), type);
- if ((f = fopen(name, "r")) == NULL) {
- fprintf(stderr, "No distribution data for %s (%s: %s)\n",
- type, name, strerror(errno));
-diff --git a/tc/tc_util.c b/tc/tc_util.c
-index aa6de24..22bb6d5 100644
---- a/tc/tc_util.c
-+++ b/tc/tc_util.c
-@@ -32,6 +32,10 @@
- #define LIBDIR "/usr/lib"
- #endif
-
-+#ifndef DATADIR
-+#define DATADIR "/usr/share"
-+#endif
-+
- static struct db_names *cls_names = NULL;
-
- #define NAMES_DB "/etc/iproute2/tc_cls"
-@@ -73,6 +77,17 @@ const char *get_tc_lib(void)
- return lib_dir;
- }
-
-+const char *get_tc_datadir(void)
-+{
-+ const char *data_dir;
-+
-+ data_dir = getenv("TC_DATA_DIR");
-+ if (!data_dir)
-+ data_dir = DATADIR "/tc/";
-+
-+ return data_dir;
-+}
-+
- int get_qdisc_handle(__u32 *h, const char *str)
- {
- __u32 maj;
-diff --git a/tc/tc_util.h b/tc/tc_util.h
-index 61e60b1..6d448de 100644
---- a/tc/tc_util.h
-+++ b/tc/tc_util.h
-@@ -55,6 +55,7 @@ struct exec_util {
- };
-
- extern const char *get_tc_lib(void);
-+extern const char *get_tc_datadir(void);
-
- extern struct qdisc_util *get_qdisc_kind(const char *str);
- extern struct filter_util *get_filter_kind(const char *str);