summaryrefslogtreecommitdiffstats
path: root/abs/core/iproute2
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-24 02:43:49 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-24 02:43:49 (GMT)
commit4409812d4344e9d926924da54e73230b6d5336ba (patch)
treeba5a5901aeec99e5cceabfbef93c355a383daff1 /abs/core/iproute2
parent58e40c80ba0b97076fcd16d54602017420b1ad08 (diff)
downloadlinhes_pkgbuild-4409812d4344e9d926924da54e73230b6d5336ba.zip
linhes_pkgbuild-4409812d4344e9d926924da54e73230b6d5336ba.tar.gz
linhes_pkgbuild-4409812d4344e9d926924da54e73230b6d5336ba.tar.bz2
iproute2: upgrade
Diffstat (limited to 'abs/core/iproute2')
-rw-r--r--abs/core/iproute2/PKGBUILD29
-rw-r--r--abs/core/iproute2/iproute2-fhs.patch57
-rw-r--r--abs/core/iproute2/iproutegetfix.patch10
3 files changed, 68 insertions, 28 deletions
diff --git a/abs/core/iproute2/PKGBUILD b/abs/core/iproute2/PKGBUILD
index 38b5a4c..deb10fa 100644
--- a/abs/core/iproute2/PKGBUILD
+++ b/abs/core/iproute2/PKGBUILD
@@ -1,10 +1,10 @@
-# $Id: PKGBUILD 82589 2010-06-14 06:49:40Z ronald $
+# $Id: PKGBUILD 96235 2010-10-19 13:01:29Z allan $
# Maintainer: Ronald van Haren <ronald.archlinux.org>
# Contributor: Judd Vinet <jvinet@zeroflux.org>
pkgname=iproute2
-pkgver=2.6.34
-pkgrel=2
+pkgver=2.6.35
+pkgrel=4
pkgdesc="IP Routing Utilities"
arch=('i686' 'x86_64')
license=('GPL2')
@@ -17,18 +17,22 @@ options=('!makeflags')
backup=('etc/iproute2/ematch_map' 'etc/iproute2/rt_dsfield' 'etc/iproute2/rt_protos' \
'etc/iproute2/rt_realms' 'etc/iproute2/rt_scopes' 'etc/iproute2/rt_tables')
source=(http://devresources.linux-foundation.org/dev/iproute2/download/iproute2-${pkgver}.tar.bz2
- 'iproute2-fhs.patch' 'tc.patch')
-sha1sums=('b57f98e284c68a464b9c3e132d29760de6331688'
- 'ae7c4529555e1dce389fcedcbb7e0df5c726741a'
- 'de7ffa44922741c1239e1715e1d81d8f4e7b04e4')
+ 'iproute2-fhs.patch' 'iproutegetfix.patch')
+sha1sums=('862b86ac73ea696867675765d119654553a22aeb'
+ '2416b11252364d7a6c742eabb4a6924a75637a46'
+ 'cd8c969800a9bd1d4ebba0e1eae69d0892786d60')
build() {
cd $srcdir/iproute2-${pkgver}
# set correct fhs structure
- patch -Np1 -i ${srcdir}/iproute2-fhs.patch || return 1
- patch -Np0 -i ${srcdir}/tc.patch || return 1
- ./configure || return 1
+ patch -Np1 -i ${srcdir}/iproute2-fhs.patch
+
+ # fix ip route get breakage
+ patch -Np0 -i ${srcdir}/iproutegetfix.patch
+
+ ./configure
+
make || return 1
}
@@ -38,7 +42,6 @@ package() {
make DESTDIR=$pkgdir install || return 1
# libnetlink isn't installed, install it FS#19385
- install -Dm644 include/libnetlink.h ${pkgdir}/usr/include/libnetlink.h || return 1
- install -Dm644 lib/libnetlink.a ${pkgdir}/usr/lib/libnetlink.a || return 1
+ install -Dm644 include/libnetlink.h ${pkgdir}/usr/include/libnetlink.h
+ install -Dm644 lib/libnetlink.a ${pkgdir}/usr/lib/libnetlink.a
}
-
diff --git a/abs/core/iproute2/iproute2-fhs.patch b/abs/core/iproute2/iproute2-fhs.patch
index 563a915..2608414 100644
--- a/abs/core/iproute2/iproute2-fhs.patch
+++ b/abs/core/iproute2/iproute2-fhs.patch
@@ -17,21 +17,6 @@ diff -Naur iproute2.old/Makefile iproute2-2.6.29/Makefile
# Path to db_185.h include
DBM_INCLUDE:=$(ROOTDIR)/usr/include
-diff -Naur iproute2.old/netem/Makefile iproute2-2.6.29/netem/Makefile
---- iproute2.old/netem/Makefile 2009-11-11 22:05:21.284750207 +0100
-+++ iproute2-2.6.29/netem/Makefile 2009-11-11 22:07:54.674736924 +0100
-@@ -20,9 +20,9 @@
- $(HOSTCC) $(CCOPTS) -I../include -o $@ $@.c -lm
-
- install: all
-- mkdir -p $(DESTDIR)/lib/tc
-+ mkdir -p $(DESTDIR)/${SHAREDIR}/tc
- for i in $(DISTDATA); \
-- do install -m 755 $$i $(DESTDIR)/lib/tc; \
-+ do install -m 755 $$i $(DESTDIR)/${SHAREDIR}/tc; \
- done
-
- clean:
diff -Naur iproute2.old/tc/tc_util.c iproute2-2.6.29/tc/tc_util.c
--- iproute2.old/tc/tc_util.c 2009-11-11 22:05:21.298076943 +0100
+++ iproute2-2.6.29/tc/tc_util.c 2009-11-11 22:09:32.865152646 +0100
@@ -55,3 +40,45 @@ diff -Naur iproute2.old/tc/tc_util.c iproute2-2.6.29/tc/tc_util.c
return lib_dir;
}
+diff -Naur iproute2.old/netem/Makefile iproute2-2.6.35/netem/Makefile
+--- iproute2.old/netem/Makefile 2010-08-06 11:30:48.640940183 +0200
++++ iproute2-2.6.35/netem/Makefile 2010-08-06 11:32:34.210908892 +0200
+@@ -20,9 +20,9 @@
+ $(HOSTCC) $(CCOPTS) -I../include -o $@ $@.c -lm
+
+ install: all
+- mkdir -p $(DESTDIR)$(LIBDIR)/tc
++ mkdir -p $(DESTDIR)$(SHAREDIR)/tc
+ for i in $(DISTDATA); \
+- do install -m 644 $$i $(DESTDIR)$(LIBDIR)/tc; \
++ do install -m 644 $$i $(DESTDIR)$(SHAREDIR)/tc; \
+ done
+
+ clean:
+diff -Naur iproute2.old/tc/Makefile iproute2-2.6.35/tc/Makefile
+--- iproute2.old/tc/Makefile 2010-08-06 11:48:35.607472252 +0200
++++ iproute2-2.6.35/tc/Makefile 2010-08-06 11:49:36.977473380 +0200
+@@ -99,18 +99,11 @@
+ $(AR) rcs $@ $(TCLIB)
+
+ install: all
+- mkdir -p $(MODDESTDIR)
+- install -m 0755 tc $(DESTDIR)$(SBINDIR)
+- for i in $(TCSO); \
+- do install -m 755 $$i $(MODDESTDIR); \
+- done
+- if [ ! -f $(MODDESTDIR)/m_ipt.so ]; then \
+- if [ -f $(MODDESTDIR)/m_xt.so ]; \
+- then ln -s m_xt.so $(MODDESTDIR)/m_ipt.so ; \
+- elif [ -f $(MODDESTDIR)/m_xt_old.so ]; \
+- then ln -s m_xt_old.so $(MODDESTDIR)/m_ipt.so ; \
+- fi; \
+- fi
++ mkdir -p $(DESTDIR)$(LIBDIR)/tc
++ install -m 0755 tc $(DESTDIR)$(SBINDIR)
++ for i in $(TCSO); \
++ do install -m 755 $$i $(DESTDIR)$(LIBDIR)/tc; \
++ done
+
+ clean:
+ rm -f $(TCOBJ) $(TCLIB) libtc.a tc *.so emp_ematch.yacc.h; \
diff --git a/abs/core/iproute2/iproutegetfix.patch b/abs/core/iproute2/iproutegetfix.patch
new file mode 100644
index 0000000..182ff56
--- /dev/null
+++ b/abs/core/iproute2/iproutegetfix.patch
@@ -0,0 +1,10 @@
+--- ip/iproute.c.orig 2010-08-12 13:50:37.510000024 +0200
++++ ip/iproute.c 2010-08-12 13:51:05.100000024 +0200
+@@ -1286,6 +1286,7 @@
+ memset(&req, 0, sizeof(req));
+
+ iproute_reset_filter();
++ filter.cloned = 2;
+
+ req.n.nlmsg_len = NLMSG_LENGTH(sizeof(struct rtmsg));
+ req.n.nlmsg_flags = NLM_F_REQUEST;