summaryrefslogtreecommitdiffstats
path: root/abs/core/iproute2
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-10-23 18:17:40 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-10-23 18:19:39 (GMT)
commitadbcf19958300e9b6598990184c8815b945ba0ee (patch)
treef4283c850ac0ac202c17e78a637ee7ca8147621b /abs/core/iproute2
parent61a68250df10d29b624650948484898334ff22d0 (diff)
downloadlinhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.zip
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.gz
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.bz2
Removed old core and extra from repo. Renamed -testing to core/extra. This will setup the base for the testing branch.
Diffstat (limited to 'abs/core/iproute2')
-rw-r--r--abs/core/iproute2/PKGBUILD35
-rw-r--r--abs/core/iproute2/iproute2-fhs.patch57
-rw-r--r--abs/core/iproute2/tc.patch26
3 files changed, 104 insertions, 14 deletions
diff --git a/abs/core/iproute2/PKGBUILD b/abs/core/iproute2/PKGBUILD
index ed280e5..38b5a4c 100644
--- a/abs/core/iproute2/PKGBUILD
+++ b/abs/core/iproute2/PKGBUILD
@@ -1,37 +1,44 @@
-# $Id: PKGBUILD 24415 2009-01-16 12:43:06Z ronald $
+# $Id: PKGBUILD 82589 2010-06-14 06:49:40Z ronald $
# Maintainer: Ronald van Haren <ronald.archlinux.org>
# Contributor: Judd Vinet <jvinet@zeroflux.org>
pkgname=iproute2
-pkgver=2.6.28
-pkgrel=1
+pkgver=2.6.34
+pkgrel=2
pkgdesc="IP Routing Utilities"
arch=('i686' 'x86_64')
license=('GPL2')
url="http://www.linux-foundation.org/en/Net:Iproute2"
depends=('linux-atm' 'perl')
-
provides=('iproute')
conflicts=('iproute')
replaces=('iproute')
-
+options=('!makeflags')
backup=('etc/iproute2/ematch_map' 'etc/iproute2/rt_dsfield' 'etc/iproute2/rt_protos' \
'etc/iproute2/rt_realms' 'etc/iproute2/rt_scopes' 'etc/iproute2/rt_tables')
-
-source=(http://devresources.linux-foundation.org/dev/iproute2/download/iproute2-${pkgver}.tar.bz2)
-md5sums=('595f9b17320f69e8d30d2fa80f1bca14')
+source=(http://devresources.linux-foundation.org/dev/iproute2/download/iproute2-${pkgver}.tar.bz2
+ 'iproute2-fhs.patch' 'tc.patch')
+sha1sums=('b57f98e284c68a464b9c3e132d29760de6331688'
+ 'ae7c4529555e1dce389fcedcbb7e0df5c726741a'
+ 'de7ffa44922741c1239e1715e1d81d8f4e7b04e4')
build() {
cd $srcdir/iproute2-${pkgver}
- sed -i 's|/usr/local/lib/iptables|/usr/lib/iptables|' include/iptables.h || return 1
- sed -i 's|=/share|=/usr/share|' Makefile || return 1
- sed -i 's|=/sbin|=/usr/sbin|' Makefile || return 1
-
+ # set correct fhs structure
+ patch -Np1 -i ${srcdir}/iproute2-fhs.patch || return 1
+ patch -Np0 -i ${srcdir}/tc.patch || return 1
./configure || return 1
make || return 1
- make DESTDIR=$pkgdir install || return 1
+}
-# chmod 755 $pkgdir/usr/sbin/ifcfg || return 1
+package() {
+ cd $srcdir/iproute2-${pkgver}
+ make DESTDIR=$pkgdir install || return 1
+
+ # libnetlink isn't installed, install it FS#19385
+ install -Dm644 include/libnetlink.h ${pkgdir}/usr/include/libnetlink.h || return 1
+ install -Dm644 lib/libnetlink.a ${pkgdir}/usr/lib/libnetlink.a || return 1
}
+
diff --git a/abs/core/iproute2/iproute2-fhs.patch b/abs/core/iproute2/iproute2-fhs.patch
new file mode 100644
index 0000000..563a915
--- /dev/null
+++ b/abs/core/iproute2/iproute2-fhs.patch
@@ -0,0 +1,57 @@
+diff -Naur iproute2.old/Makefile iproute2-2.6.29/Makefile
+--- iproute2.old/Makefile 2009-11-11 22:05:21.251407668 +0100
++++ iproute2-2.6.29/Makefile 2009-11-11 22:07:09.891833516 +0100
+@@ -1,11 +1,12 @@
+ DESTDIR=/usr/
+ ROOTDIR=$(DESTDIR)
+ LIBDIR=/usr/lib/
+-SBINDIR=/sbin
++SBINDIR=/usr/sbin
+ CONFDIR=/etc/iproute2
+-DOCDIR=/share/doc/iproute2
+-MANDIR=/share/man
++DOCDIR=/usr/share/doc/iproute2
++MANDIR=/usr/share/man
+ ARPDDIR=/var/lib/arpd
++SHAREDIR=/usr/share
+
+ # Path to db_185.h include
+ DBM_INCLUDE:=$(ROOTDIR)/usr/include
+diff -Naur iproute2.old/netem/Makefile iproute2-2.6.29/netem/Makefile
+--- iproute2.old/netem/Makefile 2009-11-11 22:05:21.284750207 +0100
++++ iproute2-2.6.29/netem/Makefile 2009-11-11 22:07:54.674736924 +0100
+@@ -20,9 +20,9 @@
+ $(HOSTCC) $(CCOPTS) -I../include -o $@ $@.c -lm
+
+ install: all
+- mkdir -p $(DESTDIR)/lib/tc
++ mkdir -p $(DESTDIR)/${SHAREDIR}/tc
+ for i in $(DISTDATA); \
+- do install -m 755 $$i $(DESTDIR)/lib/tc; \
++ do install -m 755 $$i $(DESTDIR)/${SHAREDIR}/tc; \
+ done
+
+ clean:
+diff -Naur iproute2.old/tc/tc_util.c iproute2-2.6.29/tc/tc_util.c
+--- iproute2.old/tc/tc_util.c 2009-11-11 22:05:21.298076943 +0100
++++ iproute2-2.6.29/tc/tc_util.c 2009-11-11 22:09:32.865152646 +0100
+@@ -24,8 +24,8 @@
+ #include "utils.h"
+ #include "tc_util.h"
+
+-#ifndef LIBDIR
+-#define LIBDIR "/usr/lib/"
++#ifndef SHAREDIR
++#define SHAREDIR "/usr/share"
+ #endif
+
+ const char *get_tc_lib(void)
+@@ -34,7 +34,7 @@
+
+ lib_dir = getenv("TC_LIB_DIR");
+ if (!lib_dir)
+- lib_dir = LIBDIR "/tc/";
++ lib_dir = SHAREDIR "/tc/";
+
+ return lib_dir;
+ }
diff --git a/abs/core/iproute2/tc.patch b/abs/core/iproute2/tc.patch
new file mode 100644
index 0000000..e6d6276
--- /dev/null
+++ b/abs/core/iproute2/tc.patch
@@ -0,0 +1,26 @@
+--- tc/Makefile.old 2010-06-14 08:29:49.257421437 +0200
++++ tc/Makefile 2010-06-14 08:30:07.157419977 +0200
+@@ -99,18 +99,11 @@
+ $(AR) rcs $@ $(TCLIB)
+
+ install: all
+- echo mkdir -p $(MODDESTDIR)
+- echo install -m 0755 tc $(DESTDIR)$(SBINDIR)
+- for i in $(TCSO); \
+- do echo install -m 755 $$i $(MODDESTDIR); \
+- done
+- if [ ! -f $(MODDESTDIR)/m_ipt.so ]; then \
+- if [ -f $(MODDESTDIR)/m_xt.so ]; \
+- then ln -s m_xt.so $(MODDESTDIR)/m_ipt.so ; \
+- elif [ -f $(MODDESTDIR)/m_xt_old.so ]; \
+- then ln -s m_xt_old.so $(MODDESTDIR)/m_ipt.so ; \
+- fi; \
+- fi
++ mkdir -p $(DESTDIR)$(LIBDIR)/tc
++ install -m 0755 tc $(DESTDIR)$(SBINDIR)
++ for i in $(TCSO); \
++ do install -m 755 $$i $(DESTDIR)$(LIBDIR)/tc; \
++ done
+
+ clean:
+ rm -f $(TCOBJ) $(TCLIB) libtc.a tc *.so emp_ematch.yacc.h; \