summaryrefslogtreecommitdiffstats
path: root/abs/core/iproute2
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2014-02-16 23:50:45 (GMT)
committerJames Meyer <james.meyer@operamail.com>2014-02-19 19:03:03 (GMT)
commitcdfb9e4bf2706feee766cae336e31ca21a1bd73f (patch)
treef4770b1abaf07d19701f2b9c0a7b90bc65bcac68 /abs/core/iproute2
parentdeede5e40d1a8d27388f25a90a1413f269d60a17 (diff)
downloadlinhes_pkgbuild-cdfb9e4bf2706feee766cae336e31ca21a1bd73f.zip
linhes_pkgbuild-cdfb9e4bf2706feee766cae336e31ca21a1bd73f.tar.gz
linhes_pkgbuild-cdfb9e4bf2706feee766cae336e31ca21a1bd73f.tar.bz2
iproute2, iptables, iputils:
update binary path to /usr/bin refs #961
Diffstat (limited to 'abs/core/iproute2')
-rw-r--r--abs/core/iproute2/PKGBUILD41
-rw-r--r--abs/core/iproute2/unwanted-link-help.patch17
2 files changed, 43 insertions, 15 deletions
diff --git a/abs/core/iproute2/PKGBUILD b/abs/core/iproute2/PKGBUILD
index 471b91e..04ca6df 100644
--- a/abs/core/iproute2/PKGBUILD
+++ b/abs/core/iproute2/PKGBUILD
@@ -1,36 +1,48 @@
-# $Id: PKGBUILD 162200 2012-06-23 12:13:11Z ronald $
+# $Id: PKGBUILD 199763 2013-11-15 21:24:40Z ronald $
# Maintainer: Ronald van Haren <ronald.archlinux.org>
# Contributor: Judd Vinet <jvinet@zeroflux.org>
pkgname=iproute2
-pkgver=3.4.0
-pkgrel=2
+pkgver=3.11.0
+pkgrel=1
pkgdesc="IP Routing Utilities"
arch=('i686' 'x86_64')
license=('GPL2')
url="http://www.linuxfoundation.org/collaborate/workgroups/networking/iproute2"
-depends=('glibc' 'db')
+depends=('glibc' 'db' 'iptables')
makedepends=('linux-atm')
optdepends=('linux-atm: ATM support')
+groups=('base')
provides=('iproute')
conflicts=('iproute')
replaces=('iproute')
-options=('!makeflags')
+options=('staticlibs' '!makeflags')
backup=('etc/iproute2/ematch_map' 'etc/iproute2/rt_dsfield' 'etc/iproute2/rt_protos' \
'etc/iproute2/rt_realms' 'etc/iproute2/rt_scopes' 'etc/iproute2/rt_tables')
source=(http://www.kernel.org/pub/linux/utils/net/$pkgname/$pkgname-$pkgver.tar.xz
- iproute2-fhs.patch)
-sha1sums=('fcea492dea2f3ecf9d35f279e2f1a7ea6ca0d527'
- '35b8cf2dc94b73eccad427235c07596146cd6f6c')
+ iproute2-fhs.patch
+ unwanted-link-help.patch)
+sha1sums=('efb5ca0688e28967ec146ac37cc728c4f53c9d8f'
+ '35b8cf2dc94b73eccad427235c07596146cd6f6c'
+ '3b1335f4025f657f388fbf4e5a740871e3129c2a')
-build() {
+prepare() {
cd $srcdir/$pkgname-$pkgver
# set correct fhs structure
patch -Np1 -i "$srcdir/iproute2-fhs.patch"
- ./configure
+ # allow operations on links called "h", "he", "hel", "help"
+ patch -Np1 -i "$srcdir/unwanted-link-help.patch"
+
+ # do not treat warnings as errors
+ sed -i 's/-Werror//' Makefile
+}
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ ./configure
make
}
@@ -39,12 +51,11 @@ package() {
make DESTDIR="$pkgdir" install
- # allow loopback to be started before /usr is mounted, this may not be supported in the future
- mkdir -p "$pkgdir/sbin"
- mv "$pkgdir/usr/sbin/ip" "$pkgdir/sbin/ip"
- ln -s /sbin/ip "$pkgdir/usr/sbin/ip"
-
# libnetlink isn't installed, install it FS#19385
install -Dm644 include/libnetlink.h "$pkgdir/usr/include/libnetlink.h"
install -Dm644 lib/libnetlink.a "$pkgdir/usr/lib/libnetlink.a"
+
+ # usrmove
+ cd "$pkgdir"
+ mv usr/sbin usr/bin
}
diff --git a/abs/core/iproute2/unwanted-link-help.patch b/abs/core/iproute2/unwanted-link-help.patch
new file mode 100644
index 0000000..8abe9e3
--- /dev/null
+++ b/abs/core/iproute2/unwanted-link-help.patch
@@ -0,0 +1,17 @@
+diff -ru iproute2-3.10.0.orig/ip/iplink.c iproute2-3.10.0/ip/iplink.c
+--- iproute2-3.10.0.orig/ip/iplink.c 2013-08-08 13:53:33.000000000 -0700
++++ iproute2-3.10.0/ip/iplink.c 2013-08-08 13:55:03.179865309 -0700
+@@ -467,11 +467,11 @@
+ addattr_l(&req->n, sizeof(*req), IFLA_NUM_RX_QUEUES,
+ &numrxqueues, 4);
+ } else {
++ if (matches(*argv, "help") == 0)
++ usage();
+ if (strcmp(*argv, "dev") == 0) {
+ NEXT_ARG();
+ }
+- if (matches(*argv, "help") == 0)
+- usage();
+ if (*dev)
+ duparg2("dev", *argv);
+ *dev = *argv;