summaryrefslogtreecommitdiffstats
path: root/abs/core/iptables/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2013-02-19 21:10:18 (GMT)
committerJames Meyer <james.meyer@operamail.com>2013-02-19 21:10:18 (GMT)
commit2648e999d277eac5c3d331a3609bcc73fafbea71 (patch)
tree40951fb8e7fdbe28a0baa324ae615055203f1e2e /abs/core/iptables/PKGBUILD
parentc759b5e0c4aa6fc37412b4dee2cf9ad993fd376d (diff)
parent7e6f7ca174e1af67178dc5293a312a4a733eb095 (diff)
downloadlinhes_pkgbuild-2648e999d277eac5c3d331a3609bcc73fafbea71.zip
linhes_pkgbuild-2648e999d277eac5c3d331a3609bcc73fafbea71.tar.gz
linhes_pkgbuild-2648e999d277eac5c3d331a3609bcc73fafbea71.tar.bz2
Merge branch 'testing'
# By James Meyer (1091) and others # Via James Meyer (5) and others * testing: (1148 commits) LinHES-config: during install don't kill off lirc. This keeps the remote active all the way to the finish Change version numbers to 8.0 to match the release number. LinHES-conifg LinHES-system mythdb-initial runit-scripts supplemental-web LinHES-conifig: mv_install.py for the last partition don't go all the way to the end. Gotta leave room for gpt tables. xf86-video-ati: xorg ati driver. LinHES-config: timezip.py add syncing up of parental lvl passwords and starting level with MBE. LinHES-system: correct the logic for breaking out of the wmctrl loop. As written it would break out of the inner loop..but not the 60 iteration loop. e16_theme_settings: remove slide-in prop for new windows. For whatever reason this was preventing mplayer from being positioned correctly for appletrailers. LinHES-config, mythinstall: change case of hd_pvr and serial to all lower refs #902 zilog-firmware: firmware for TX support of the hdpvr and pvr-150 In general I can't recommend anybody using these transmitters but including the firmware just in case someone really wants to linhes-udev-rules: added hdprv_lirc rule. All of these lirc rules are limited to exactly one device. If more then one device is present then only the last device in init will get the symlink runit-scripts: fix logging for igdeamon, add support to remote init script so that the blaster is always the first device in the chain. added support specificly for hd_pvr LinHES-system: add lh_system_restore and lh_system_backup. These scripts are called from the mythmenu. refs #900 iguanair: rebuild with python 2.7 LinHES-system: msg_daemon.py fix init and nasty bug related to timeout. In a nutshell timeout wouldn't work unless a msg without a timeout was called first. linhes-udev-rules: add rules for mce,streamzap,serial lirc devices. mythinstall: recompile for matching libs mythtv: latest .25-fixes and change mythbackup/restore call lh_system_$op to replace mythbackup/mythrestore. mythbackup no longer works correctly with the new windowmanager linhes-scripts: myth2mp3, myth2x264, myth2xvid: use mythutil to get cutlist LinHES-config, supplimental-web: Fix proxy numbering for Ceton infiniTV linhes-system: add additional stuff to the system backup and also introduced an exclude file. The exclude/include files are locate in /home/mythtv/backup_config/ ...
Diffstat (limited to 'abs/core/iptables/PKGBUILD')
-rw-r--r--abs/core/iptables/PKGBUILD89
1 files changed, 62 insertions, 27 deletions
diff --git a/abs/core/iptables/PKGBUILD b/abs/core/iptables/PKGBUILD
index 107e033..d2c859d 100644
--- a/abs/core/iptables/PKGBUILD
+++ b/abs/core/iptables/PKGBUILD
@@ -1,49 +1,84 @@
-# $Id: PKGBUILD 86873 2010-08-06 09:59:22Z ronald $
+# $Id: PKGBUILD 162152 2012-06-22 12:55:41Z dreisner $
# Maintainer: Ronald van Haren <ronald.archlinux.org>
# Contributor: Thomas Baechler <thomas@archlinux.org>
pkgname=iptables
-pkgver=1.4.9
-pkgrel=1
-pkgdesc="A Linux kernel packet control tool"
+pkgver=1.4.14
+pkgrel=2
+pkgdesc='Linux kernel packet control tool'
arch=('i686' 'x86_64')
license=('GPL2')
-url="http://www.netfilter.org/"
+url='http://www.netfilter.org/projects/iptables/index.html'
depends=('glibc' 'bash')
+makedepends=('linux-api-headers')
options=('!libtool')
-source=(http://www.iptables.org/projects/iptables/files/${pkgname}-${pkgver}.tar.bz2 \
- iptables ip6tables empty.rules simple_firewall.rules iptables.conf.d)
+source=("http://www.iptables.org/projects/iptables/files/${pkgname}-${pkgver}.tar.bz2"
+ iptables
+ ip6tables
+ empty.rules
+ simple_firewall.rules
+ iptables.conf.d
+ empty-filter.rules
+ empty-mangle.rules
+ empty-nat.rules
+ empty-raw.rules
+ empty-security.rules
+ 0503-extension_cppflags.patch
+ iptables.service
+ ip6tables.service
+ iptables-flush)
backup=(etc/conf.d/iptables)
-sha1sums=('c961b58c57cb99b10f5bb753bf3b436c0df05c7c'
- 'd7540316581bb66c5594885882a14ba394e95098'
- '70d70113e3a23f0fe99404c5536507a887a4ca5c'
+sha1sums=('daf2972b81e52f562a644798013e946c88319ea3'
+ '5bb6fa526665cdd728c26f0f282f5a51f220cf88'
+ '2db68906b603e5268736f48c8e251f3a49da1d75'
'83b3363878e3660ce23b2ad325b53cbd6c796ecf'
'9907f9e815592837abc7fa3264a401567b7606ab'
- '1c52444ffbecc09f56bb325db49e924dd32f9213')
+ 'cdb830137192bbe002c6d01058656bd053ed0ddd'
+ 'd9f9f06b46b4187648e860afa0552335aafe3ce4'
+ 'c45b738b5ec4cfb11611b984c21a83b91a2d58f3'
+ '1694d79b3e6e9d9d543f6a6e75fed06066c9a6c6'
+ '7db53bb882f62f6c677cc8559cff83d8bae2ef73'
+ 'ebbd1424a1564fd45f455a81c61ce348f0a14c2e'
+ '44626980a52e49f345a0b1e1ca03060f3a35763c'
+ '5c4eb4ea88c302e8ff98f435a11dd59b00f4d8b9'
+ 'f1f16f44c6a5547b6f251d13007fe6585761e8b0'
+ 'e7abda09c61142121b6695928d3b71ccd8fdf73a')
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd "${srcdir}/${pkgname}-${pkgver}"
- # http://bugs.archlinux.org/task/17046
- sed -i '87 i libxt_RATEEST.so: libxt_RATEEST.oo' extensions/GNUmakefile.in
- sed -i '88 i \\t${AM_VERBOSE_CCLD} ${CCLD} ${AM_LDFLAGS} -lm -shared ${LDFLAGS} -o $@ $<;\n' extensions/GNUmakefile.in
+ # use system one
+ rm include/linux/types.h
- ./configure --prefix=/usr --with-kernel=usr/src/linux-$(uname -r) \
- --libexecdir=/usr/lib/iptables --sysconfdir=/etc \
- --with-xtlibdir=/usr/lib/iptables \
- --enable-devel --enable-libipq
+ patch -Np1 -i ${srcdir}/0503-extension_cppflags.patch
- make || return 1
+ ./configure --prefix=/usr \
+ --libexecdir=/usr/lib/iptables --sysconfdir=/etc \
+ --with-xtlibdir=/usr/lib/iptables \
+ --enable-devel --enable-libipq \
+ --enable-shared
+
+ make
}
package() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
- make DESTDIR=${pkgdir} install || return 1
+ cd "${srcdir}"
+ install -D -m755 iptables "${pkgdir}"/etc/rc.d/iptables
+ install -D -m755 ip6tables "${pkgdir}"/etc/rc.d/ip6tables
+ install -D -m644 empty.rules "${pkgdir}"/etc/iptables/empty.rules
+ install -D -m644 simple_firewall.rules "${pkgdir}"/etc/iptables/simple_firewall.rules
+ install -D -m644 iptables.conf.d "${pkgdir}"/etc/conf.d/iptables
- install -D -m755 ../iptables ${pkgdir}/etc/rc.d/iptables
- install -D -m755 ../ip6tables ${pkgdir}/etc/rc.d/ip6tables
- install -D -m644 ../empty.rules ${pkgdir}/etc/iptables/empty.rules
- install -D -m644 ../simple_firewall.rules ${pkgdir}/etc/iptables/simple_firewall.rules
- install -D -m644 ../iptables.conf.d ${pkgdir}/etc/conf.d/iptables
+ mkdir -p "${pkgdir}"/var/lib/iptables
+ install -m644 empty-{filter,mangle,nat,raw,security}.rules "${pkgdir}"/var/lib/iptables
+
+ # install systemd files
+ install -Dm644 ${srcdir}/iptables.service ${pkgdir}/usr/lib/systemd/system/iptables.service
+ install -Dm644 ${srcdir}/ip6tables.service ${pkgdir}/usr/lib/systemd/system/ip6tables.service
+ install -Dm755 ${srcdir}/iptables-flush ${pkgdir}/usr/lib/systemd/scripts/iptables-flush
}
+