summaryrefslogtreecommitdiffstats
path: root/abs/core/ipw2100-fw
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 02:45:26 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 02:45:26 (GMT)
commit7a1b8b2d4c515434232f08a10114a018305da119 (patch)
tree9161d4566af6805c4de9cc4792e6c6b39e19d9a4 /abs/core/ipw2100-fw
parent679e855206798435f8b168db6426e283e1f70a12 (diff)
downloadlinhes_pkgbuild-7a1b8b2d4c515434232f08a10114a018305da119.zip
linhes_pkgbuild-7a1b8b2d4c515434232f08a10114a018305da119.tar.gz
linhes_pkgbuild-7a1b8b2d4c515434232f08a10114a018305da119.tar.bz2
ipw2001fw
Diffstat (limited to 'abs/core/ipw2100-fw')
-rw-r--r--abs/core/ipw2100-fw/PKGBUILD18
-rw-r--r--abs/core/ipw2100-fw/ipw2100-fw.install18
2 files changed, 9 insertions, 27 deletions
diff --git a/abs/core/ipw2100-fw/PKGBUILD b/abs/core/ipw2100-fw/PKGBUILD
index ccb797a..2fc4a20 100644
--- a/abs/core/ipw2100-fw/PKGBUILD
+++ b/abs/core/ipw2100-fw/PKGBUILD
@@ -1,27 +1,27 @@
-# $Id: PKGBUILD 59422 2009-11-23 20:05:10Z giovanni $
-# Maintainer: Thomas Baechler <thomas@archlinux.org>
+# $Id: PKGBUILD 156556 2012-04-20 21:36:42Z tomegun $
+# Maintainer: Tom Gundersen <teg@jklm.no>
+# Contributor: Thomas Baechler <thomas@archlinux.org>
# Contributor: Giovanni Scafora <giovanni@archlinux.org>
pkgname=ipw2100-fw
pkgver=1.3
-pkgrel=4
+pkgrel=7
pkgdesc="Intel Centrino Drivers firmware for IPW2100"
arch=('any')
url="http://ipw2100.sourceforge.net/"
license=('custom')
-depends=()
replaces=('ipw2100')
-source=(http://bughost.org/firmware/${pkgname}-${pkgver}.tgz)
+source=("http://bughost.org/firmware/${pkgname}-${pkgver}.tgz")
md5sums=('46aa75bcda1a00efa841f9707bbbd113')
-build() {
+package() {
cd "${srcdir}"
-
+
# Install firmware
for i in *.fw
do
- install -D -m 644 $i "${pkgdir}/lib/firmware/$i" || return 1
+ install -D -m 644 $i "${pkgdir}/usr/lib/firmware/$i"
done
# Install license
- install -D -m 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE" || return 1
+ install -D -m 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
diff --git a/abs/core/ipw2100-fw/ipw2100-fw.install b/abs/core/ipw2100-fw/ipw2100-fw.install
deleted file mode 100644
index 1a0ff6b..0000000
--- a/abs/core/ipw2100-fw/ipw2100-fw.install
+++ /dev/null
@@ -1,18 +0,0 @@
-# arg 1: the new package version
-post_install() {
-cat << EOF
-IMPORTANT
-==> In order to use the firmware you have to agree to Intel's license located in
-==> /lib/firmware/LICENSE.ipw2100-fw else please remove this package
-EOF
-}
-
-# arg 1: the new package version
-# arg 2: the old package version
-post_upgrade() {
-post_install $1
-}
-
-op=$1
-shift
-$op $*