summaryrefslogtreecommitdiffstats
path: root/abs/core/ipw2100-fw
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-10-23 18:17:40 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-10-23 18:19:39 (GMT)
commitadbcf19958300e9b6598990184c8815b945ba0ee (patch)
treef4283c850ac0ac202c17e78a637ee7ca8147621b /abs/core/ipw2100-fw
parent61a68250df10d29b624650948484898334ff22d0 (diff)
downloadlinhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.zip
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.gz
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.bz2
Removed old core and extra from repo. Renamed -testing to core/extra. This will setup the base for the testing branch.
Diffstat (limited to 'abs/core/ipw2100-fw')
-rw-r--r--abs/core/ipw2100-fw/PKGBUILD39
1 files changed, 15 insertions, 24 deletions
diff --git a/abs/core/ipw2100-fw/PKGBUILD b/abs/core/ipw2100-fw/PKGBUILD
index 52cd9f5..ccb797a 100644
--- a/abs/core/ipw2100-fw/PKGBUILD
+++ b/abs/core/ipw2100-fw/PKGBUILD
@@ -1,36 +1,27 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
-# Maintainer : Tobias Powalowski <tpowa@archlinux.org>
+# $Id: PKGBUILD 59422 2009-11-23 20:05:10Z giovanni $
+# Maintainer: Thomas Baechler <thomas@archlinux.org>
+# Contributor: Giovanni Scafora <giovanni@archlinux.org>
pkgname=ipw2100-fw
pkgver=1.3
-pkgrel=2
+pkgrel=4
pkgdesc="Intel Centrino Drivers firmware for IPW2100"
-arch=(i686 x86_64)
+arch=('any')
url="http://ipw2100.sourceforge.net/"
-depends=('wireless_tools')
-#source=(ipw2100-fw-1.3.tgz http://switch.dl.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tgz)
-source=(http://bughost.org/firmware/$pkgname-$pkgver.tgz)
-install=ipw2100-fw.install
-replaces=ipw2100
+license=('custom')
+depends=()
+replaces=('ipw2100')
+source=(http://bughost.org/firmware/${pkgname}-${pkgver}.tgz)
+md5sums=('46aa75bcda1a00efa841f9707bbbd113')
build() {
- #cd $startdir/src/$pkgname-$pkgver
- #make
- #Install kernel modules
- #for i in *.ko
- #do
- #install -D -m 644 $i $startdir/pkg/lib/modules/$(uname -r)/kernel/drivers/net/wireless/ipw2100/$i
- #done
-
- cd $startdir/src
+ cd "${srcdir}"
# Install firmware
for i in *.fw
do
- install -D -m 644 $i $startdir/pkg/lib/firmware/$i
+ install -D -m 644 $i "${pkgdir}/lib/firmware/$i" || return 1
done
-
- # Install firmware license
- install -D -m 644 LICENSE $startdir/pkg/lib/firmware/LICENSE.ipw2100-fw
- }
-md5sums=('46aa75bcda1a00efa841f9707bbbd113')
+ # Install license
+ install -D -m 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE" || return 1
+}