summaryrefslogtreecommitdiffstats
path: root/abs/core/isl/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 02:45:57 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 02:45:57 (GMT)
commit773d7745fc4d009c62cb304f615efa569107f457 (patch)
tree49c918e56ab75d38f1fb4224011246732348630b /abs/core/isl/PKGBUILD
parent339c2f07b2abd4b2721f3b69e6fbfdd18bcd1ed9 (diff)
downloadlinhes_pkgbuild-773d7745fc4d009c62cb304f615efa569107f457.zip
linhes_pkgbuild-773d7745fc4d009c62cb304f615efa569107f457.tar.gz
linhes_pkgbuild-773d7745fc4d009c62cb304f615efa569107f457.tar.bz2
isl .1
-new
Diffstat (limited to 'abs/core/isl/PKGBUILD')
-rw-r--r--abs/core/isl/PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/abs/core/isl/PKGBUILD b/abs/core/isl/PKGBUILD
new file mode 100644
index 0000000..2aa5e21
--- /dev/null
+++ b/abs/core/isl/PKGBUILD
@@ -0,0 +1,32 @@
+# $Id: PKGBUILD 162067 2012-06-19 12:27:31Z allan $
+# Maintainer: Allan McRae <allan@archlinux.org>
+
+pkgname=isl
+pkgver=0.10
+pkgrel=1
+pkgdesc="Library for manipulating sets and relations of integer points bounded by linear constraints"
+arch=('i686' 'x86_64')
+url="http://www.kotnet.org/~skimo/isl/"
+license=('LGPL2.1')
+options=('!libtool')
+source=(http://www.kotnet.org/~skimo/isl/$pkgname-$pkgver.tar.bz2)
+md5sums=('c1ece653891bb2a5f55ca25e3f4e8f35')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make check
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make -j1 DESTDIR="$pkgdir/" install
+
+ install -dm755 $pkgdir/usr/share/gdb/auto-load/usr/lib/
+ mv $pkgdir/{,/usr/share/gdb/auto-load/}usr/lib/libisl.so.10.0.0-gdb.py
+}