summaryrefslogtreecommitdiffstats
path: root/abs/core/ivtv-utils
diff options
context:
space:
mode:
authorJames Meyer <James.meyer@operamail.com>2008-10-02 03:19:12 (GMT)
committerJames Meyer <James.meyer@operamail.com>2008-10-02 03:19:12 (GMT)
commit0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a (patch)
treec0aa2c0b53c317be87eacfcb77b63f53f1f415e7 /abs/core/ivtv-utils
downloadlinhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.zip
linhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.tar.gz
linhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.tar.bz2
initial import
Diffstat (limited to 'abs/core/ivtv-utils')
-rw-r--r--abs/core/ivtv-utils/PKGBUILD46
-rw-r--r--abs/core/ivtv-utils/ivtv-utils.install31
2 files changed, 77 insertions, 0 deletions
diff --git a/abs/core/ivtv-utils/PKGBUILD b/abs/core/ivtv-utils/PKGBUILD
new file mode 100644
index 0000000..d8e13c6
--- /dev/null
+++ b/abs/core/ivtv-utils/PKGBUILD
@@ -0,0 +1,46 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Contributor: Sasha Zbrozek <kleptophobiac@gmail.com>
+# Maintainer: Paul Mattal <paul@archlinux.org>
+
+pkgname=ivtv-utils
+pkgver=1.0.3
+pkgrel=1
+_kernver=2.6.23-ARCH
+pkgdesc="Non-mainline kernel drivers and userspace utilities for Hauppauge PVR cards"
+arch=(i686 x86_64)
+license=('GPL')
+url="http://ivtvdriver.org"
+source=("http://dl.ivtvdriver.org/ivtv/archive/1.0.x/ivtv-$pkgver.tar.gz" \
+ 'http://dl.ivtvdriver.org/ivtv/firmware/ivtv-firmware.tar.gz' )
+depends=('gcc-libs')
+md5sums=('2c0e04a861cb7409ea82a2935b1e0050' 'b9a871f1c569025be9c48a77b3515faf')
+
+build() {
+ # SET UP
+ cd $startdir/src/ivtv-$pkgver || return 1
+
+ # don't call depmod here
+ sed -i 's|/sbin/depmod -a||' driver/Makefile i2c-drivers/Makefile || return 1
+
+ # install the utils in /usr/bin, not /usr/local/bin
+ sed -i "s%PREFIX = /usr/local%PREFIX = /usr%g" utils/Makefile || return 1
+
+ #cd to utils as that is all we need since ivtv is now in the kernel
+ cd utils/
+
+ # build
+ make INSTALLDIR=/usr/bin || return 1
+
+ # install
+ make DESTDIR=$startdir/pkg install || return 1
+
+ # remove the kernel modules in the utils package
+ rm -rf $startdir/pkg/lib/modules || return 1
+
+ # install the firmware
+ cd $startdir/src || return 1
+ for file in v4l-cx2341x-dec.fw v4l-cx2341x-enc.fw v4l-cx2341x-init.mpg v4l-cx25840.fw v4l-pvrusb2-24xxx-01.fw v4l-pvrusb2-29xxx-01.fw
+ do
+ install -D -m 0644 $file $startdir/pkg/lib/firmware/$file || return 1
+ done
+}
diff --git a/abs/core/ivtv-utils/ivtv-utils.install b/abs/core/ivtv-utils/ivtv-utils.install
new file mode 100644
index 0000000..4966d4a
--- /dev/null
+++ b/abs/core/ivtv-utils/ivtv-utils.install
@@ -0,0 +1,31 @@
+pre_install() {
+ /bin/true
+}
+
+post_install() {
+ # updating module dependencies
+ echo ">>> Updating module dependencies. Please wait ..."
+ KERNEL_VERSION=2.6.22-ARCH
+ depmod -v $KERNEL_VERSION > /dev/null 2>&1
+ /bin/true
+}
+
+post_upgrade() {
+ # updating module dependencies
+ echo ">>> Updating module dependencies. Please wait ..."
+ KERNEL_VERSION=2.6.22-ARCH
+ depmod -v $KERNEL_VERSION > /dev/null 2>&1
+ /bin/true
+}
+
+post_remove() {
+ # updating module dependencies
+ echo ">>> Updating module dependencies. Please wait ..."
+ KERNEL_VERSION=2.6.22-ARCH
+ depmod -v $KERNEL_VERSION > /dev/null 2>&1
+ /bin/true
+}
+
+op=$1
+shift
+$op $*