summaryrefslogtreecommitdiffstats
path: root/abs/core/ivtv-utils
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-30 23:33:10 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-30 23:33:10 (GMT)
commite2180d2a70197872ac049cf04a686d85f84facd0 (patch)
treead41bf620e5226f6dc5563f3a2bfc5ea8e9d32a6 /abs/core/ivtv-utils
parent977208242976cd631ce6314366b205637d54ee3d (diff)
downloadlinhes_pkgbuild-e2180d2a70197872ac049cf04a686d85f84facd0.zip
linhes_pkgbuild-e2180d2a70197872ac049cf04a686d85f84facd0.tar.gz
linhes_pkgbuild-e2180d2a70197872ac049cf04a686d85f84facd0.tar.bz2
ivtv-utils: update
Diffstat (limited to 'abs/core/ivtv-utils')
-rw-r--r--abs/core/ivtv-utils/PKGBUILD63
1 files changed, 27 insertions, 36 deletions
diff --git a/abs/core/ivtv-utils/PKGBUILD b/abs/core/ivtv-utils/PKGBUILD
index 5b272b1..b92f274 100644
--- a/abs/core/ivtv-utils/PKGBUILD
+++ b/abs/core/ivtv-utils/PKGBUILD
@@ -1,46 +1,37 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
-# Contributor: Sasha Zbrozek <kleptophobiac@gmail.com>
-# Maintainer: Paul Mattal <paul@archlinux.org>
+# $Id: PKGBUILD 89079 2010-08-29 10:28:03Z thomas $
+# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: Andrea Scarpino <bash.lnx@gmail.com>
pkgname=ivtv-utils
-pkgver=1.0.3
-pkgrel=2
-_kernver=2.6.26-ARCH
-pkgdesc="Non-mainline kernel drivers and userspace utilities for Hauppauge PVR cards"
-arch=('i586' 'i686' 'x86_64')
+pkgver=1.4.1
+pkgrel=3
+pkgdesc="Userspace utilities for Hauppauge PVR cards"
+arch=('i686' 'x86_64')
license=('GPL')
url="http://ivtvdriver.org"
-source=("http://dl.ivtvdriver.org/ivtv/archive/1.0.x/ivtv-$pkgver.tar.gz" \
- 'http://dl.ivtvdriver.org/ivtv/firmware/ivtv-firmware.tar.gz' )
+source=(http://dl.ivtvdriver.org/ivtv/stable/${pkgname}-${pkgver}.tar.gz
+ http://dl.ivtvdriver.org/ivtv/firmware/ivtv-firmware.tar.gz)
depends=('gcc-libs')
-md5sums=('2c0e04a861cb7409ea82a2935b1e0050' 'b9a871f1c569025be9c48a77b3515faf')
-
+install=ivtv-utils.install
+md5sums=('3a4219d698262ca2b28e41f0f547b0a2'
+ 'b9a871f1c569025be9c48a77b3515faf')
+
build() {
- # SET UP
- cd $startdir/src/ivtv-$pkgver || return 1
-
- # don't call depmod here
- sed -i 's|/sbin/depmod -a||' driver/Makefile i2c-drivers/Makefile || return 1
-
- # install the utils in /usr/bin, not /usr/local/bin
- sed -i "s%PREFIX = /usr/local%PREFIX = /usr%g" utils/Makefile || return 1
-
- #cd to utils as that is all we need since ivtv is now in the kernel
- cd utils/
-
- # build
- make INSTALLDIR=/usr/bin || return 1
-
- # install
- make DESTDIR=$startdir/pkg install || return 1
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make || return 1
+}
- # remove the kernel modules in the utils package
- rm -rf $startdir/pkg/lib/modules || return 1
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" PREFIX=/usr install
- # install the firmware
- cd $startdir/src || return 1
- for file in v4l-cx2341x-dec.fw v4l-cx2341x-enc.fw v4l-cx2341x-init.mpg v4l-cx25840.fw v4l-pvrusb2-24xxx-01.fw v4l-pvrusb2-29xxx-01.fw
- do
- install -D -m 0644 $file $startdir/pkg/lib/firmware/$file || return 1
+ cd "${srcdir}"
+ for file in v4l-cx2341x-dec.fw v4l-cx2341x-enc.fw v4l-pvrusb2-24xxx-01.fw v4l-pvrusb2-29xxx-01.fw v4l-cx2341x-init.mpg; do
+ install -D -m644 $file "${pkgdir}/lib/firmware/$file"
done
+
+ # FS#15133 - files already provided by the kernel-headers package
+ rm -rf "${pkgdir}"/usr/include
+ # Resolve conflict with v4l-utils
+ rm -f "${pkgdir}"/usr/bin/v4l2-ctl
}