summaryrefslogtreecommitdiffstats
path: root/abs/core/kbd/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <James.meyer@operamail.com>2008-10-02 03:19:12 (GMT)
committerJames Meyer <James.meyer@operamail.com>2008-10-02 03:19:12 (GMT)
commit0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a (patch)
treec0aa2c0b53c317be87eacfcb77b63f53f1f415e7 /abs/core/kbd/PKGBUILD
downloadlinhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.zip
linhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.tar.gz
linhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.tar.bz2
initial import
Diffstat (limited to 'abs/core/kbd/PKGBUILD')
-rw-r--r--abs/core/kbd/PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/abs/core/kbd/PKGBUILD b/abs/core/kbd/PKGBUILD
new file mode 100644
index 0000000..bbc68f7
--- /dev/null
+++ b/abs/core/kbd/PKGBUILD
@@ -0,0 +1,34 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
+
+pkgname=kbd
+pkgver=1.14.1.20080309
+pkgrel=11
+pkgdesc="Keytable files and keyboard utilities"
+arch=('i686' 'x86_64')
+url="ftp://ftp.altlinux.org/pub/people/legion/kbd/"
+license=('GPL')
+groups=('base')
+depends=('glibc')
+source=(ftp://ftp.archlinux.org/other/$pkgname/$pkgname-$pkgver.tar.gz
+ #ftp://ftp.altlinux.org/pub/people/legion/kbd/${pkgname}-${pkgver}.tar.gz
+ rename-duplicates.patch)
+md5sums=('76e817f11c6ec80d9fc9f3f7ace79b4a'
+ 'bd2d9f88141a8e78baaa4982f1d1f6c5')
+
+build() {
+ cd ${startdir}/src
+ #cd ${startdir}/src/${pkgname}-${pkgver}
+ patch -Np1 -i rename-duplicates.patch || return 1
+
+ autoconf
+ ./configure --prefix=/usr --datadir=/usr/share/kbd --mandir=/usr/share/man
+ make KEYCODES_PROGS=yes RESIZECONS_PROGS=yes || return 1
+ make KEYCODES_PROGS=yes RESIZECONS_PROGS=yes DESTDIR=${startdir}/pkg install
+
+ # this is needed because initscripts call /bin/loadkeys
+ # remove this when next versions of kbd
+ # and initscripts with /usr/bin/loadkeys usage will be released
+ mkdir ${startdir}/pkg/bin
+ ln -s /usr/bin/loadkeys ${startdir}/pkg/bin/loadkeys
+}