summaryrefslogtreecommitdiffstats
path: root/abs/core/kbd
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-13 02:16:38 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-13 02:16:38 (GMT)
commit8087452d95b71aed84bc9868a29b97572b332173 (patch)
tree9f7b36e4e70636a89b42607af1f29a1c7f181e59 /abs/core/kbd
parentd08ffab52b311338c9e8c8ffd9180d748f820254 (diff)
downloadlinhes_pkgbuild-8087452d95b71aed84bc9868a29b97572b332173.zip
linhes_pkgbuild-8087452d95b71aed84bc9868a29b97572b332173.tar.gz
linhes_pkgbuild-8087452d95b71aed84bc9868a29b97572b332173.tar.bz2
kbd: up to latest
Diffstat (limited to 'abs/core/kbd')
-rw-r--r--abs/core/kbd/PKGBUILD38
1 files changed, 22 insertions, 16 deletions
diff --git a/abs/core/kbd/PKGBUILD b/abs/core/kbd/PKGBUILD
index bbc68f7..5f0bd44 100644
--- a/abs/core/kbd/PKGBUILD
+++ b/abs/core/kbd/PKGBUILD
@@ -1,34 +1,40 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# $Id: PKGBUILD 82650 2010-06-15 05:16:19Z allan $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
pkgname=kbd
-pkgver=1.14.1.20080309
-pkgrel=11
+pkgver=1.15.2
+pkgrel=1
pkgdesc="Keytable files and keyboard utilities"
arch=('i686' 'x86_64')
url="ftp://ftp.altlinux.org/pub/people/legion/kbd/"
license=('GPL')
-groups=('base')
depends=('glibc')
-source=(ftp://ftp.archlinux.org/other/$pkgname/$pkgname-$pkgver.tar.gz
- #ftp://ftp.altlinux.org/pub/people/legion/kbd/${pkgname}-${pkgver}.tar.gz
- rename-duplicates.patch)
-md5sums=('76e817f11c6ec80d9fc9f3f7ace79b4a'
- 'bd2d9f88141a8e78baaa4982f1d1f6c5')
+source=(ftp://ftp.altlinux.org/pub/people/legion/kbd/${pkgname}-${pkgver}.tar.gz)
+md5sums=('77d0b51454522bc6c170bbdc6e31202a')
build() {
- cd ${startdir}/src
- #cd ${startdir}/src/${pkgname}-${pkgver}
- patch -Np1 -i rename-duplicates.patch || return 1
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ # rename keymap files with the same names
+ # this is needed because when only name of keymap is specified
+ # loadkeys loads the first keymap it can find, which is bad (see FS#13837)
+ # this should be removed when upstream adopts the change
+ mv data/keymaps/i386/qwertz/cz{,-qwertz}.map
+ mv data/keymaps/i386/olpc/es{,-olpc}.map
+ mv data/keymaps/i386/olpc/pt{,-olpc}.map
+ mv data/keymaps/i386/dvorak/no{,-dvorak}.map
+ mv data/keymaps/i386/fgGIod/trf{,-fgGIod}.map
- autoconf
./configure --prefix=/usr --datadir=/usr/share/kbd --mandir=/usr/share/man
make KEYCODES_PROGS=yes RESIZECONS_PROGS=yes || return 1
- make KEYCODES_PROGS=yes RESIZECONS_PROGS=yes DESTDIR=${startdir}/pkg install
+}
+packages() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make KEYCODES_PROGS=yes RESIZECONS_PROGS=yes DESTDIR=${pkgdir} install
# this is needed because initscripts call /bin/loadkeys
# remove this when next versions of kbd
# and initscripts with /usr/bin/loadkeys usage will be released
- mkdir ${startdir}/pkg/bin
- ln -s /usr/bin/loadkeys ${startdir}/pkg/bin/loadkeys
+ mkdir ${pkgdir}/bin
+ ln -s /usr/bin/loadkeys ${pkgdir}/bin/loadkeys
}