summaryrefslogtreecommitdiffstats
path: root/abs/core/kbd
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 02:47:55 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 02:47:55 (GMT)
commit8b3b83efb54d263daef6ec7254dc8a3601fc2607 (patch)
treefeaa069656467871fc81b9f326413919c5b0a727 /abs/core/kbd
parent98af7523b7a65ad6ddff389ae42f173a159c614f (diff)
downloadlinhes_pkgbuild-8b3b83efb54d263daef6ec7254dc8a3601fc2607.zip
linhes_pkgbuild-8b3b83efb54d263daef6ec7254dc8a3601fc2607.tar.gz
linhes_pkgbuild-8b3b83efb54d263daef6ec7254dc8a3601fc2607.tar.bz2
kbd 1.15.3
Diffstat (limited to 'abs/core/kbd')
-rw-r--r--abs/core/kbd/PKGBUILD22
-rw-r--r--abs/core/kbd/fix-es.po.patch11
2 files changed, 21 insertions, 12 deletions
diff --git a/abs/core/kbd/PKGBUILD b/abs/core/kbd/PKGBUILD
index 03da2dd..cfb6b3d 100644
--- a/abs/core/kbd/PKGBUILD
+++ b/abs/core/kbd/PKGBUILD
@@ -1,20 +1,22 @@
-# $Id: PKGBUILD 82650 2010-06-15 05:16:19Z allan $
+# $Id: PKGBUILD 163716 2012-07-18 02:17:05Z dreisner $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
pkgname=kbd
-pkgver=1.15.2
+pkgver=1.15.3
pkgrel=3
pkgdesc="Keytable files and keyboard utilities"
arch=('i686' 'x86_64')
url="ftp://ftp.altlinux.org/pub/people/legion/kbd/"
license=('GPL')
depends=('glibc')
-source=(ftp://ftp.altlinux.org/pub/people/legion/kbd/${pkgname}-${pkgver}.tar.gz)
-md5sums=('77d0b51454522bc6c170bbdc6e31202a')
+source=(ftp://ftp.altlinux.org/pub/people/legion/kbd/${pkgname}-${pkgver}.tar.gz
+ fix-es.po.patch)
+md5sums=('8143e179a0f3c25646ce5085e8777200'
+ '4ded3edb50fb7a3277bae6a870cee812')
build() {
cd ${srcdir}/${pkgname}-${pkgver}
-
+ patch -Np1 -i ../fix-es.po.patch
# rename keymap files with the same names
# this is needed because when only name of keymap is specified
# loadkeys loads the first keymap it can find, which is bad (see FS#13837)
@@ -24,17 +26,13 @@ build() {
mv data/keymaps/i386/olpc/pt{,-olpc}.map
mv data/keymaps/i386/dvorak/no{,-dvorak}.map
mv data/keymaps/i386/fgGIod/trf{,-fgGIod}.map
+ mv data/keymaps/i386/colemak/{en-latin9,colemak}.map
./configure --prefix=/usr --datadir=/usr/share/kbd --mandir=/usr/share/man
- make KEYCODES_PROGS=yes RESIZECONS_PROGS=yes || return 1
+ make KEYCODES_PROGS=yes RESIZECONS_PROGS=yes
}
+
package() {
cd ${srcdir}/${pkgname}-${pkgver}
make KEYCODES_PROGS=yes RESIZECONS_PROGS=yes DESTDIR=${pkgdir} install
-
- # this is needed because initscripts call /bin/loadkeys
- # remove this when next versions of kbd
- # and initscripts with /usr/bin/loadkeys usage will be released
- mkdir ${pkgdir}/bin
- ln -s /usr/bin/loadkeys ${pkgdir}/bin/loadkeys
}
diff --git a/abs/core/kbd/fix-es.po.patch b/abs/core/kbd/fix-es.po.patch
new file mode 100644
index 0000000..578f0a7
--- /dev/null
+++ b/abs/core/kbd/fix-es.po.patch
@@ -0,0 +1,11 @@
+--- kbd-1.15.3/po/es.old 2011-05-14 23:12:49.000000000 +0200
++++ kbd-1.15.3/po/es.po 2011-05-15 21:07:02.120669404 +0200
+@@ -1363,7 +1363,7 @@
+ #: src/setfont.c:682
+ #, c-format
+ msgid "Saved %d-char %dx%d font file on %s\n"
+-msgstr "Se ha guardado el fichero de tipos %2$dx%3$d de %1$d caracteres en %s\n"
++msgstr "Se ha guardado el fichero de tipos %dx%d de %d caracteres en %s\n"
+
+ #: src/setkeycodes.c:21
+ #, c-format