summaryrefslogtreecommitdiffstats
path: root/abs/core/kernel26/PKGBUILD
diff options
context:
space:
mode:
authorCecil <knoppmyth@gmail.com>2011-07-17 20:40:13 (GMT)
committerCecil <knoppmyth@gmail.com>2011-07-17 20:40:13 (GMT)
commit99940cf1f228736b21713df64f993015ae0d586d (patch)
tree66681918a7fdaddfeced8d977c46c63cc6c4ba8b /abs/core/kernel26/PKGBUILD
parentde0161dec5775de3e8929570ae2fd19d2359df11 (diff)
downloadlinhes_pkgbuild-99940cf1f228736b21713df64f993015ae0d586d.zip
linhes_pkgbuild-99940cf1f228736b21713df64f993015ae0d586d.tar.gz
linhes_pkgbuild-99940cf1f228736b21713df64f993015ae0d586d.tar.bz2
kernel26:Bumped to 2.6.39.3 w/ ck2 and fbdecon.
Diffstat (limited to 'abs/core/kernel26/PKGBUILD')
-rw-r--r--abs/core/kernel26/PKGBUILD122
1 files changed, 64 insertions, 58 deletions
diff --git a/abs/core/kernel26/PKGBUILD b/abs/core/kernel26/PKGBUILD
index 92fc907..fd7f05d 100644
--- a/abs/core/kernel26/PKGBUILD
+++ b/abs/core/kernel26/PKGBUILD
@@ -1,44 +1,61 @@
-# $Id: PKGBUILD 105315 2011-01-07 18:08:55Z tpowa $
+# $Id: PKGBUILD 130991 2011-07-09 12:23:51Z thomas $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Maintainer: Thomas Baechler <thomas@archlinux.org>
+# Maintainer: Cecil Watson <knoppmyth@gmail.com>
pkgbase="kernel26"
pkgname=('kernel26' 'kernel26-headers' 'kernel26-docs') # Build stock -ARCH kernel
# pkgname=kernel26-custom # Build kernel with a different name
_kernelname=${pkgname#kernel26}
-_basekernel=2.6.37
-pkgver=${_basekernel}
-pkgrel=10
-_archver=6
-depends=('fbsplash')
+_basekernel=2.6.39
+pkgver=${_basekernel}.3
+pkgrel=3
+depends=('module-init-tools>=3.16')
makedepends=('xmlto' 'docbook-xsl')
-_patchname="patch-${pkgver}.${_archver}-1-ARCH"
+_archpatch=1
+_patchname="patch-${pkgver}-${_archpatch}-ARCH"
+_fbpatchname="fbcondecor-0.9.6-3.0-rc2.patch"
+_ckpatchversion=2
+_ckpatchname="patch-${_basekernel}-ck${_ckpatchversion}"
+_bfqpatch1="0001-block-prepare-I-O-context-code-for-BFQ-v2-for-2.6.39.patch"
+_bfqpath="http://algo.ing.unimo.it/people/paolo/disk_sched/patches/2.6.39"
+_bfqpatch2="0002-block-cgroups-kconfig-build-bits-for-BFQ-v2-2.6.39.patch"
+_bfqpatch3="0003-block-introduce-the-BFQ-v2-I-O-sched-for-2.6.39.patch"
#_patchname="patch-${pkgver}-1-ARCH"
-_fbpatchname="4200_fbcondecor-0.9.6.patch"
-_ckpatchname="patch-2.6.37-ck2"
-_lhpatchname="lh.patch"
arch=(i686 x86_64)
license=('GPL2')
url="http://www.kernel.org"
+options=(!strip)
source=(ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-$_basekernel.tar.bz2
ftp://ftp.archlinux.org/other/kernel26/${_patchname}.bz2
-# http://kernel.org/pub/linux/kernel/people/ck/patches/2.6/2.6.37/2.6.37-ck1/patch-2.6.37-ck1.bz2
- http://ompldr.org/vN2d6cg/patch-2.6.37-ck2.bz2
- ftp://ftp.knoppmyth.net/R6/sources/sk98lin_v10.88.3.3_K2.6.37.patch
- 4200_fbcondecor-0.9.6.patch
+ http://dev.gentoo.org/~spock/projects/fbcondecor/archive/${_fbpatchname}
+ http://www.kernel.org/pub/linux/kernel/people/ck/patches/2.6/${_basekernel}/${_basekernel}-ck${_ckpatchversion}/${_ckpatchname}.bz2
+ # Let's leave these out for now...
+ #${_bfqpath}/${_bfqpatch1}
+ #${_bfqpath}/${_bfqpatch2}
+ #${_bfqpath}/${_bfqpatch3}
+ fix_ck2.patch
+ logo_linux_clut224.ppm
+ lh.patch
# the main kernel config files
- config config.x86_64 lh.patch.bz2
+ config config.x86_64
# standard config files for mkinitcpio ramdisk
- kernel26.preset 2.6.37.1-fix-no-more-unsigned.patch)
+ kernel26.preset)
+
build() {
+ patch -N -i ${srcdir}/fix_ck2.patch
cd ${srcdir}/linux-$_basekernel
# Add -ARCH patches
# See http://projects.archlinux.org/linux-2.6-ARCH.git/
patch -Np1 -i ${srcdir}/${_patchname}
+ # Add -LinHES patches
patch -Np1 -i ${srcdir}/${_fbpatchname}
patch -Np1 -i ${srcdir}/${_ckpatchname}
- patch -Np1 -i ${srcdir}/${_lhpatchname}
- patch -Np1 -i ${srcdir}/2.6.37.1-fix-no-more-unsigned.patch
- patch -Np1 -i ${srcdir}/sk98lin_v10.88.3.3_K2.6.37.patch
+ patch -Np1 -i ${srcdir}/lh.patch
+ # Let's leave these out for now...
+ #patch -Np1 -i ${srcdir}/${_bfqpatch1}
+ #patch -Np1 -i ${srcdir}/${_bfqpatch2}
+ #patch -Np1 -i ${srcdir}/${_bfqpatch3}
+ install -m644 ${srcdir}/logo_linux_clut224.ppm drivers/video/logo/
if [ "$CARCH" = "x86_64" ]; then
cat ../config.x86_64 >./.config
@@ -72,7 +89,7 @@ package_kernel26() {
pkgdesc="The Linux Kernel and modules"
groups=('base')
backup=(etc/mkinitcpio.d/${pkgname}.preset)
- depends=('coreutils' 'linux-firmware' 'module-init-tools' 'mkinitcpio>=0.5.20')
+ depends=('coreutils' 'linux-firmware' 'module-init-tools>=3.12-2' 'mkinitcpio>=0.6.8-2')
# pwc, ieee80211 and hostap-driver26 modules are included in kernel26 now
# nforce package support was abandoned by nvidia, kernel modules should cover everything now.
# kernel24 support is dropped since glibc24
@@ -80,7 +97,7 @@ package_kernel26() {
'alsa-driver' 'ieee80211' 'hostap-driver26'
'pwc' 'nforce' 'squashfs' 'unionfs' 'ivtv'
'zd1211' 'kvm-modules' 'iwlwifi' 'rt2x00-cvs'
- 'gspcav1' 'atl2' 'wlan-ng26' 'rt2500' 'nouveau-drm' 'lirc')
+ 'gspcav1' 'atl2' 'wlan-ng26' 'rt2500' 'nouveau-drm')
install=kernel26.install
optdepends=('crda: to set the correct wireless channels of your country')
@@ -113,6 +130,8 @@ package_kernel26() {
rm -f ${pkgdir}/lib/modules/${_kernver}/{source,build}
# remove the firmware
rm -rf ${pkgdir}/lib/firmware
+ # gzip -9 all modules to safe 100MB of space
+ find "$pkgdir" -name '*.ko' -exec gzip -9 {} \;
}
package_kernel26-headers() {
@@ -129,7 +148,8 @@ package_kernel26-headers() {
${pkgdir}/usr/src/linux-${_kernver}/.config
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/include
- for i in acpi asm-generic config generated linux math-emu media net pcmcia scsi sound trace video xen; do
+ for i in acpi asm-generic config crypto drm generated linux math-emu \
+ media net pcmcia scsi sound trace video xen; do
cp -a include/$i ${pkgdir}/usr/src/linux-${_kernver}/include/
done
@@ -155,7 +175,7 @@ package_kernel26-headers() {
# add headers for lirc package
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/video
cp drivers/media/video/*.h ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/video/
- for i in bt8xx cpia2 cx25840 cx88 em28xx et61x251 pwc saa7134 sn9c102 usbvideo; do
+ for i in bt8xx cpia2 cx25840 cx88 em28xx et61x251 pwc saa7134 sn9c102; do
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/video/$i
cp -a drivers/media/video/$i/*.h ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/video/$i
done
@@ -200,18 +220,6 @@ package_kernel26-headers() {
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/fs/xfs
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/mm
cp fs/xfs/xfs_sb.h ${pkgdir}/usr/src/linux-${_kernver}/fs/xfs/xfs_sb.h
- # add headers vor virtualbox
- # in reference to:
- # http://bugs.archlinux.org/task/14568
- cp -a include/drm $pkgdir/usr/src/linux-${_kernver}/include/
- # add headers for broadcom wl
- # in reference to:
- # http://bugs.archlinux.org/task/14568
- cp -a include/trace $pkgdir/usr/src/linux-${_kernver}/include/
- # add headers for crypto modules
- # in reference to:
- # http://bugs.archlinux.org/task/22081
- cp -a include/crypto $pkgdir/usr/src/linux-${_kernver}/include/
# copy in Kconfig files
for i in `find . -name "Kconfig*"`; do
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/`echo $i | sed 's|/Kconfig.*||'`
@@ -220,23 +228,21 @@ package_kernel26-headers() {
chown -R root.root ${pkgdir}/usr/src/linux-${_kernver}
find ${pkgdir}/usr/src/linux-${_kernver} -type d -exec chmod 755 {} \;
+ # strip scripts directory
+ find ${pkgdir}/usr/src/linux-${_kernver}/scripts -type f -perm -u+w 2>/dev/null | while read binary ; do
+ case "$(file -bi "$binary")" in
+ *application/x-sharedlib*) # Libraries (.so)
+ /usr/bin/strip $STRIP_SHARED "$binary";;
+ *application/x-archive*) # Libraries (.a)
+ /usr/bin/strip $STRIP_STATIC "$binary";;
+ *application/x-executable*) # Binaries
+ /usr/bin/strip $STRIP_BINARIES "$binary";;
+ esac
+ done
# remove unneeded architectures
rm -rf ${pkgdir}/usr/src/linux-${_kernver}/arch/{alpha,arm,arm26,avr32,blackfin,cris,frv,h8300,ia64,m32r,m68k,m68knommu,mips,microblaze,mn10300,parisc,powerpc,ppc,s390,sh,sh64,sparc,sparc64,um,v850,xtensa}
}
-#package_kernel26-manpages() {
-#pkgdesc="Kernel hackers manual - Section 9 manpages that comes with the Linux kernel."
-
-#cd ${srcdir}/linux-$_basekernel
-#make mandocs || return 1
-
-#install -d ${pkgdir}/usr/share/man/man9/
-#install ${srcdir}/linux-${_basekernel}/Documentation/DocBook/man/*.9.gz \
-#${pkgdir}/usr/share/man/man9/
-
-#find ${pkgdir} -type f -exec chmod 644 {} \;
-#}
-
package_kernel26-docs() {
pkgdesc="Kernel hackers manual - HTML documentation that comes with the Linux kernel."
@@ -248,13 +254,13 @@ find $pkgdir -type d -exec chmod 755 {} \;
# remove a file already in kernel26 package
rm -f $pkgdir/usr/src/linux-$_kernver/Documentation/DocBook/Makefile
}
-md5sums=('c8ee37b4fdccdb651e0603d35350b434'
- '2a7c0e9a9cd6bea46aa9b62f246439e2'
- '4961070c8deebee3506df40083e84d3a'
- 'ae26934abb7168d0f928fb91eca12d92'
- 'db9a807e03b7e8cfbc389089b006c7a7'
- '8ef406c78b36e218d1152842e568f1f8'
- '58990501d493d3e516a9ff58b3e0e0e7'
- 'c5793a80c59be4f0b54bc3b2a49e14c7'
- '25584700a0a679542929c4bed31433b6'
- 'c99a13ccbba56e3516ca8907c211a27b')
+md5sums=('1aab7a741abe08d42e8eccf20de61e05'
+ 'b23d7def30e57242cfe088f4d8ca8baa'
+ '865216ca79342c67dc3aa43c18245694'
+ 'ffa0384d5a243d17ca47c9bd0e2217e7'
+ '0ab7720f0d80d142a280cfe35b9a8730'
+ '57d5f9aedb2e52ef76bab244cd2645cf'
+ '23f6df0ea11870513c7b6a02d9e6ed07'
+ '1f2b4ac021459a2ad87e3e30c22b7d22'
+ '8be1f60e54eb505b7e67d39fd2233103'
+ '25584700a0a679542929c4bed31433b6')