summaryrefslogtreecommitdiffstats
path: root/abs/core/kernel26/PKGBUILD
diff options
context:
space:
mode:
authorCecil <knoppmyth@gmail.com>2011-08-17 04:38:33 (GMT)
committerCecil <knoppmyth@gmail.com>2011-08-17 04:38:33 (GMT)
commit9c123aaf65a69c79605c62fa4d1064def7019bfd (patch)
treeea1bf0042474096337be34010e3057b8d1f24597 /abs/core/kernel26/PKGBUILD
parentd7b0ad9151942bf042e6761b6671fb72078e42e0 (diff)
downloadlinhes_pkgbuild-9c123aaf65a69c79605c62fa4d1064def7019bfd.zip
linhes_pkgbuild-9c123aaf65a69c79605c62fa4d1064def7019bfd.tar.gz
linhes_pkgbuild-9c123aaf65a69c79605c62fa4d1064def7019bfd.tar.bz2
kernel26:Bumped to 2.6.39.4. Removed ck patchset.
Diffstat (limited to 'abs/core/kernel26/PKGBUILD')
-rw-r--r--abs/core/kernel26/PKGBUILD38
1 files changed, 20 insertions, 18 deletions
diff --git a/abs/core/kernel26/PKGBUILD b/abs/core/kernel26/PKGBUILD
index 3340474..1b0efcd 100644
--- a/abs/core/kernel26/PKGBUILD
+++ b/abs/core/kernel26/PKGBUILD
@@ -5,18 +5,19 @@ pkgname=('kernel26' 'kernel26-headers' 'kernel26-docs') # Build stock -ARCH kern
# pkgname=kernel26-custom # Build kernel with a different name
_kernelname=${pkgname#kernel26}
_basekernel=2.6.39
-pkgver=${_basekernel}.3
-pkgrel=9
+pkgver=${_basekernel}.4
+pkgrel=2
makedepends=('xmlto' 'docbook-xsl')
_archpatch=1
-_patchname="patch-${pkgver}-${_archpatch}-ARCH"
+_patchname="patch-${_basekernel}-1-ARCH"
_fbpatchname="fbcondecor-0.9.6-3.0-rc2.patch"
-_ckpatchversion=2
-_ckpatchname="patch-${_basekernel}-ck${_ckpatchversion}"
-_bfqpatch1="0001-block-prepare-I-O-context-code-for-BFQ-v2-for-2.6.39.patch"
-_bfqpath="http://algo.ing.unimo.it/people/paolo/disk_sched/patches/2.6.39"
-_bfqpatch2="0002-block-cgroups-kconfig-build-bits-for-BFQ-v2-2.6.39.patch"
-_bfqpatch3="0003-block-introduce-the-BFQ-v2-I-O-sched-for-2.6.39.patch"
+_kernelpatch="patch-${pkgver}"
+#_ckpatchversion=2
+#_ckpatchname="patch-${_basekernel}-ck${_ckpatchversion}"
+#_bfqpatch1="0001-block-prepare-I-O-context-code-for-BFQ-v2-for-2.6.39.patch"
+#_bfqpath="http://algo.ing.unimo.it/people/paolo/disk_sched/patches/2.6.39"
+#_bfqpatch2="0002-block-cgroups-kconfig-build-bits-for-BFQ-v2-2.6.39.patch"
+#_bfqpatch3="0003-block-introduce-the-BFQ-v2-I-O-sched-for-2.6.39.patch"
_aufspath="http://chakra-project.org/sources/kernel26/patches/39/aufs2.1/"
_aufs1="aufs2-base-39-20110704.patch"
_aufs2="aufs2-kbuild-39-20110704.patch"
@@ -29,14 +30,15 @@ license=('GPL2')
url="http://www.kernel.org"
options=(!strip)
source=(ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-$_basekernel.tar.bz2
+ http://www.kernel.org/pub/linux/kernel/v2.6/$_kernelpatch.bz2
ftp://ftp.archlinux.org/other/kernel26/${_patchname}.bz2
http://dev.gentoo.org/~spock/projects/fbcondecor/archive/${_fbpatchname}
- http://www.kernel.org/pub/linux/kernel/people/ck/patches/2.6/${_basekernel}/${_basekernel}-ck${_ckpatchversion}/${_ckpatchname}.bz2
+ #http://www.kernel.org/pub/linux/kernel/people/ck/patches/2.6/${_basekernel}/${_basekernel}-ck${_ckpatchversion}/${_ckpatchname}.bz2
# Let's leave these out for now...
#${_bfqpath}/${_bfqpatch1}
#${_bfqpath}/${_bfqpatch2}
#${_bfqpath}/${_bfqpatch3}
- fix_ck2.patch
+ #fix_ck2.patch
logo_linux_clut224.ppm
lh.patch
${_aufspath}/${_aufs1}
@@ -49,14 +51,15 @@ source=(ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-$_basekernel.tar.bz2
kernel26.preset)
build() {
- patch -N -i ${srcdir}/fix_ck2.patch
+ # patch -N -i ${srcdir}/fix_ck2.patch
cd ${srcdir}/linux-$_basekernel
# Add -ARCH patches
# See http://projects.archlinux.org/linux-2.6-ARCH.git/
+ patch -Np1 -i ${srcdir}/${_kernelpatch}
patch -Np1 -i ${srcdir}/${_patchname}
# Add -LinHES patches
patch -Np1 -i ${srcdir}/${_fbpatchname}
- patch -Np1 -i ${srcdir}/${_ckpatchname}
+ # patch -Np1 -i ${srcdir}/${_ckpatchname}
patch -Np1 -i ${srcdir}/lh.patch
patch -Np1 -i ${srcdir}/${_aufs1}
patch -Np1 -i ${srcdir}/${_aufs2}
@@ -268,16 +271,15 @@ find $pkgdir -type d -exec chmod 755 {} \;
rm -f $pkgdir/usr/src/linux-$_kernver/Documentation/DocBook/Makefile
}
md5sums=('1aab7a741abe08d42e8eccf20de61e05'
- 'b23d7def30e57242cfe088f4d8ca8baa'
+ 'ff5eb7323c054a128d2922bde3297ed5'
+ '25bb870bed3865d3771b5e40d6dbfd50'
'865216ca79342c67dc3aa43c18245694'
- 'ffa0384d5a243d17ca47c9bd0e2217e7'
- '0ab7720f0d80d142a280cfe35b9a8730'
'57d5f9aedb2e52ef76bab244cd2645cf'
- '23f6df0ea11870513c7b6a02d9e6ed07'
+ '577f8e94d2525c7e6933f8a14dcda984'
'964034dd2716e930b72e59a7231471db'
'351469fd75d3fa848398728360c6ffa4'
'3b4a1df8e1f584446918f76cfca66e9b'
'93d83faea1144a5dbd6df0f42148fb7f'
- 'c4c29a94610354288183ad0ee23e7ec3'
+ '7b90f6fcd433ddba40337b1e1158b789'
'8be1f60e54eb505b7e67d39fd2233103'
'25584700a0a679542929c4bed31433b6')