summaryrefslogtreecommitdiffstats
path: root/abs/core/keylaunch/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2011-12-07 19:22:18 (GMT)
committerJames Meyer <james.meyer@operamail.com>2011-12-07 19:22:18 (GMT)
commita26d28c380288d7c70a19bee81314a934df7c788 (patch)
tree51283a69de5373e066666c4c82fc5b87b4ec6fa4 /abs/core/keylaunch/PKGBUILD
parent31241d8ab04062f0fae61441cbd6c8de3dc1b660 (diff)
downloadlinhes_pkgbuild-a26d28c380288d7c70a19bee81314a934df7c788.zip
linhes_pkgbuild-a26d28c380288d7c70a19bee81314a934df7c788.tar.gz
linhes_pkgbuild-a26d28c380288d7c70a19bee81314a934df7c788.tar.bz2
keylaunch: first build. Used to bind actions to hot keys. This is needed to keep the linhes keybindings when not using fluxbox
Diffstat (limited to 'abs/core/keylaunch/PKGBUILD')
-rw-r--r--abs/core/keylaunch/PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/abs/core/keylaunch/PKGBUILD b/abs/core/keylaunch/PKGBUILD
new file mode 100644
index 0000000..5ae239a
--- /dev/null
+++ b/abs/core/keylaunch/PKGBUILD
@@ -0,0 +1,19 @@
+pkgname=keylaunch
+pkgver=1.3.9
+pkgrel=2
+arch=('i686')
+pkgdesc="KeyLaunch is a small utility for binding commands to a hot key. "
+url="http://www.oroborus.org/"
+depends=(glibc)
+source=(http://ftp.debian.org/debian/pool/main/k/keylaunch/keylaunch_1.3.9.tar.gz example_rc)
+install=keylaunch.install
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ ./configure --prefix=/usr
+ make
+ make DESTDIR=$startdir/pkg install
+ install -D -m0755 ../example_rc $startdir/pkg/etc/keylaunchrc
+}
+md5sums=('710f68a3e7026b4139cc94ea790576c3'
+ '652de5f0db90f32c664c9698f865e07a')