summaryrefslogtreecommitdiffstats
path: root/abs/core/keylaunch
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2013-10-16 20:41:16 (GMT)
committerBritney Fransen <brfransen@gmail.com>2013-10-16 20:41:16 (GMT)
commit4fb36a904c3818185105d2fe09adc512c46285c7 (patch)
tree56c1deb162824e4695133a955a6022e90282dd79 /abs/core/keylaunch
parent2648e999d277eac5c3d331a3609bcc73fafbea71 (diff)
parent36f4b0be52fddbd5f491da90475e69c25bf6903f (diff)
downloadlinhes_pkgbuild-4fb36a904c3818185105d2fe09adc512c46285c7.zip
linhes_pkgbuild-4fb36a904c3818185105d2fe09adc512c46285c7.tar.gz
linhes_pkgbuild-4fb36a904c3818185105d2fe09adc512c46285c7.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/core/keylaunch')
-rw-r--r--abs/core/keylaunch/PKGBUILD13
-rw-r--r--abs/core/keylaunch/example_rc7
-rw-r--r--abs/core/keylaunch/keylaunch.install13
3 files changed, 18 insertions, 15 deletions
diff --git a/abs/core/keylaunch/PKGBUILD b/abs/core/keylaunch/PKGBUILD
index 67b8d77..5d77379 100644
--- a/abs/core/keylaunch/PKGBUILD
+++ b/abs/core/keylaunch/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=keylaunch
pkgver=1.3.9
-pkgrel=6
+pkgrel=9
arch=('i686' 'x86_64')
pkgdesc="KeyLaunch is a small utility for binding commands to a hot key. "
url="http://www.oroborus.org/"
@@ -9,11 +9,14 @@ source=(http://ftp.debian.org/debian/pool/main/k/keylaunch/keylaunch_1.3.9.tar.g
install=keylaunch.install
build() {
- cd $startdir/src/$pkgname-$pkgver
+ cd $srcdir/$pkgname-$pkgver
./configure --prefix=/usr
make
- make DESTDIR=$startdir/pkg install
- install -D -m0755 ../example_rc $startdir/pkg/etc/keylaunchrc
+ make DESTDIR=$pkgdir install
+}
+
+package() {
+ install -D -m0755 $srcdir/example_rc $pkgdir/etc/keylaunchrc
}
md5sums=('710f68a3e7026b4139cc94ea790576c3'
- '98d341f2fb87ce4fbbecafbdc776b2a7')
+ '1141e182e2accb02c17548189bead4dc')
diff --git a/abs/core/keylaunch/example_rc b/abs/core/keylaunch/example_rc
index 5dd0f59..8d409df 100644
--- a/abs/core/keylaunch/example_rc
+++ b/abs/core/keylaunch/example_rc
@@ -15,13 +15,10 @@ key=..*u:/usr/LH/bin/unclutter-toggle.sh
key=.**u:/usr/LH/bin/unclutter-toggle.sh
key=..*h:/usr/MythVantage/bin/mythinstall -H
key=..*m:/usr/LH/bin/mythfrontend-start
+key=..*f:sudo sv restart frontend
+key=..*w:/usr/bin/google-chrome --no-first-run||msg_client.py --msg "Chrome is not installed."
-
-#key=..*1:sudo sv start mythbackend
-#key=..*2:sudo sv stop mythbackend
-#key=..*3:sudo sv restart mythbackend
-
key=..*1:/usr/LH/bin/lh_backend_control.sh start
key=..*2:/usr/LH/bin/lh_backend_control.sh stop
key=..*3:/usr/LH/bin/lh_backend_control.sh restart
diff --git a/abs/core/keylaunch/keylaunch.install b/abs/core/keylaunch/keylaunch.install
index faa176b..87f8fde 100644
--- a/abs/core/keylaunch/keylaunch.install
+++ b/abs/core/keylaunch/keylaunch.install
@@ -9,13 +9,16 @@ pre_install() {
# arg 1: the new package version
post_install() {
MHOME=`cat /etc/passwd | grep "mythtv" | cut -d":" -f6`
- if [ ! -e $MHOME/.keylaunchrc ]
+ if [ ! -z $MHOME ]
then
- echo "setting symlink for keylaunch"
- ln -s /etc/keylaunchrc $MHOME/.keylaunchrc
+ if [ ! -e $MHOME/.keylaunchrc ]
+ then
+ echo "setting symlink for keylaunch"
+ ln -s /etc/keylaunchrc $MHOME/.keylaunchrc
+ fi
+ echo "updating .keylaunchrc to run mythtv-setup as user"
+ sed -i 's/key=..*s:sudo\ \/usr\/bin\/mythtv-setup/key=..*s:\/usr\/bin\/mythtv-setup/g' $MHOME/.keylaunchrc
fi
- echo "updating .keylaunchrc to run mythtv-setup as user"
- sed -i 's/key=..*s:sudo\ \/usr\/bin\/mythtv-setup/key=..*s:\/usr\/bin\/mythtv-setup/g' $MHOME/.keylaunchrc
}
# arg 1: the new package version