summaryrefslogtreecommitdiffstats
path: root/abs/core/keylaunch
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2013-09-18 13:44:03 (GMT)
committerBritney Fransen <brfransen@gmail.com>2013-09-18 13:44:03 (GMT)
commitf1d637f88d67fb598ae3c0af7d44a3f2083452fa (patch)
tree47ab7cb8751d1fde3bf5564af2ac6bdfcfa6b080 /abs/core/keylaunch
parent1e9f1068d75226eea306c999a85051baf9a832c0 (diff)
downloadlinhes_pkgbuild-f1d637f88d67fb598ae3c0af7d44a3f2083452fa.zip
linhes_pkgbuild-f1d637f88d67fb598ae3c0af7d44a3f2083452fa.tar.gz
linhes_pkgbuild-f1d637f88d67fb598ae3c0af7d44a3f2083452fa.tar.bz2
keylaunch: add keybindings for chrome and restarting frontend window manager
Diffstat (limited to 'abs/core/keylaunch')
-rw-r--r--abs/core/keylaunch/PKGBUILD13
-rw-r--r--abs/core/keylaunch/example_rc7
2 files changed, 10 insertions, 10 deletions
diff --git a/abs/core/keylaunch/PKGBUILD b/abs/core/keylaunch/PKGBUILD
index 67b8d77..d869044 100644
--- a/abs/core/keylaunch/PKGBUILD
+++ b/abs/core/keylaunch/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=keylaunch
pkgver=1.3.9
-pkgrel=6
+pkgrel=7
arch=('i686' 'x86_64')
pkgdesc="KeyLaunch is a small utility for binding commands to a hot key. "
url="http://www.oroborus.org/"
@@ -9,11 +9,14 @@ source=(http://ftp.debian.org/debian/pool/main/k/keylaunch/keylaunch_1.3.9.tar.g
install=keylaunch.install
build() {
- cd $startdir/src/$pkgname-$pkgver
+ cd $srcdir/$pkgname-$pkgver
./configure --prefix=/usr
make
- make DESTDIR=$startdir/pkg install
- install -D -m0755 ../example_rc $startdir/pkg/etc/keylaunchrc
+ make DESTDIR=$pkgdir install
+}
+
+package() {
+ install -D -m0755 $srcdir/example_rc $pkgdir/etc/keylaunchrc
}
md5sums=('710f68a3e7026b4139cc94ea790576c3'
- '98d341f2fb87ce4fbbecafbdc776b2a7')
+ '01d31c5c748f7a2802d7b0e7aa07a678')
diff --git a/abs/core/keylaunch/example_rc b/abs/core/keylaunch/example_rc
index 5dd0f59..284a4a1 100644
--- a/abs/core/keylaunch/example_rc
+++ b/abs/core/keylaunch/example_rc
@@ -15,13 +15,10 @@ key=..*u:/usr/LH/bin/unclutter-toggle.sh
key=.**u:/usr/LH/bin/unclutter-toggle.sh
key=..*h:/usr/MythVantage/bin/mythinstall -H
key=..*m:/usr/LH/bin/mythfrontend-start
+key=.**f:sudo sv restart frontend
+key=..*w:/usr/bin/google-chrome
-
-#key=..*1:sudo sv start mythbackend
-#key=..*2:sudo sv stop mythbackend
-#key=..*3:sudo sv restart mythbackend
-
key=..*1:/usr/LH/bin/lh_backend_control.sh start
key=..*2:/usr/LH/bin/lh_backend_control.sh stop
key=..*3:/usr/LH/bin/lh_backend_control.sh restart