summaryrefslogtreecommitdiffstats
path: root/abs/core/lame
diff options
context:
space:
mode:
authorJames Meyer <James.meyer@operamail.com>2008-10-02 03:19:12 (GMT)
committerJames Meyer <James.meyer@operamail.com>2008-10-02 03:19:12 (GMT)
commit0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a (patch)
treec0aa2c0b53c317be87eacfcb77b63f53f1f415e7 /abs/core/lame
downloadlinhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.zip
linhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.tar.gz
linhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.tar.bz2
initial import
Diffstat (limited to 'abs/core/lame')
-rw-r--r--abs/core/lame/PKGBUILD23
-rw-r--r--abs/core/lame/shared-frontend.patch23
2 files changed, 46 insertions, 0 deletions
diff --git a/abs/core/lame/PKGBUILD b/abs/core/lame/PKGBUILD
new file mode 100644
index 0000000..7be3e87
--- /dev/null
+++ b/abs/core/lame/PKGBUILD
@@ -0,0 +1,23 @@
+# $Id: PKGBUILD 4167 2008-07-04 18:00:32Z hugo $
+# Maintainer: Hugo Doria <hugo@archlinux.org>
+# Contributor: Hugo Doria <hugo@archlinux.org>
+pkgname=lame
+pkgver=3.98
+pkgrel=1
+pkgdesc="An MP3 encoder and graphical frame analyzer"
+arch=('i686' 'x86_64')
+url="http://lame.sourceforge.net/"
+depends=('ncurses')
+makedepends=('nasm')
+license=('LGPL')
+source=(http://downloads.sourceforge.net/sourceforge/lame/lame-398.tar.gz \
+ shared-frontend.patch)
+md5sums=('f44b9f8e1b5d8835d0a77f9cc9cedd1c' 'e7fc0e6d82dd35a01411be96fc8effab')
+
+build() {
+ cd $startdir/src/$pkgname-398
+ ./configure --prefix=/usr --enable-nasm --enable-shared
+ make || return 1
+ make DESTDIR=$startdir/pkg install
+ find $startdir/pkg -name '*.la' -exec rm {} \;
+}
diff --git a/abs/core/lame/shared-frontend.patch b/abs/core/lame/shared-frontend.patch
new file mode 100644
index 0000000..e5ae0a9
--- /dev/null
+++ b/abs/core/lame/shared-frontend.patch
@@ -0,0 +1,23 @@
+--- lame-3.96.1.orig/frontend/Makefile.am 2004-01-21 01:41:36.000000000 -0800
++++ lame-3.96.1/frontend/Makefile.am 2004-10-03 16:39:12.415901779 -0700
+@@ -50,7 +50,7 @@
+ endif
+
+ CFLAGS = @CFLAGS@ @GTK_CFLAGS@ @FRONTEND_CFLAGS@
+-LDFLAGS = @LDFLAGS@ @FRONTEND_LDFLAGS@ -static
++LDFLAGS = @LDFLAGS@ @FRONTEND_LDFLAGS@
+
+ INCLUDES = -I$(top_srcdir)/libmp3lame -I$(top_srcdir)/include -I$(top_builddir)
+
+diff -Naur lame-3.96.1.orig/frontend/Makefile.in lame-3.96.1/frontend/Makefile.in
+--- lame-3.96.1.orig/frontend/Makefile.in 2004-01-21 05:50:29.000000000 -0800
++++ lame-3.96.1/frontend/Makefile.in 2004-10-03 16:39:19.711701553 -0700
+@@ -91,7 +91,7 @@
+ $(top_builddir)/libmp3lame/libmp3lame.la \
+ @FRONTEND_LDADD@
+
+-LDFLAGS = @LDFLAGS@ @FRONTEND_LDFLAGS@ -static
++LDFLAGS = @LDFLAGS@ @FRONTEND_LDFLAGS@
+ LIBOBJS = @LIBOBJS@
+ LIBS = @LIBS@
+ LIBTOOL = @LIBTOOL@