summaryrefslogtreecommitdiffstats
path: root/abs/core/ldns
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 02:51:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 02:51:09 (GMT)
commita4fe65f8d512461e8c3bdc462380a43705f9b7e3 (patch)
tree53c985287595f89bff47ce2aaaba4fc95c2cfe8a /abs/core/ldns
parent992aad1991a7cd65284ebbff56d0a45e74a513e9 (diff)
downloadlinhes_pkgbuild-a4fe65f8d512461e8c3bdc462380a43705f9b7e3.zip
linhes_pkgbuild-a4fe65f8d512461e8c3bdc462380a43705f9b7e3.tar.gz
linhes_pkgbuild-a4fe65f8d512461e8c3bdc462380a43705f9b7e3.tar.bz2
ldns 1.6.13
-new
Diffstat (limited to 'abs/core/ldns')
-rw-r--r--abs/core/ldns/PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/abs/core/ldns/PKGBUILD b/abs/core/ldns/PKGBUILD
new file mode 100644
index 0000000..e936b0b
--- /dev/null
+++ b/abs/core/ldns/PKGBUILD
@@ -0,0 +1,41 @@
+# $Id: PKGBUILD 159413 2012-05-23 22:28:28Z bisson $
+# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+# Contributor: mathieui <mathieui@mathieui.net>
+# Contributor: jiribb <jiribb@gmail.com>
+
+pkgname=ldns
+pkgver=1.6.13
+pkgrel=1
+pkgdesc='Fast DNS library supporting recent RFCs'
+url='http://www.nlnetlabs.nl/projects/ldns/'
+license=('custom:BSD')
+arch=('i686' 'x86_64')
+options=('!libtool')
+depends=('openssl' 'dnssec-anchors')
+optdepends=('libpcap: ldns-dpa tool')
+makedepends=('libpcap')
+source=("http://www.nlnetlabs.nl/downloads/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+sha1sums=('859f633d10b763f06b602e2113828cbbd964c7eb')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --enable-static=no \
+ --disable-rpath \
+ --with-drill \
+ --with-examples \
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
+
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}