summaryrefslogtreecommitdiffstats
path: root/abs/core/libart-lgpl
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 14:41:33 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 14:41:33 (GMT)
commit12768e4e0bee45ec97463b6315d5260ca15ddd50 (patch)
tree825cc19fc45f52fc0af1221f41192fb90c1d0c01 /abs/core/libart-lgpl
parent83bd81d79b0ba55ab6e61d96136867805af0cf93 (diff)
downloadlinhes_pkgbuild-12768e4e0bee45ec97463b6315d5260ca15ddd50.zip
linhes_pkgbuild-12768e4e0bee45ec97463b6315d5260ca15ddd50.tar.gz
linhes_pkgbuild-12768e4e0bee45ec97463b6315d5260ca15ddd50.tar.bz2
libart-gpl 2.3.21
Diffstat (limited to 'abs/core/libart-lgpl')
-rw-r--r--abs/core/libart-lgpl/PKGBUILD20
-rw-r--r--abs/core/libart-lgpl/art_misc.h-cplusplus.patch35
2 files changed, 12 insertions, 43 deletions
diff --git a/abs/core/libart-lgpl/PKGBUILD b/abs/core/libart-lgpl/PKGBUILD
index 92d659f..de97c2b 100644
--- a/abs/core/libart-lgpl/PKGBUILD
+++ b/abs/core/libart-lgpl/PKGBUILD
@@ -1,20 +1,24 @@
-# $Id$
+# $Id: PKGBUILD 150419 2012-02-17 12:52:28Z allan $
# Maintainer: Jan de Groot <jgc@archlinux.org>
+
pkgname=libart-lgpl
pkgver=2.3.21
-pkgrel=1
+pkgrel=2
pkgdesc="A library for high-performance 2D graphics"
url="http://www.levien.com/libart/"
-arch=(i686 x86_64)
+arch=('i686' 'x86_64')
license=('LGPL')
-depends=('glibc')
source=(http://ftp.gnome.org/pub/GNOME/sources/libart_lgpl/2.3/libart_lgpl-${pkgver}.tar.bz2)
options=('!libtool')
sha256sums=('fdc11e74c10fc9ffe4188537e2b370c0abacca7d89021d4d303afdf7fd7476fa')
build() {
- cd ${startdir}/src/libart_lgpl-${pkgver}
- ./configure --prefix=/usr || return 1
- make || return 1
- make DESTDIR=${startdir}/pkg install || return 1
+ cd "${srcdir}/libart_lgpl-${pkgver}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/libart_lgpl-${pkgver}"
+ make DESTDIR="${pkgdir}" install
}
diff --git a/abs/core/libart-lgpl/art_misc.h-cplusplus.patch b/abs/core/libart-lgpl/art_misc.h-cplusplus.patch
deleted file mode 100644
index dea8eb0..0000000
--- a/abs/core/libart-lgpl/art_misc.h-cplusplus.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-Index: art_misc.h
-===================================================================
---- art_misc.h (revision 277)
-+++ art_misc.h (working copy)
-@@ -34,9 +34,15 @@
- #include <libart_lgpl/art_config.h>
- #endif
-
-+#ifdef __cplusplus
-+extern "C" {
-+#endif
- void *art_alloc(size_t size);
- void art_free(void *ptr);
- void *art_realloc(void *ptr, size_t size);
-+#ifdef __cplusplus
-+}
-+#endif /* __cplusplus */
-
- /* These aren't, strictly speaking, configuration macros, but they're
- damn handy to have around, and may be worth playing with for
-Index: ChangeLog
-===================================================================
---- ChangeLog (revision 277)
-+++ ChangeLog (working copy)
-@@ -1,3 +1,10 @@
-+2007-03-01 Frederic Crozat <fcrozat@mandriva.com>
-+
-+ reviewed by: Dom Lachowicz <cinamod@hotmail.com>
-+
-+ * art_misc.h: Fix header when included in C++.
-+ Patch from Goetz Waschk and Laurent Montel.
-+
- 2007-02-28 Kjartan Maraas <kmaraas@gnome.org>
-
- configure.in: Release 2.3.19