summaryrefslogtreecommitdiffstats
path: root/abs/core/libcec
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-11-25 01:15:50 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-11-25 01:15:50 (GMT)
commit6be75ea83696f8de8bcb9750c5f200f9eeb331f7 (patch)
treeed53b10f472720866ef5edb47d4b7cac46bcae5f /abs/core/libcec
parent0ecc17312908fcb18f024d4e54fce988890fdd94 (diff)
downloadlinhes_pkgbuild-6be75ea83696f8de8bcb9750c5f200f9eeb331f7.zip
linhes_pkgbuild-6be75ea83696f8de8bcb9750c5f200f9eeb331f7.tar.gz
linhes_pkgbuild-6be75ea83696f8de8bcb9750c5f200f9eeb331f7.tar.bz2
libcec: update to 2.2.0
Diffstat (limited to 'abs/core/libcec')
-rw-r--r--abs/core/libcec/PKGBUILD19
1 files changed, 6 insertions, 13 deletions
diff --git a/abs/core/libcec/PKGBUILD b/abs/core/libcec/PKGBUILD
index e2ce13d..b877e84 100644
--- a/abs/core/libcec/PKGBUILD
+++ b/abs/core/libcec/PKGBUILD
@@ -4,31 +4,24 @@
# vim: ft=sh:
pkgname=libcec
-pkgver=2.1.3
+pkgver=2.2.0
pkgrel=1
pkgdesc="Pulse-Eight's libcec for the Pulse-Eight USB-CEC adapter"
arch=('i686' 'x86_64')
-url="https://github.com/Pulse-Eight/libcec"
+url="http://libcec.pulse-eight.com/"
license=('GPL')
depends=('udev' 'lockdev')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/Pulse-Eight/libcec/tarball/$pkgname-$pkgver")
-_srcfolder=Pulse-Eight-libcec-54be21e
-options=(!libtool)
-sha256sums=('2aa88451b528184b02077ee8c6cd10e2f89121a6a05b1b35b4b792b03108a9d1')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/Pulse-Eight/$pkgname/archive/$pkgname-$pkgver.tar.gz")
build() {
- mv "$_srcfolder" "$pkgname-$pkgver"
-
- cd "$pkgname-$pkgver"
- export CFLAGS="$CFLAGS -fPIC"
- export CXXFLAGS="$CXXFLAGS -fPIC"
- export LDFLAGS="$LDFLAGS -fPIC"
+ cd "$pkgname-$pkgname-$pkgver"
autoreconf -vif
./configure --prefix=/usr
make
}
package() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname-$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
}
+sha256sums=('fd4f47a18d6e0f4b9e6f5831280207ee2b2a5fc2741ae32ae09ad12a8aa52917')