summaryrefslogtreecommitdiffstats
path: root/abs/core/libdatrie
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-16 22:16:21 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-16 22:16:21 (GMT)
commitac254975d83d37a9d7ada979d746aef7956f53a1 (patch)
treeeb2a99ca220d8cbc99036a299858a9c35c27029a /abs/core/libdatrie
parentb3b816ff1351a79ceb0f3b4c567a5e3832a73dc0 (diff)
downloadlinhes_pkgbuild-ac254975d83d37a9d7ada979d746aef7956f53a1.zip
linhes_pkgbuild-ac254975d83d37a9d7ada979d746aef7956f53a1.tar.gz
linhes_pkgbuild-ac254975d83d37a9d7ada979d746aef7956f53a1.tar.bz2
libdatrie: up to latest
Diffstat (limited to 'abs/core/libdatrie')
-rw-r--r--abs/core/libdatrie/PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/abs/core/libdatrie/PKGBUILD b/abs/core/libdatrie/PKGBUILD
index 9da01c0..166cd43 100644
--- a/abs/core/libdatrie/PKGBUILD
+++ b/abs/core/libdatrie/PKGBUILD
@@ -1,22 +1,26 @@
-# $Id: PKGBUILD 71215 2010-03-05 15:34:36Z jgc $
+# $Id: PKGBUILD 87837 2010-08-18 12:55:23Z jgc $
# Maintainer: Jan de Groot <jgc@archlinux.org>
# Contributor: Chaiwat Suttipongsakul <cwt114@gmail.com>
pkgname=libdatrie
-pkgver=0.2.3
+pkgver=0.2.4
pkgrel=1
-pkgdesc="Libdatrie is an implementation of double-array structure for representing trie, as proposed by Junichi Aoe."
+pkgdesc="Implementation of double-array structure for representing trie, as proposed by Junichi Aoe."
url="http://linux.thai.net/~thep/datrie/datrie.html"
license=('LGPL')
arch=('i686' 'x86_64')
depends=('glibc')
options=('!libtool' '!emptydirs')
source=(http://linux.thai.net/pub/thailinux/software/libthai/${pkgname}-${pkgver}.tar.gz)
-md5sums=('c6814f4fe68aa8d41d1b7183ad78d319')
+md5sums=('7f7d592114f98db9e4c7171c3f2befc5')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- ./configure --prefix=/usr --disable-static || return 1
+ ./configure --prefix=/usr --disable-static
make || return 1
+}
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install || return 1
}
+