summaryrefslogtreecommitdiffstats
path: root/abs/core/libdvdread
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-17 22:24:37 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-17 22:24:37 (GMT)
commit2b28f4edd87526b7775580f8d5996b86a750823d (patch)
tree9fc304c2a629d3249747f356870cff19e7402371 /abs/core/libdvdread
parent139157db8d34b5662687bf303eca59728d81dda8 (diff)
downloadlinhes_pkgbuild-2b28f4edd87526b7775580f8d5996b86a750823d.zip
linhes_pkgbuild-2b28f4edd87526b7775580f8d5996b86a750823d.tar.gz
linhes_pkgbuild-2b28f4edd87526b7775580f8d5996b86a750823d.tar.bz2
libdvdread: update to latest, fix patch
Diffstat (limited to 'abs/core/libdvdread')
-rw-r--r--abs/core/libdvdread/DVDFileStat.patch237
-rw-r--r--abs/core/libdvdread/PKGBUILD36
-rw-r--r--abs/core/libdvdread/__changelog2
3 files changed, 263 insertions, 12 deletions
diff --git a/abs/core/libdvdread/DVDFileStat.patch b/abs/core/libdvdread/DVDFileStat.patch
new file mode 100644
index 0000000..6431122
--- /dev/null
+++ b/abs/core/libdvdread/DVDFileStat.patch
@@ -0,0 +1,237 @@
+diff -pruN libdvdread-4.1.3/src/dvd_reader.c libdvdread-4.1.3.new/src/dvd_reader.c
+--- libdvdread-4.1.3/src/dvd_reader.c 2008-09-06 23:55:51.000000000 +0200
++++ libdvdread-4.1.3.new/src/dvd_reader.c 2009-02-28 01:36:20.000000000 +0100
+@@ -889,6 +889,187 @@ void DVDCloseFile( dvd_file_t *dvd_file
+ }
+ }
+
++static int DVDFileStatVOBUDF(dvd_reader_t *dvd, int title,
++ int menu, dvd_stat_t *statbuf)
++{
++ char filename[ MAX_UDF_FILE_NAME_LEN ];
++ uint32_t size;
++ off_t tot_size;
++ off_t parts_size[9];
++ int nr_parts = 0;
++ int n;
++
++ if( title == 0 ) {
++ sprintf( filename, "/VIDEO_TS/VIDEO_TS.VOB" );
++ } else {
++ sprintf( filename, "/VIDEO_TS/VTS_%02d_%d.VOB", title, menu ? 0 : 1 );
++ }
++ if(!UDFFindFile( dvd, filename, &size )) {
++ return -1;
++ }
++ tot_size = size;
++ nr_parts = 1;
++ parts_size[0] = size;
++
++ if( !menu ) {
++ int cur;
++
++ for( cur = 2; cur < 10; cur++ ) {
++ sprintf( filename, "/VIDEO_TS/VTS_%02d_%d.VOB", title, cur );
++ if( !UDFFindFile( dvd, filename, &size ) ) {
++ break;
++ }
++ parts_size[nr_parts] = size;
++ tot_size += size;
++ nr_parts++;
++ }
++ }
++
++ statbuf->size = tot_size;
++ statbuf->nr_parts = nr_parts;
++ for(n = 0; n < nr_parts; n++) {
++ statbuf->parts_size[n] = parts_size[n];
++ }
++ return 0;
++}
++
++
++static int DVDFileStatVOBPath( dvd_reader_t *dvd, int title,
++ int menu, dvd_stat_t *statbuf )
++{
++ char filename[ MAX_UDF_FILE_NAME_LEN ];
++ char full_path[ PATH_MAX + 1 ];
++ struct stat fileinfo;
++ off_t tot_size;
++ off_t parts_size[9];
++ int nr_parts = 0;
++ int n;
++
++
++
++ if( title == 0 ) {
++ sprintf( filename, "VIDEO_TS.VOB" );
++ } else {
++ sprintf( filename, "VTS_%02d_%d.VOB", title, menu ? 0 : 1 );
++ }
++ if( !findDVDFile( dvd, filename, full_path ) ) {
++ return -1;
++ }
++
++ if( stat( full_path, &fileinfo ) < 0 ) {
++ fprintf( stderr, "libdvdread: Can't stat() %s.\n", filename );
++ return -1;
++ }
++
++
++ tot_size = fileinfo.st_size;
++ nr_parts = 1;
++ parts_size[0] = fileinfo.st_size;
++
++ if( !menu ) {
++ int cur;
++
++ for( cur = 2; cur < 10; cur++ ) {
++
++ sprintf( filename, "VTS_%02d_%d.VOB", title, cur );
++ if( !findDVDFile( dvd, filename, full_path ) ) {
++ break;
++ }
++
++ if( stat( full_path, &fileinfo ) < 0 ) {
++ fprintf( stderr, "libdvdread: Can't stat() %s.\n", filename );
++ break;
++ }
++
++ parts_size[nr_parts] = fileinfo.st_size;
++ tot_size += parts_size[nr_parts];
++ nr_parts++;
++ }
++ }
++
++ statbuf->size = tot_size;
++ statbuf->nr_parts = nr_parts;
++ for(n = 0; n < nr_parts; n++) {
++ statbuf->parts_size[n] = parts_size[n];
++ }
++ return 0;
++}
++
++
++int DVDFileStat(dvd_reader_t *dvd, int titlenum,
++ dvd_read_domain_t domain, dvd_stat_t *statbuf)
++{
++ char filename[ MAX_UDF_FILE_NAME_LEN ];
++ char full_path[ PATH_MAX + 1 ];
++ struct stat fileinfo;
++ uint32_t size;
++
++ /* Check arguments. */
++ if( dvd == NULL || titlenum < 0 ) {
++ errno = EINVAL;
++ return -1;
++ }
++
++ switch( domain ) {
++ case DVD_READ_INFO_FILE:
++ if( titlenum == 0 ) {
++ sprintf( filename, "/VIDEO_TS/VIDEO_TS.IFO" );
++ } else {
++ sprintf( filename, "/VIDEO_TS/VTS_%02i_0.IFO", titlenum );
++ }
++ break;
++ case DVD_READ_INFO_BACKUP_FILE:
++ if( titlenum == 0 ) {
++ sprintf( filename, "/VIDEO_TS/VIDEO_TS.BUP" );
++ } else {
++ sprintf( filename, "/VIDEO_TS/VTS_%02i_0.BUP", titlenum );
++ }
++ break;
++ case DVD_READ_MENU_VOBS:
++ if( dvd->isImageFile ) {
++ return DVDFileStatVOBUDF( dvd, titlenum, 1, statbuf );
++ } else {
++ return DVDFileStatVOBPath( dvd, titlenum, 1, statbuf );
++ }
++ break;
++ case DVD_READ_TITLE_VOBS:
++ if( titlenum == 0 ) {
++ return -1;
++ }
++ if( dvd->isImageFile ) {
++ return DVDFileStatVOBUDF( dvd, titlenum, 0, statbuf );
++ } else {
++ return DVDFileStatVOBPath( dvd, titlenum, 0, statbuf );
++ }
++ break;
++ default:
++ fprintf( stderr, "libdvdread: Invalid domain for file stat.\n" );
++ errno = EINVAL;
++ return -1;
++ }
++
++ if( dvd->isImageFile ) {
++ if( UDFFindFile( dvd, filename, &size ) ) {
++ statbuf->size = size;
++ statbuf->nr_parts = 1;
++ statbuf->parts_size[0] = size;
++ return 0;
++ }
++ } else {
++ if( findDVDFile( dvd, filename, full_path ) ) {
++ if( stat( full_path, &fileinfo ) < 0 ) {
++ fprintf( stderr, "libdvdread: Can't stat() %s.\n", filename );
++ } else {
++ statbuf->size = fileinfo.st_size;
++ statbuf->nr_parts = 1;
++ statbuf->parts_size[0] = statbuf->size;
++ return 0;
++ }
++ }
++ }
++ return -1;
++}
++
+ /* Internal, but used from dvd_udf.c */
+ int UDFReadBlocksRaw( dvd_reader_t *device, uint32_t lb_number,
+ size_t block_count, unsigned char *data,
+diff -pruN libdvdread-4.1.3/src/dvd_reader.h libdvdread-4.1.3.new/src/dvd_reader.h
+--- libdvdread-4.1.3/src/dvd_reader.h 2008-09-06 23:55:51.000000000 +0200
++++ libdvdread-4.1.3.new/src/dvd_reader.h 2009-02-28 01:36:49.000000000 +0100
+@@ -115,6 +115,42 @@ typedef enum {
+ } dvd_read_domain_t;
+
+ /**
++ *
++ */
++typedef struct {
++ off_t size; /**< Total size of file in bytes */
++ int nr_parts; /**< Number of file parts */
++ off_t parts_size[9]; /**< Size of each part in bytes */
++} dvd_stat_t;
++
++/**
++ * Stats a file on the DVD given the title number and domain.
++ * The information about the file is stored in a dvd_stat_t
++ * which contains information about the size of the file and
++ * the number of parts in case of a multipart file and the respective
++ * sizes of the parts.
++ * A multipart file is for instance VTS_02_1.VOB, VTS_02_2.VOB, VTS_02_3.VOB
++ * The size of VTS_02_1.VOB will be stored in stat->parts_size[0],
++ * VTS_02_2.VOB in stat->parts_size[1], ...
++ * The total size (sum of all parts) is stored in stat->size and
++ * stat->nr_parts will hold the number of parts.
++ * Only DVD_READ_TITLE_VOBS (VTS_??_[1-9].VOB) can be multipart files.
++ *
++ * This function is only of use if you want to get the size of each file
++ * in the filesystem. These sizes are not needed to use any other
++ * functions in libdvdread.
++ *
++ * @param dvd A dvd read handle.
++ * @param titlenum Which Video Title Set should be used, VIDEO_TS is 0.
++ * @param domain Which domain.
++ * @param stat Pointer to where the result is stored.
++ * @return If successful 0, otherwise -1.
++ *
++ * int DVDFileStat(dvd, titlenum, domain, stat);
++ */
++int DVDFileStat(dvd_reader_t *, int, dvd_read_domain_t, dvd_stat_t *);
++
++/**
+ * Opens a file on the DVD given the title number and domain.
+ *
+ * If the title number is 0, the video manager information is opened
diff --git a/abs/core/libdvdread/PKGBUILD b/abs/core/libdvdread/PKGBUILD
index e39e586..3e5ece3 100644
--- a/abs/core/libdvdread/PKGBUILD
+++ b/abs/core/libdvdread/PKGBUILD
@@ -1,23 +1,35 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
-# Maintainer: Thomas Baechler <thomas@archlinux.org>
+# $Id: PKGBUILD 80196 2010-05-13 15:59:09Z andrea $
+# Maintainer:
+# Contributor: Thomas Baechler <thomas@archlinux.org>
# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
pkgname=libdvdread
-pkgver=0.9.7
-pkgrel=1
+pkgver=4.1.3
+pkgrel=3
+pkgdesc="Provides a simple foundation for reading DVD video disks"
arch=(i686 x86_64)
-pkgdesc="libdvdread provides a simple foundation for reading DVD video disks"
+url="http://www.mplayerhq.hu/MPlayer/releases/dvdnav/"
+license=('GPL')
depends=('glibc')
makedepends=('libdvdcss')
-install=$pkgname.install
+optdepends=('libdvdcss: for decoding encrypted DVDs')
options=('!libtool')
-source=(http://www.dtek.chalmers.se/groups/dvd/dist/$pkgname-$pkgver.tar.gz)
-url="http://www.dtek.chalmers.se/groups/dvd/downloads.shtml"
-md5sums=('078788c9241ae16763529e1235502337')
+source=("http://www.mplayerhq.hu/MPlayer/releases/dvdnav/${pkgname}-${pkgver}.tar.bz2"
+ 'DVDFileStat.patch')
+md5sums=('6dc068d442c85a3cdd5ad3da75f6c6e8'
+ '0e8e8c19f811a06dc761322e208cbda0')
build() {
- cd $startdir/src/$pkgname-$pkgver
- ./configure --prefix=/usr
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ # http://lists.mplayerhq.hu/pipermail/dvdnav-discuss/2009-February/000986.html (FS#19324)
+ patch -Np1 -i ${srcdir}/DVDFileStat.patch || return 1
+
+ ./autogen.sh --prefix=/usr || return 1
make || return 1
- make DESTDIR=$startdir/pkg install
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install || return 1
}
diff --git a/abs/core/libdvdread/__changelog b/abs/core/libdvdread/__changelog
new file mode 100644
index 0000000..35387a5
--- /dev/null
+++ b/abs/core/libdvdread/__changelog
@@ -0,0 +1,2 @@
+DVDFileStat.patch has DOS new lines. To fix:
+sed -i 's/.$//' DVDFileStat.patch