summaryrefslogtreecommitdiffstats
path: root/abs/core/libdvdread
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 14:45:31 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 14:45:31 (GMT)
commit85e6ee3b78a45a448e19de16eddc5eba40ab9886 (patch)
tree30debf841e5d8667a5fb01d8debf3644b1842e38 /abs/core/libdvdread
parent446f826c31f5df8da845322afb9632b1173da7c9 (diff)
downloadlinhes_pkgbuild-85e6ee3b78a45a448e19de16eddc5eba40ab9886.zip
linhes_pkgbuild-85e6ee3b78a45a448e19de16eddc5eba40ab9886.tar.gz
linhes_pkgbuild-85e6ee3b78a45a448e19de16eddc5eba40ab9886.tar.bz2
libdvdread 4.2.0
Diffstat (limited to 'abs/core/libdvdread')
-rw-r--r--abs/core/libdvdread/DVDFileStat.patch237
-rw-r--r--abs/core/libdvdread/PKGBUILD23
-rw-r--r--abs/core/libdvdread/__changelog2
3 files changed, 10 insertions, 252 deletions
diff --git a/abs/core/libdvdread/DVDFileStat.patch b/abs/core/libdvdread/DVDFileStat.patch
deleted file mode 100644
index 6431122..0000000
--- a/abs/core/libdvdread/DVDFileStat.patch
+++ /dev/null
@@ -1,237 +0,0 @@
-diff -pruN libdvdread-4.1.3/src/dvd_reader.c libdvdread-4.1.3.new/src/dvd_reader.c
---- libdvdread-4.1.3/src/dvd_reader.c 2008-09-06 23:55:51.000000000 +0200
-+++ libdvdread-4.1.3.new/src/dvd_reader.c 2009-02-28 01:36:20.000000000 +0100
-@@ -889,6 +889,187 @@ void DVDCloseFile( dvd_file_t *dvd_file
- }
- }
-
-+static int DVDFileStatVOBUDF(dvd_reader_t *dvd, int title,
-+ int menu, dvd_stat_t *statbuf)
-+{
-+ char filename[ MAX_UDF_FILE_NAME_LEN ];
-+ uint32_t size;
-+ off_t tot_size;
-+ off_t parts_size[9];
-+ int nr_parts = 0;
-+ int n;
-+
-+ if( title == 0 ) {
-+ sprintf( filename, "/VIDEO_TS/VIDEO_TS.VOB" );
-+ } else {
-+ sprintf( filename, "/VIDEO_TS/VTS_%02d_%d.VOB", title, menu ? 0 : 1 );
-+ }
-+ if(!UDFFindFile( dvd, filename, &size )) {
-+ return -1;
-+ }
-+ tot_size = size;
-+ nr_parts = 1;
-+ parts_size[0] = size;
-+
-+ if( !menu ) {
-+ int cur;
-+
-+ for( cur = 2; cur < 10; cur++ ) {
-+ sprintf( filename, "/VIDEO_TS/VTS_%02d_%d.VOB", title, cur );
-+ if( !UDFFindFile( dvd, filename, &size ) ) {
-+ break;
-+ }
-+ parts_size[nr_parts] = size;
-+ tot_size += size;
-+ nr_parts++;
-+ }
-+ }
-+
-+ statbuf->size = tot_size;
-+ statbuf->nr_parts = nr_parts;
-+ for(n = 0; n < nr_parts; n++) {
-+ statbuf->parts_size[n] = parts_size[n];
-+ }
-+ return 0;
-+}
-+
-+
-+static int DVDFileStatVOBPath( dvd_reader_t *dvd, int title,
-+ int menu, dvd_stat_t *statbuf )
-+{
-+ char filename[ MAX_UDF_FILE_NAME_LEN ];
-+ char full_path[ PATH_MAX + 1 ];
-+ struct stat fileinfo;
-+ off_t tot_size;
-+ off_t parts_size[9];
-+ int nr_parts = 0;
-+ int n;
-+
-+
-+
-+ if( title == 0 ) {
-+ sprintf( filename, "VIDEO_TS.VOB" );
-+ } else {
-+ sprintf( filename, "VTS_%02d_%d.VOB", title, menu ? 0 : 1 );
-+ }
-+ if( !findDVDFile( dvd, filename, full_path ) ) {
-+ return -1;
-+ }
-+
-+ if( stat( full_path, &fileinfo ) < 0 ) {
-+ fprintf( stderr, "libdvdread: Can't stat() %s.\n", filename );
-+ return -1;
-+ }
-+
-+
-+ tot_size = fileinfo.st_size;
-+ nr_parts = 1;
-+ parts_size[0] = fileinfo.st_size;
-+
-+ if( !menu ) {
-+ int cur;
-+
-+ for( cur = 2; cur < 10; cur++ ) {
-+
-+ sprintf( filename, "VTS_%02d_%d.VOB", title, cur );
-+ if( !findDVDFile( dvd, filename, full_path ) ) {
-+ break;
-+ }
-+
-+ if( stat( full_path, &fileinfo ) < 0 ) {
-+ fprintf( stderr, "libdvdread: Can't stat() %s.\n", filename );
-+ break;
-+ }
-+
-+ parts_size[nr_parts] = fileinfo.st_size;
-+ tot_size += parts_size[nr_parts];
-+ nr_parts++;
-+ }
-+ }
-+
-+ statbuf->size = tot_size;
-+ statbuf->nr_parts = nr_parts;
-+ for(n = 0; n < nr_parts; n++) {
-+ statbuf->parts_size[n] = parts_size[n];
-+ }
-+ return 0;
-+}
-+
-+
-+int DVDFileStat(dvd_reader_t *dvd, int titlenum,
-+ dvd_read_domain_t domain, dvd_stat_t *statbuf)
-+{
-+ char filename[ MAX_UDF_FILE_NAME_LEN ];
-+ char full_path[ PATH_MAX + 1 ];
-+ struct stat fileinfo;
-+ uint32_t size;
-+
-+ /* Check arguments. */
-+ if( dvd == NULL || titlenum < 0 ) {
-+ errno = EINVAL;
-+ return -1;
-+ }
-+
-+ switch( domain ) {
-+ case DVD_READ_INFO_FILE:
-+ if( titlenum == 0 ) {
-+ sprintf( filename, "/VIDEO_TS/VIDEO_TS.IFO" );
-+ } else {
-+ sprintf( filename, "/VIDEO_TS/VTS_%02i_0.IFO", titlenum );
-+ }
-+ break;
-+ case DVD_READ_INFO_BACKUP_FILE:
-+ if( titlenum == 0 ) {
-+ sprintf( filename, "/VIDEO_TS/VIDEO_TS.BUP" );
-+ } else {
-+ sprintf( filename, "/VIDEO_TS/VTS_%02i_0.BUP", titlenum );
-+ }
-+ break;
-+ case DVD_READ_MENU_VOBS:
-+ if( dvd->isImageFile ) {
-+ return DVDFileStatVOBUDF( dvd, titlenum, 1, statbuf );
-+ } else {
-+ return DVDFileStatVOBPath( dvd, titlenum, 1, statbuf );
-+ }
-+ break;
-+ case DVD_READ_TITLE_VOBS:
-+ if( titlenum == 0 ) {
-+ return -1;
-+ }
-+ if( dvd->isImageFile ) {
-+ return DVDFileStatVOBUDF( dvd, titlenum, 0, statbuf );
-+ } else {
-+ return DVDFileStatVOBPath( dvd, titlenum, 0, statbuf );
-+ }
-+ break;
-+ default:
-+ fprintf( stderr, "libdvdread: Invalid domain for file stat.\n" );
-+ errno = EINVAL;
-+ return -1;
-+ }
-+
-+ if( dvd->isImageFile ) {
-+ if( UDFFindFile( dvd, filename, &size ) ) {
-+ statbuf->size = size;
-+ statbuf->nr_parts = 1;
-+ statbuf->parts_size[0] = size;
-+ return 0;
-+ }
-+ } else {
-+ if( findDVDFile( dvd, filename, full_path ) ) {
-+ if( stat( full_path, &fileinfo ) < 0 ) {
-+ fprintf( stderr, "libdvdread: Can't stat() %s.\n", filename );
-+ } else {
-+ statbuf->size = fileinfo.st_size;
-+ statbuf->nr_parts = 1;
-+ statbuf->parts_size[0] = statbuf->size;
-+ return 0;
-+ }
-+ }
-+ }
-+ return -1;
-+}
-+
- /* Internal, but used from dvd_udf.c */
- int UDFReadBlocksRaw( dvd_reader_t *device, uint32_t lb_number,
- size_t block_count, unsigned char *data,
-diff -pruN libdvdread-4.1.3/src/dvd_reader.h libdvdread-4.1.3.new/src/dvd_reader.h
---- libdvdread-4.1.3/src/dvd_reader.h 2008-09-06 23:55:51.000000000 +0200
-+++ libdvdread-4.1.3.new/src/dvd_reader.h 2009-02-28 01:36:49.000000000 +0100
-@@ -115,6 +115,42 @@ typedef enum {
- } dvd_read_domain_t;
-
- /**
-+ *
-+ */
-+typedef struct {
-+ off_t size; /**< Total size of file in bytes */
-+ int nr_parts; /**< Number of file parts */
-+ off_t parts_size[9]; /**< Size of each part in bytes */
-+} dvd_stat_t;
-+
-+/**
-+ * Stats a file on the DVD given the title number and domain.
-+ * The information about the file is stored in a dvd_stat_t
-+ * which contains information about the size of the file and
-+ * the number of parts in case of a multipart file and the respective
-+ * sizes of the parts.
-+ * A multipart file is for instance VTS_02_1.VOB, VTS_02_2.VOB, VTS_02_3.VOB
-+ * The size of VTS_02_1.VOB will be stored in stat->parts_size[0],
-+ * VTS_02_2.VOB in stat->parts_size[1], ...
-+ * The total size (sum of all parts) is stored in stat->size and
-+ * stat->nr_parts will hold the number of parts.
-+ * Only DVD_READ_TITLE_VOBS (VTS_??_[1-9].VOB) can be multipart files.
-+ *
-+ * This function is only of use if you want to get the size of each file
-+ * in the filesystem. These sizes are not needed to use any other
-+ * functions in libdvdread.
-+ *
-+ * @param dvd A dvd read handle.
-+ * @param titlenum Which Video Title Set should be used, VIDEO_TS is 0.
-+ * @param domain Which domain.
-+ * @param stat Pointer to where the result is stored.
-+ * @return If successful 0, otherwise -1.
-+ *
-+ * int DVDFileStat(dvd, titlenum, domain, stat);
-+ */
-+int DVDFileStat(dvd_reader_t *, int, dvd_read_domain_t, dvd_stat_t *);
-+
-+/**
- * Opens a file on the DVD given the title number and domain.
- *
- * If the title number is 0, the video manager information is opened
diff --git a/abs/core/libdvdread/PKGBUILD b/abs/core/libdvdread/PKGBUILD
index 3e5ece3..53a51bc 100644
--- a/abs/core/libdvdread/PKGBUILD
+++ b/abs/core/libdvdread/PKGBUILD
@@ -1,35 +1,32 @@
-# $Id: PKGBUILD 80196 2010-05-13 15:59:09Z andrea $
-# Maintainer:
+# $Id: PKGBUILD 144377 2011-12-05 12:49:24Z jgc $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
# Contributor: Thomas Baechler <thomas@archlinux.org>
# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
pkgname=libdvdread
-pkgver=4.1.3
-pkgrel=3
+pkgver=4.2.0
+pkgrel=1
pkgdesc="Provides a simple foundation for reading DVD video disks"
arch=(i686 x86_64)
-url="http://www.mplayerhq.hu/MPlayer/releases/dvdnav/"
+url="http://dvdnav.mplayerhq.hu"
license=('GPL')
depends=('glibc')
makedepends=('libdvdcss')
optdepends=('libdvdcss: for decoding encrypted DVDs')
options=('!libtool')
-source=("http://www.mplayerhq.hu/MPlayer/releases/dvdnav/${pkgname}-${pkgver}.tar.bz2"
- 'DVDFileStat.patch')
-md5sums=('6dc068d442c85a3cdd5ad3da75f6c6e8'
- '0e8e8c19f811a06dc761322e208cbda0')
+source=(http://dvdnav.mplayerhq.hu/releases/${pkgname}-${pkgver}.tar.bz2)
+sha256sums=('0bea15da842a4b04a482b009d72dcc6d9c9524ccc1bf67e5748319ec5ada8097')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
# http://lists.mplayerhq.hu/pipermail/dvdnav-discuss/2009-February/000986.html (FS#19324)
- patch -Np1 -i ${srcdir}/DVDFileStat.patch || return 1
- ./autogen.sh --prefix=/usr || return 1
- make || return 1
+ ./autogen.sh --prefix=/usr
+ make
}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install || return 1
+ make DESTDIR="${pkgdir}" install
}
diff --git a/abs/core/libdvdread/__changelog b/abs/core/libdvdread/__changelog
deleted file mode 100644
index 35387a5..0000000
--- a/abs/core/libdvdread/__changelog
+++ /dev/null
@@ -1,2 +0,0 @@
-DVDFileStat.patch has DOS new lines. To fix:
-sed -i 's/.$//' DVDFileStat.patch