summaryrefslogtreecommitdiffstats
path: root/abs/core/libgcrypt
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-02-13 23:06:51 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-02-13 23:06:51 (GMT)
commite8c87f84aeb8d61ce176fae568fc9aeaea69ff54 (patch)
tree32f1b531b6468d537b644b67c10b7fe512b82a57 /abs/core/libgcrypt
parente43bace9f0334e9a85d2c59d19d383930fe6d5ae (diff)
downloadlinhes_pkgbuild-e8c87f84aeb8d61ce176fae568fc9aeaea69ff54.zip
linhes_pkgbuild-e8c87f84aeb8d61ce176fae568fc9aeaea69ff54.tar.gz
linhes_pkgbuild-e8c87f84aeb8d61ce176fae568fc9aeaea69ff54.tar.bz2
libgcrypt: update to 1.8.2
Diffstat (limited to 'abs/core/libgcrypt')
-rw-r--r--abs/core/libgcrypt/PKGBUILD50
-rw-r--r--abs/core/libgcrypt/libgcrypt.install20
2 files changed, 34 insertions, 36 deletions
diff --git a/abs/core/libgcrypt/PKGBUILD b/abs/core/libgcrypt/PKGBUILD
index e3a887b..aea1f81 100644
--- a/abs/core/libgcrypt/PKGBUILD
+++ b/abs/core/libgcrypt/PKGBUILD
@@ -1,35 +1,53 @@
-# $Id: PKGBUILD 156348 2012-04-17 15:57:54Z andyrtr $
+# $Id$
# Maintainer: Andreas Radke <andyrtr@archlinux.org>
+# after a .so bump first rebuild dirmngr
+# with sudo testing-x86_64-build -- -I libgcrypt-1.6.0-1-x86_64.pkg.tar.xz
+# then cp /usr/lib/libgcrypt.so.11 /var/lib/archbuild/staging-x86_64/root/usr/lib/ and do staging-x86_64-build
+
pkgname=libgcrypt
-pkgver=1.5.0
-pkgrel=3
-pkgdesc="a general purpose crypto library based on the code used"
-arch=(i686 x86_64)
+pkgver=1.8.2
+pkgrel=1
+pkgdesc="General purpose cryptographic library based on the code from GnuPG"
+arch=(x86_64)
url="http://www.gnupg.org"
license=('LGPL')
-depends=('libgpg-error>=1.10-2')
-options=('!libtool' '!emptydirs')
-install=$pkgname.install
-source=(ftp://ftp.gnupg.org/gcrypt/${pkgname}/${pkgname}-${pkgver}.tar.bz2
- #ftp://ftp.franken.de/pub/crypt/mirror/ftp.gnupg.org/gcrypt/libgcrypt/${pkgname}-${pkgver}.tar.bz2
-)
-sha1sums=('3e776d44375dc1a710560b98ae8437d5da6e32cf')
+depends=('libgpg-error')
+options=('!emptydirs')
+# https://www.gnupg.org/download/integrity_check.html
+source=(https://gnupg.org/ftp/gcrypt/${pkgname}/${pkgname}-${pkgver}.tar.bz2{,.sig})
+sha1sums=('ab8aae5d7a68f8e0988f90e11e7f6a4805af5c8d'
+ 'SKIP')
+validpgpkeys=('031EC2536E580D8EA286A9F22071B08A33BD3F06' # "NIIBE Yutaka (GnuPG Release Key) <gniibe@fsij.org>"
+ 'D8692123C4065DEA5E0F3AB5249B39D24F25E3B6') # Werner Koch
+options=(!makeflags)
+
+prepare() {
+ cd ${pkgname}-${pkgver}
+ # tests fail due to systemd+libseccomp preventing memory syscalls when building in chroots
+ # t-secmem: line 176: gcry_control (GCRYCTL_INIT_SECMEM, pool_size, 0) failed: General error
+ # FAIL: t-secmem
+ # t-sexp: line 1174: gcry_control (GCRYCTL_INIT_SECMEM, 16384, 0) failed: General error
+ # FAIL: t-sexp
+ sed -i "s:t-secmem::" tests/Makefile.am
+ sed -i "s:t-sexp::" tests/Makefile.am
+ autoreconf -vfi
+}
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd ${pkgname}-${pkgver}
./configure --prefix=/usr \
--disable-static \
- --disable-padlock-support #$EXTRAFLAGS
+ --disable-padlock-support
make
}
check() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd ${pkgname}-${pkgver}
make check
}
package() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd ${pkgname}-${pkgver}
make DESTDIR=${pkgdir} install
}
diff --git a/abs/core/libgcrypt/libgcrypt.install b/abs/core/libgcrypt/libgcrypt.install
deleted file mode 100644
index 79b8782..0000000
--- a/abs/core/libgcrypt/libgcrypt.install
+++ /dev/null
@@ -1,20 +0,0 @@
-infodir=/usr/share/info
-filelist=(gcrypt.info.gz gcrypt.info-1.gz)
-
-post_install() {
- [ -x usr/bin/install-info ] || return 0
- for file in ${filelist[@]}; do
- install-info $infodir/$file $infodir/dir 2> /dev/null
- done
-}
-
-post_upgrade() {
- post_install $1
-}
-
-pre_remove() {
- [ -x usr/bin/install-info ] || return 0
- for file in ${filelist[@]}; do
- install-info --delete $infodir/$file $infodir/dir 2> /dev/null
- done
-}