summaryrefslogtreecommitdiffstats
path: root/abs/core/libgpg-error
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-10-23 18:17:40 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-10-23 18:19:39 (GMT)
commitadbcf19958300e9b6598990184c8815b945ba0ee (patch)
treef4283c850ac0ac202c17e78a637ee7ca8147621b /abs/core/libgpg-error
parent61a68250df10d29b624650948484898334ff22d0 (diff)
downloadlinhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.zip
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.gz
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.bz2
Removed old core and extra from repo. Renamed -testing to core/extra. This will setup the base for the testing branch.
Diffstat (limited to 'abs/core/libgpg-error')
-rw-r--r--abs/core/libgpg-error/PKGBUILD21
1 files changed, 13 insertions, 8 deletions
diff --git a/abs/core/libgpg-error/PKGBUILD b/abs/core/libgpg-error/PKGBUILD
index 834b39c..b7083bb 100644
--- a/abs/core/libgpg-error/PKGBUILD
+++ b/abs/core/libgpg-error/PKGBUILD
@@ -1,23 +1,28 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# $Id: PKGBUILD 80074 2010-05-10 21:13:12Z thomas $
# Maintainer: judd <jvinet@zeroflux.org>
pkgname=libgpg-error
-pkgver=1.6
-pkgrel=10
+pkgver=1.7
+pkgrel=3
pkgdesc="Support library for libgcrypt"
arch=(i686 x86_64)
url="http://www.gnupg.org"
license=('LGPL')
-groups=('base')
-depends=('glibc')
+depends=('glibc' 'sh')
options=(!libtool)
source=(#ftp://ftp.gnupg.org/gcrypt/libgpg-error/${pkgname}-${pkgver}.tar.bz2
ftp://ftp.franken.de/pub/crypt/mirror/ftp.gnupg.org/gcrypt/libgpg-error/${pkgname}-${pkgver}.tar.bz2)
-md5sums=('f3e9870e213518b407a959f8d29cd554')
+md5sums=('62c0d09d1e76c5b6da8fff92314c4665')
build() {
- cd ${startdir}/src/${pkgname}-${pkgver}
+ cd "${srcdir}"/${pkgname}-${pkgver}
+ # keep static lib for crypsetup
./configure --prefix=/usr
make || return 1
- make DESTDIR=${startdir}/pkg install
+ make DESTDIR="${pkgdir}/" install || return 1
+
+ # Move dynamic libraries to /lib
+ install -d -m755 "${pkgdir}"/lib/ || return 1
+ mv "${pkgdir}"/usr/lib/libgpg-error.so* "${pkgdir}"/lib/ || return 1
+ ln -sf /lib/libgpg-error.so "${pkgdir}"/usr/lib/libgpg-error.so || return 1
}