summaryrefslogtreecommitdiffstats
path: root/abs/core/libgssglue
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-17 21:16:41 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-17 21:16:41 (GMT)
commit4e5ff57bdec84087fb631911fbf244b3b32b17ad (patch)
tree9a0485956248e3ce4d2068b5a31f74b718527a6f /abs/core/libgssglue
parent80b272a530c4d411423282074c3cc25492bd70bd (diff)
downloadlinhes_pkgbuild-4e5ff57bdec84087fb631911fbf244b3b32b17ad.zip
linhes_pkgbuild-4e5ff57bdec84087fb631911fbf244b3b32b17ad.tar.gz
linhes_pkgbuild-4e5ff57bdec84087fb631911fbf244b3b32b17ad.tar.bz2
libgssglue: inital import. Dep of libtirpc
Diffstat (limited to 'abs/core/libgssglue')
-rw-r--r--abs/core/libgssglue/PKGBUILD32
-rw-r--r--abs/core/libgssglue/gssapi_mech.conf22
2 files changed, 54 insertions, 0 deletions
diff --git a/abs/core/libgssglue/PKGBUILD b/abs/core/libgssglue/PKGBUILD
new file mode 100644
index 0000000..12c0698
--- /dev/null
+++ b/abs/core/libgssglue/PKGBUILD
@@ -0,0 +1,32 @@
+# $Id: PKGBUILD 62214 2010-01-04 09:19:11Z tpowa $
+# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
+
+pkgname=libgssglue
+pkgver=0.1
+pkgrel=2
+pkgdesc="exports a gssapi interface which calls other random gssapi libraries"
+arch=('i686' 'x86_64')
+url="http://www.citi.umich.edu/projects/nfsv4/linux/"
+license=('BSD')
+depends=('glibc')
+makedepends=('pkgconfig' 'autoconf')
+backup=(etc/gssapi_mech.conf)
+options=('!libtool')
+source=(http://www.citi.umich.edu/projects/nfsv4/linux/$pkgname/$pkgname-$pkgver.tar.gz
+ gssapi_mech.conf)
+md5sums=('ce1b4c758e6de01b712d154c5c97e540'
+ '234b9cca75a33af98eda3f1683756879')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make || return 1
+}
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install || return 1
+ # Configuration
+ install -D -m 644 ../gssapi_mech.conf "$pkgdir/"etc/gssapi_mech.conf
+ # install license
+ install -D -m644 COPYING $pkgdir/usr/share/licenses/libgssglue/COPYING
+}
diff --git a/abs/core/libgssglue/gssapi_mech.conf b/abs/core/libgssglue/gssapi_mech.conf
new file mode 100644
index 0000000..f71aca0
--- /dev/null
+++ b/abs/core/libgssglue/gssapi_mech.conf
@@ -0,0 +1,22 @@
+# Example /etc/gssapi_mech.conf file
+#
+# GSSAPI Mechanism Definitions
+#
+# This configuration file determines which GSS-API mechanisms
+# the gssd code should use
+#
+# NOTE:
+# The initiaiization function "mechglue_internal_krb5_init"
+# is used for the MIT krb5 gssapi mechanism. This special
+# function name indicates that an internal function should
+# be used to determine the entry points for the MIT gssapi
+# mechanism funtions.
+#
+# library initialization function
+# ================================ ==========================
+# The MIT K5 gssapi library, use special function for initialization.
+#/usr/lib/libgssapi_krb5.so mechglue_internal_krb5_init
+/usr/lib/libgssapi.so mechglue_internal_krb5_init
+#
+# The SPKM3 gssapi library function. Use the function spkm3_gss_initialize.
+# /usr/local/gss_mechs/spkm/spkm3/libgssapi_spkm3.so spkm3_gss_initialize