summaryrefslogtreecommitdiffstats
path: root/abs/core/libhdhomerun
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2011-04-01 21:32:23 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2011-04-01 21:32:23 (GMT)
commitcbf1d64d91bf0cb8b64ca549c1059db9d0e4eeb6 (patch)
tree557eece6a0b8b11c5168d2fb5252ff4000c750e6 /abs/core/libhdhomerun
parent09f58ec70914ec2644e127eb748f8d70400aebfd (diff)
downloadlinhes_pkgbuild-cbf1d64d91bf0cb8b64ca549c1059db9d0e4eeb6.zip
linhes_pkgbuild-cbf1d64d91bf0cb8b64ca549c1059db9d0e4eeb6.tar.gz
linhes_pkgbuild-cbf1d64d91bf0cb8b64ca549c1059db9d0e4eeb6.tar.bz2
libhdhomerun: Update software/firmware to 20110323. Removed GUI config app
becasue it does not seem to honor ${DESTDIR} and I don't care enough to patch it to make it install correctly. 20110323 Includes fw for new model HDHR's.
Diffstat (limited to 'abs/core/libhdhomerun')
-rw-r--r--[-rwxr-xr-x]abs/core/libhdhomerun/PKGBUILD64
1 files changed, 40 insertions, 24 deletions
diff --git a/abs/core/libhdhomerun/PKGBUILD b/abs/core/libhdhomerun/PKGBUILD
index 69986df..d30f1b0 100755..100644
--- a/abs/core/libhdhomerun/PKGBUILD
+++ b/abs/core/libhdhomerun/PKGBUILD
@@ -1,42 +1,58 @@
pkgname=libhdhomerun
-pkgver=20100828
+pkgver=20110323
pkgrel=1
pkgdesc="utils and firmware needed for the hdhomerun"
arch=('i686' 'x86_64')
url="http://www.silicondust.com"
license=('GPL3')
-makedepends=('gtk2')
-optdepends=('gtk2: for using hdhomerun_config_gui')
+#makedepends=('gtk2')
+#optdepends=('gtk2: for using hdhomerun_config_gui')
replaces=('hdhomerun')
-firmware=hdhomerun_atsc_firmware_${pkgver}.bin
-firmware2=hdhomerun_dvbt_firmware_${pkgver}.bin
-firmware3=hdhomerun_tech_atsc_firmware_${pkgver}.bin
-url2=http://download.silicondust.com/hdhomerun
-source=("${url2}/libhdhomerun_${pkgver}.tgz"
- "${url2}/${firmware}"
- "${url2}/${firmware2}"
- "${url2}/${firmware3}"
- "${url2}/hdhomerun_config_gui_${pkgver}.tgz")
+_firmware1=hdhomerun_atsc_firmware_${pkgver}.bin
+_firmware2=hdhomerun_dvbt_firmware_${pkgver}.bin
+_firmware3=hdhomerun_tech_atsc_firmware_${pkgver}.bin
+_firmware4=hdhomerun3_atsc_firmware_${pkgver}.bin
+_firmware5=hdhomerun3_dvbt_firmware_${pkgver}.bin
+_firmware6=hdhomerun3_dvbtc_firmware_${pkgver}.bin
+_url2=http://download.silicondust.com/hdhomerun
+source=("${_url2}/libhdhomerun_${pkgver}.tgz"
+ "${_url2}/${_firmware1}"
+ "${_url2}/${_firmware2}"
+ "${_url2}/${_firmware3}"
+ "${_url2}/${_firmware4}"
+ "${_url2}/${_firmware5}"
+ "${_url2}/${_firmware6}")
+ #"${_url2}/hdhomerun_config_gui_${pkgver}.tgz")
build() {
cd ${srcdir}/libhdhomerun
make || return 1
- cd ${srcdir}/hdhomerun_config_gui
- ./configure --prefix=/usr || return 1
- make || return 1
+ #cd ${srcdir}/hdhomerun_config_gui
+ # ./configure --prefix=/usr || return 1
+ # make || return 1
}
package() {
cd ${srcdir}/libhdhomerun
+ install -D -m755 libhdhomerun.so ${pkgdir}/usr/lib/libhdhomerun.so
install -D -m755 hdhomerun_config ${pkgdir}/usr/bin/hdhomerun_config
- cd ${srcdir}/hdhomerun_config_gui
- make DESTDIR=${pkgdir} install || return 1
+
+ # cd ${srcdir}/hdhomerun_config_gui
+ # make DESTDIR=${pkgdir} install || return 1
+
cd ${srcdir}
- mkdir -p ${pkgdir}/lib/firmware
- cp ${srcdir}/*.bin ${pkgdir}/lib/firmware/
+ install -d ${pkgdir}/lib/firmware
+
+ for file in ${_firmware1} ${_firmware2} ${_firmware3} ${_firmware4} \
+ ${_firmware5} ${_firmware6} ; do
+ install -D ${srcdir}/${file} ${pkgdir}/lib/firmware/
+ done
}
-md5sums=('3923ea7f88504271f76117aa608062e2'
- 'bfc6b2fc80680795dac0c642807963ad'
- '99f422cf78a6f0ee79647c75c4ea9b5b'
- '4e2e693057f9251873558fcec2522b46'
- '6c602c5d11eff26c70a707f6559d3f3f')
+md5sums=('5d318777b7779aafd2427bdd57775613'
+ 'c9baa14996a50a5a2d22d58c4f424b01'
+ '22675bda3f1c7a7771068318bdbda288'
+ '829ca4319fbafaf327cac4516c72635a'
+ '6da45e1d2759d4da790c75ee107103f2'
+ '8d3852ff7454c0a0eb4c6783c30b5a4e'
+ 'a3c0a626d56582728c2f853090973aea')
+ #'b6512efae4ad3cf4ee43b9d6d11ac629')