summaryrefslogtreecommitdiffstats
path: root/abs/core/libiec61883
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 14:57:44 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 14:57:44 (GMT)
commita19ab5389c7746a8afe3f0cd1b56cf4afde9b913 (patch)
treec983b7e93168ee4f1a6c864024a5b7d2300faa08 /abs/core/libiec61883
parent356f47550a1d05cd1115e186a6816d614bbf8eeb (diff)
downloadlinhes_pkgbuild-a19ab5389c7746a8afe3f0cd1b56cf4afde9b913.zip
linhes_pkgbuild-a19ab5389c7746a8afe3f0cd1b56cf4afde9b913.tar.gz
linhes_pkgbuild-a19ab5389c7746a8afe3f0cd1b56cf4afde9b913.tar.bz2
libiec61883
Diffstat (limited to 'abs/core/libiec61883')
-rw-r--r--abs/core/libiec61883/PKGBUILD25
-rw-r--r--abs/core/libiec61883/libiec61883-1.2.0-Makefile.patch25
2 files changed, 14 insertions, 36 deletions
diff --git a/abs/core/libiec61883/PKGBUILD b/abs/core/libiec61883/PKGBUILD
index dbb0b49..cd00382 100644
--- a/abs/core/libiec61883/PKGBUILD
+++ b/abs/core/libiec61883/PKGBUILD
@@ -1,5 +1,6 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
-# Maintainer: Jason Chu <jason@archlinux.org>
+# $Id: PKGBUILD 144006 2011-12-01 16:55:03Z giovanni $
+# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: Jason Chu <jason@archlinux.org>
# Contributor: Jaroslaw Swierczynski <swiergot@juvepoland.com>
# Contributor: Stephen Caraher <moskvax@gmail.com>
@@ -8,20 +9,22 @@ pkgver=1.2.0
pkgrel=3
pkgdesc="A higher level API for streaming DV, MPEG-2 and audio over Linux IEEE 1394"
arch=('i686' 'x86_64')
-url="http://www.linux1394.org/"
+url="http://www.kernel.org/pub/linux/libs/ieee1394/"
license=('LGPL')
depends=('libraw1394')
options=('!libtool')
-source=(http://www.kernel.org/pub/linux/libs/ieee1394/$pkgname-$pkgver.tar.gz)
+source=("http://ftp.osuosl.org/pub/linux/libs/ieee1394/${pkgname}-${pkgver}.tar.gz")
md5sums=('8af39fff74988073c3ad53fbab147da9')
build() {
- cd $startdir/src/$pkgname-$pkgver
- patch -p0 <$startdir/libiec61883-1.2.0-Makefile.patch
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
./configure --prefix=/usr
- make || return 1
- make DESTDIR=$startdir/pkg install || return 1
-# mkdir -p $startdir/pkg/usr/bin/.libs
-# cp $startdir/src/$pkgname-$pkgver/examples/test-mpeg2 $startdir/pkg/usr/bin || return 1
-# cp $startdir/src/$pkgname-$pkgver/examples/.libs/lt-test-mpeg2 $startdir/pkg/usr/bin/.libs || return 1
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
}
diff --git a/abs/core/libiec61883/libiec61883-1.2.0-Makefile.patch b/abs/core/libiec61883/libiec61883-1.2.0-Makefile.patch
deleted file mode 100644
index 59166ce..0000000
--- a/abs/core/libiec61883/libiec61883-1.2.0-Makefile.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- examples/Makefile.in.orig 2010-01-01 03:30:47.294012274 +0000
-+++ examples/Makefile.in 2010-01-01 03:35:31.530650431 +0000
-@@ -33,8 +33,8 @@
- build_triplet = @build@
- host_triplet = @host@
- noinst_PROGRAMS = test-amdtp$(EXEEXT) test-dv$(EXEEXT) \
-- test-mpeg2$(EXEEXT) test-plugs$(EXEEXT)
--bin_PROGRAMS = plugreport$(EXEEXT) plugctl$(EXEEXT)
-+ test-plugs$(EXEEXT)
-+bin_PROGRAMS = plugreport$(EXEEXT) plugctl$(EXEEXT) test-mpeg2$(EXEEXT)
- subdir = examples
- DIST_COMMON = $(srcdir)/Makefile.am $(srcdir)/Makefile.in
- ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
-
---- examples/Makefile.am.orig 2010-01-01 03:30:57.440678420 +0000
-+++ examples/Makefile.am 2010-01-01 03:33:34.714412431 +0000
-@@ -1,6 +1,6 @@
-
--noinst_PROGRAMS = test-amdtp test-dv test-mpeg2 test-plugs
--bin_PROGRAMS = plugreport plugctl
-+noinst_PROGRAMS = test-amdtp test-dv test-plugs
-+bin_PROGRAMS = plugreport plugctl test-mpeg2
- man_MANS = plugreport.1 plugctl.1
- EXTRA_DIST = plugreport.1 plugctl.1
-