summaryrefslogtreecommitdiffstats
path: root/abs/core/libiec61883
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-08-30 22:24:02 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-08-30 22:24:02 (GMT)
commitc4bd4457b5d640e1c8f5afbca7cd54c53691e5fc (patch)
treef4e4f7a91e1d9d90033fd99d89e5e26a2c144528 /abs/core/libiec61883
parent0e7b327a1ae444233f1308a95420f70540ad74a3 (diff)
downloadlinhes_pkgbuild-c4bd4457b5d640e1c8f5afbca7cd54c53691e5fc.zip
linhes_pkgbuild-c4bd4457b5d640e1c8f5afbca7cd54c53691e5fc.tar.gz
linhes_pkgbuild-c4bd4457b5d640e1c8f5afbca7cd54c53691e5fc.tar.bz2
RSYNC CORE:
resync core-testing -> core Signed-off-by: James Meyer <james.meyer@operamail.com>
Diffstat (limited to 'abs/core/libiec61883')
-rw-r--r--abs/core/libiec61883/PKGBUILD10
-rw-r--r--abs/core/libiec61883/libiec61883-1.2.0-Makefile.patch25
2 files changed, 32 insertions, 3 deletions
diff --git a/abs/core/libiec61883/PKGBUILD b/abs/core/libiec61883/PKGBUILD
index 8159d36..dbb0b49 100644
--- a/abs/core/libiec61883/PKGBUILD
+++ b/abs/core/libiec61883/PKGBUILD
@@ -5,19 +5,23 @@
pkgname=libiec61883
pkgver=1.2.0
-pkgrel=2
+pkgrel=3
pkgdesc="A higher level API for streaming DV, MPEG-2 and audio over Linux IEEE 1394"
arch=('i686' 'x86_64')
url="http://www.linux1394.org/"
license=('LGPL')
depends=('libraw1394')
options=('!libtool')
-source=(http://www.linux1394.org/dl/$pkgname-$pkgver.tar.gz)
+source=(http://www.kernel.org/pub/linux/libs/ieee1394/$pkgname-$pkgver.tar.gz)
md5sums=('8af39fff74988073c3ad53fbab147da9')
build() {
cd $startdir/src/$pkgname-$pkgver
+ patch -p0 <$startdir/libiec61883-1.2.0-Makefile.patch
./configure --prefix=/usr
make || return 1
- make DESTDIR=$startdir/pkg install
+ make DESTDIR=$startdir/pkg install || return 1
+# mkdir -p $startdir/pkg/usr/bin/.libs
+# cp $startdir/src/$pkgname-$pkgver/examples/test-mpeg2 $startdir/pkg/usr/bin || return 1
+# cp $startdir/src/$pkgname-$pkgver/examples/.libs/lt-test-mpeg2 $startdir/pkg/usr/bin/.libs || return 1
}
diff --git a/abs/core/libiec61883/libiec61883-1.2.0-Makefile.patch b/abs/core/libiec61883/libiec61883-1.2.0-Makefile.patch
new file mode 100644
index 0000000..59166ce
--- /dev/null
+++ b/abs/core/libiec61883/libiec61883-1.2.0-Makefile.patch
@@ -0,0 +1,25 @@
+--- examples/Makefile.in.orig 2010-01-01 03:30:47.294012274 +0000
++++ examples/Makefile.in 2010-01-01 03:35:31.530650431 +0000
+@@ -33,8 +33,8 @@
+ build_triplet = @build@
+ host_triplet = @host@
+ noinst_PROGRAMS = test-amdtp$(EXEEXT) test-dv$(EXEEXT) \
+- test-mpeg2$(EXEEXT) test-plugs$(EXEEXT)
+-bin_PROGRAMS = plugreport$(EXEEXT) plugctl$(EXEEXT)
++ test-plugs$(EXEEXT)
++bin_PROGRAMS = plugreport$(EXEEXT) plugctl$(EXEEXT) test-mpeg2$(EXEEXT)
+ subdir = examples
+ DIST_COMMON = $(srcdir)/Makefile.am $(srcdir)/Makefile.in
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
+
+--- examples/Makefile.am.orig 2010-01-01 03:30:57.440678420 +0000
++++ examples/Makefile.am 2010-01-01 03:33:34.714412431 +0000
+@@ -1,6 +1,6 @@
+
+-noinst_PROGRAMS = test-amdtp test-dv test-mpeg2 test-plugs
+-bin_PROGRAMS = plugreport plugctl
++noinst_PROGRAMS = test-amdtp test-dv test-plugs
++bin_PROGRAMS = plugreport plugctl test-mpeg2
+ man_MANS = plugreport.1 plugctl.1
+ EXTRA_DIST = plugreport.1 plugctl.1
+