summaryrefslogtreecommitdiffstats
path: root/abs/core/libjpeg-turbo
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-12-04 18:51:41 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-12-04 18:51:41 (GMT)
commit41f84477615bd6e2286c681458a72685207bddf6 (patch)
treeaab9e32c918a94304870f5de322c1038b3c512d8 /abs/core/libjpeg-turbo
parentb88253492f364da79024745e2be2ede68b7164b7 (diff)
downloadlinhes_pkgbuild-41f84477615bd6e2286c681458a72685207bddf6.zip
linhes_pkgbuild-41f84477615bd6e2286c681458a72685207bddf6.tar.gz
linhes_pkgbuild-41f84477615bd6e2286c681458a72685207bddf6.tar.bz2
libjpeg-turbo: update to 1.3.1-3
Diffstat (limited to 'abs/core/libjpeg-turbo')
-rw-r--r--abs/core/libjpeg-turbo/PKGBUILD16
-rw-r--r--abs/core/libjpeg-turbo/jstdhuff.patch301
-rw-r--r--abs/core/libjpeg-turbo/overrun.patch21
3 files changed, 335 insertions, 3 deletions
diff --git a/abs/core/libjpeg-turbo/PKGBUILD b/abs/core/libjpeg-turbo/PKGBUILD
index 65f5bc4..e2dedc3 100644
--- a/abs/core/libjpeg-turbo/PKGBUILD
+++ b/abs/core/libjpeg-turbo/PKGBUILD
@@ -5,19 +5,29 @@
pkgname=libjpeg-turbo
pkgver=1.3.1
-pkgrel=1
+pkgrel=3
pkgdesc='JPEG image codec with accelerated baseline compression and decompression'
url='http://libjpeg-turbo.virtualgl.org/'
license=('GPL' 'custom')
arch=('i686' 'x86_64')
makedepends=('nasm')
-source=("http://downloads.sourceforge.net/project/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz")
-sha1sums=('5fa19252e5ca992cfa40446a0210ceff55fbe468')
+source=("http://downloads.sourceforge.net/project/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz"
+ 'jstdhuff.patch'
+ 'overrun.patch')
+sha1sums=('5fa19252e5ca992cfa40446a0210ceff55fbe468'
+ 'f459890257df430dc4e2d8bd3060173a1be7516e'
+ '438aba2241b19857bab090c6f61bd3f249f27591')
provides=('libjpeg=8.0.2' 'turbojpeg')
conflicts=('libjpeg' 'turbojpeg')
replaces=('libjpeg' 'turbojpeg')
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -p0 -i ../jstdhuff.patch # FS#42747
+ patch -p1 -i ../overrun.patch # FS#42922
+}
+
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
./configure --prefix=/usr --with-jpeg8 --mandir=/usr/share/man
diff --git a/abs/core/libjpeg-turbo/jstdhuff.patch b/abs/core/libjpeg-turbo/jstdhuff.patch
new file mode 100644
index 0000000..764147d
--- /dev/null
+++ b/abs/core/libjpeg-turbo/jstdhuff.patch
@@ -0,0 +1,301 @@
+Index: jcparam.c
+===================================================================
+--- jcparam.c (revision 1103)
++++ jcparam.c (revision 1104)
+@@ -16,6 +16,7 @@
+ #define JPEG_INTERNALS
+ #include "jinclude.h"
+ #include "jpeglib.h"
++#include "jstdhuff.c"
+
+
+ /*
+@@ -166,116 +167,6 @@
+
+
+ /*
+- * Huffman table setup routines
+- */
+-
+-LOCAL(void)
+-add_huff_table (j_compress_ptr cinfo,
+- JHUFF_TBL **htblptr, const UINT8 *bits, const UINT8 *val)
+-/* Define a Huffman table */
+-{
+- int nsymbols, len;
+-
+- if (*htblptr == NULL)
+- *htblptr = jpeg_alloc_huff_table((j_common_ptr) cinfo);
+-
+- /* Copy the number-of-symbols-of-each-code-length counts */
+- MEMCOPY((*htblptr)->bits, bits, SIZEOF((*htblptr)->bits));
+-
+- /* Validate the counts. We do this here mainly so we can copy the right
+- * number of symbols from the val[] array, without risking marching off
+- * the end of memory. jchuff.c will do a more thorough test later.
+- */
+- nsymbols = 0;
+- for (len = 1; len <= 16; len++)
+- nsymbols += bits[len];
+- if (nsymbols < 1 || nsymbols > 256)
+- ERREXIT(cinfo, JERR_BAD_HUFF_TABLE);
+-
+- MEMCOPY((*htblptr)->huffval, val, nsymbols * SIZEOF(UINT8));
+-
+- /* Initialize sent_table FALSE so table will be written to JPEG file. */
+- (*htblptr)->sent_table = FALSE;
+-}
+-
+-
+-LOCAL(void)
+-std_huff_tables (j_compress_ptr cinfo)
+-/* Set up the standard Huffman tables (cf. JPEG standard section K.3) */
+-/* IMPORTANT: these are only valid for 8-bit data precision! */
+-{
+- static const UINT8 bits_dc_luminance[17] =
+- { /* 0-base */ 0, 0, 1, 5, 1, 1, 1, 1, 1, 1, 0, 0, 0, 0, 0, 0, 0 };
+- static const UINT8 val_dc_luminance[] =
+- { 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11 };
+-
+- static const UINT8 bits_dc_chrominance[17] =
+- { /* 0-base */ 0, 0, 3, 1, 1, 1, 1, 1, 1, 1, 1, 1, 0, 0, 0, 0, 0 };
+- static const UINT8 val_dc_chrominance[] =
+- { 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11 };
+-
+- static const UINT8 bits_ac_luminance[17] =
+- { /* 0-base */ 0, 0, 2, 1, 3, 3, 2, 4, 3, 5, 5, 4, 4, 0, 0, 1, 0x7d };
+- static const UINT8 val_ac_luminance[] =
+- { 0x01, 0x02, 0x03, 0x00, 0x04, 0x11, 0x05, 0x12,
+- 0x21, 0x31, 0x41, 0x06, 0x13, 0x51, 0x61, 0x07,
+- 0x22, 0x71, 0x14, 0x32, 0x81, 0x91, 0xa1, 0x08,
+- 0x23, 0x42, 0xb1, 0xc1, 0x15, 0x52, 0xd1, 0xf0,
+- 0x24, 0x33, 0x62, 0x72, 0x82, 0x09, 0x0a, 0x16,
+- 0x17, 0x18, 0x19, 0x1a, 0x25, 0x26, 0x27, 0x28,
+- 0x29, 0x2a, 0x34, 0x35, 0x36, 0x37, 0x38, 0x39,
+- 0x3a, 0x43, 0x44, 0x45, 0x46, 0x47, 0x48, 0x49,
+- 0x4a, 0x53, 0x54, 0x55, 0x56, 0x57, 0x58, 0x59,
+- 0x5a, 0x63, 0x64, 0x65, 0x66, 0x67, 0x68, 0x69,
+- 0x6a, 0x73, 0x74, 0x75, 0x76, 0x77, 0x78, 0x79,
+- 0x7a, 0x83, 0x84, 0x85, 0x86, 0x87, 0x88, 0x89,
+- 0x8a, 0x92, 0x93, 0x94, 0x95, 0x96, 0x97, 0x98,
+- 0x99, 0x9a, 0xa2, 0xa3, 0xa4, 0xa5, 0xa6, 0xa7,
+- 0xa8, 0xa9, 0xaa, 0xb2, 0xb3, 0xb4, 0xb5, 0xb6,
+- 0xb7, 0xb8, 0xb9, 0xba, 0xc2, 0xc3, 0xc4, 0xc5,
+- 0xc6, 0xc7, 0xc8, 0xc9, 0xca, 0xd2, 0xd3, 0xd4,
+- 0xd5, 0xd6, 0xd7, 0xd8, 0xd9, 0xda, 0xe1, 0xe2,
+- 0xe3, 0xe4, 0xe5, 0xe6, 0xe7, 0xe8, 0xe9, 0xea,
+- 0xf1, 0xf2, 0xf3, 0xf4, 0xf5, 0xf6, 0xf7, 0xf8,
+- 0xf9, 0xfa };
+-
+- static const UINT8 bits_ac_chrominance[17] =
+- { /* 0-base */ 0, 0, 2, 1, 2, 4, 4, 3, 4, 7, 5, 4, 4, 0, 1, 2, 0x77 };
+- static const UINT8 val_ac_chrominance[] =
+- { 0x00, 0x01, 0x02, 0x03, 0x11, 0x04, 0x05, 0x21,
+- 0x31, 0x06, 0x12, 0x41, 0x51, 0x07, 0x61, 0x71,
+- 0x13, 0x22, 0x32, 0x81, 0x08, 0x14, 0x42, 0x91,
+- 0xa1, 0xb1, 0xc1, 0x09, 0x23, 0x33, 0x52, 0xf0,
+- 0x15, 0x62, 0x72, 0xd1, 0x0a, 0x16, 0x24, 0x34,
+- 0xe1, 0x25, 0xf1, 0x17, 0x18, 0x19, 0x1a, 0x26,
+- 0x27, 0x28, 0x29, 0x2a, 0x35, 0x36, 0x37, 0x38,
+- 0x39, 0x3a, 0x43, 0x44, 0x45, 0x46, 0x47, 0x48,
+- 0x49, 0x4a, 0x53, 0x54, 0x55, 0x56, 0x57, 0x58,
+- 0x59, 0x5a, 0x63, 0x64, 0x65, 0x66, 0x67, 0x68,
+- 0x69, 0x6a, 0x73, 0x74, 0x75, 0x76, 0x77, 0x78,
+- 0x79, 0x7a, 0x82, 0x83, 0x84, 0x85, 0x86, 0x87,
+- 0x88, 0x89, 0x8a, 0x92, 0x93, 0x94, 0x95, 0x96,
+- 0x97, 0x98, 0x99, 0x9a, 0xa2, 0xa3, 0xa4, 0xa5,
+- 0xa6, 0xa7, 0xa8, 0xa9, 0xaa, 0xb2, 0xb3, 0xb4,
+- 0xb5, 0xb6, 0xb7, 0xb8, 0xb9, 0xba, 0xc2, 0xc3,
+- 0xc4, 0xc5, 0xc6, 0xc7, 0xc8, 0xc9, 0xca, 0xd2,
+- 0xd3, 0xd4, 0xd5, 0xd6, 0xd7, 0xd8, 0xd9, 0xda,
+- 0xe2, 0xe3, 0xe4, 0xe5, 0xe6, 0xe7, 0xe8, 0xe9,
+- 0xea, 0xf2, 0xf3, 0xf4, 0xf5, 0xf6, 0xf7, 0xf8,
+- 0xf9, 0xfa };
+-
+- add_huff_table(cinfo, &cinfo->dc_huff_tbl_ptrs[0],
+- bits_dc_luminance, val_dc_luminance);
+- add_huff_table(cinfo, &cinfo->ac_huff_tbl_ptrs[0],
+- bits_ac_luminance, val_ac_luminance);
+- add_huff_table(cinfo, &cinfo->dc_huff_tbl_ptrs[1],
+- bits_dc_chrominance, val_dc_chrominance);
+- add_huff_table(cinfo, &cinfo->ac_huff_tbl_ptrs[1],
+- bits_ac_chrominance, val_ac_chrominance);
+-}
+-
+-
+-/*
+ * Default parameter setup for compression.
+ *
+ * Applications that don't choose to use this routine must do their
+@@ -313,7 +204,7 @@
+ /* Set up two quantization tables using default quality of 75 */
+ jpeg_set_quality(cinfo, 75, TRUE);
+ /* Set up two Huffman tables */
+- std_huff_tables(cinfo);
++ std_huff_tables((j_common_ptr) cinfo);
+
+ /* Initialize default arithmetic coding conditioning */
+ for (i = 0; i < NUM_ARITH_TBLS; i++) {
+Index: jstdhuff.c
+===================================================================
+--- jstdhuff.c (revision 0)
++++ jstdhuff.c (revision 1104)
+@@ -0,0 +1,133 @@
++/*
++* jstdhuff.c
++*
++* This file was part of the Independent JPEG Group's software:
++* Copyright (C) 1991-1998, Thomas G. Lane.
++* libjpeg-turbo Modifications:
++* Copyright (C) 2013, D. R. Commander.
++* For conditions of distribution and use, see the accompanying README file.
++*
++* This file contains routines to set the default Huffman tables, if they are
++* not already set.
++*/
++
++/*
++ * Huffman table setup routines
++ */
++
++LOCAL(void)
++add_huff_table (j_common_ptr cinfo,
++ JHUFF_TBL **htblptr, const UINT8 *bits, const UINT8 *val)
++/* Define a Huffman table */
++{
++ int nsymbols, len;
++
++ if (*htblptr == NULL)
++ *htblptr = jpeg_alloc_huff_table(cinfo);
++ else
++ return;
++
++ /* Copy the number-of-symbols-of-each-code-length counts */
++ MEMCOPY((*htblptr)->bits, bits, SIZEOF((*htblptr)->bits));
++
++ /* Validate the counts. We do this here mainly so we can copy the right
++ * number of symbols from the val[] array, without risking marching off
++ * the end of memory. jchuff.c will do a more thorough test later.
++ */
++ nsymbols = 0;
++ for (len = 1; len <= 16; len++)
++ nsymbols += bits[len];
++ if (nsymbols < 1 || nsymbols > 256)
++ ERREXIT(cinfo, JERR_BAD_HUFF_TABLE);
++
++ MEMCOPY((*htblptr)->huffval, val, nsymbols * SIZEOF(UINT8));
++
++ /* Initialize sent_table FALSE so table will be written to JPEG file. */
++ (*htblptr)->sent_table = FALSE;
++}
++
++
++LOCAL(void)
++std_huff_tables (j_common_ptr cinfo)
++/* Set up the standard Huffman tables (cf. JPEG standard section K.3) */
++/* IMPORTANT: these are only valid for 8-bit data precision! */
++{
++ JHUFF_TBL **dc_huff_tbl_ptrs, **ac_huff_tbl_ptrs;
++
++ static const UINT8 bits_dc_luminance[17] =
++ { /* 0-base */ 0, 0, 1, 5, 1, 1, 1, 1, 1, 1, 0, 0, 0, 0, 0, 0, 0 };
++ static const UINT8 val_dc_luminance[] =
++ { 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11 };
++
++ static const UINT8 bits_dc_chrominance[17] =
++ { /* 0-base */ 0, 0, 3, 1, 1, 1, 1, 1, 1, 1, 1, 1, 0, 0, 0, 0, 0 };
++ static const UINT8 val_dc_chrominance[] =
++ { 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11 };
++
++ static const UINT8 bits_ac_luminance[17] =
++ { /* 0-base */ 0, 0, 2, 1, 3, 3, 2, 4, 3, 5, 5, 4, 4, 0, 0, 1, 0x7d };
++ static const UINT8 val_ac_luminance[] =
++ { 0x01, 0x02, 0x03, 0x00, 0x04, 0x11, 0x05, 0x12,
++ 0x21, 0x31, 0x41, 0x06, 0x13, 0x51, 0x61, 0x07,
++ 0x22, 0x71, 0x14, 0x32, 0x81, 0x91, 0xa1, 0x08,
++ 0x23, 0x42, 0xb1, 0xc1, 0x15, 0x52, 0xd1, 0xf0,
++ 0x24, 0x33, 0x62, 0x72, 0x82, 0x09, 0x0a, 0x16,
++ 0x17, 0x18, 0x19, 0x1a, 0x25, 0x26, 0x27, 0x28,
++ 0x29, 0x2a, 0x34, 0x35, 0x36, 0x37, 0x38, 0x39,
++ 0x3a, 0x43, 0x44, 0x45, 0x46, 0x47, 0x48, 0x49,
++ 0x4a, 0x53, 0x54, 0x55, 0x56, 0x57, 0x58, 0x59,
++ 0x5a, 0x63, 0x64, 0x65, 0x66, 0x67, 0x68, 0x69,
++ 0x6a, 0x73, 0x74, 0x75, 0x76, 0x77, 0x78, 0x79,
++ 0x7a, 0x83, 0x84, 0x85, 0x86, 0x87, 0x88, 0x89,
++ 0x8a, 0x92, 0x93, 0x94, 0x95, 0x96, 0x97, 0x98,
++ 0x99, 0x9a, 0xa2, 0xa3, 0xa4, 0xa5, 0xa6, 0xa7,
++ 0xa8, 0xa9, 0xaa, 0xb2, 0xb3, 0xb4, 0xb5, 0xb6,
++ 0xb7, 0xb8, 0xb9, 0xba, 0xc2, 0xc3, 0xc4, 0xc5,
++ 0xc6, 0xc7, 0xc8, 0xc9, 0xca, 0xd2, 0xd3, 0xd4,
++ 0xd5, 0xd6, 0xd7, 0xd8, 0xd9, 0xda, 0xe1, 0xe2,
++ 0xe3, 0xe4, 0xe5, 0xe6, 0xe7, 0xe8, 0xe9, 0xea,
++ 0xf1, 0xf2, 0xf3, 0xf4, 0xf5, 0xf6, 0xf7, 0xf8,
++ 0xf9, 0xfa };
++
++ static const UINT8 bits_ac_chrominance[17] =
++ { /* 0-base */ 0, 0, 2, 1, 2, 4, 4, 3, 4, 7, 5, 4, 4, 0, 1, 2, 0x77 };
++ static const UINT8 val_ac_chrominance[] =
++ { 0x00, 0x01, 0x02, 0x03, 0x11, 0x04, 0x05, 0x21,
++ 0x31, 0x06, 0x12, 0x41, 0x51, 0x07, 0x61, 0x71,
++ 0x13, 0x22, 0x32, 0x81, 0x08, 0x14, 0x42, 0x91,
++ 0xa1, 0xb1, 0xc1, 0x09, 0x23, 0x33, 0x52, 0xf0,
++ 0x15, 0x62, 0x72, 0xd1, 0x0a, 0x16, 0x24, 0x34,
++ 0xe1, 0x25, 0xf1, 0x17, 0x18, 0x19, 0x1a, 0x26,
++ 0x27, 0x28, 0x29, 0x2a, 0x35, 0x36, 0x37, 0x38,
++ 0x39, 0x3a, 0x43, 0x44, 0x45, 0x46, 0x47, 0x48,
++ 0x49, 0x4a, 0x53, 0x54, 0x55, 0x56, 0x57, 0x58,
++ 0x59, 0x5a, 0x63, 0x64, 0x65, 0x66, 0x67, 0x68,
++ 0x69, 0x6a, 0x73, 0x74, 0x75, 0x76, 0x77, 0x78,
++ 0x79, 0x7a, 0x82, 0x83, 0x84, 0x85, 0x86, 0x87,
++ 0x88, 0x89, 0x8a, 0x92, 0x93, 0x94, 0x95, 0x96,
++ 0x97, 0x98, 0x99, 0x9a, 0xa2, 0xa3, 0xa4, 0xa5,
++ 0xa6, 0xa7, 0xa8, 0xa9, 0xaa, 0xb2, 0xb3, 0xb4,
++ 0xb5, 0xb6, 0xb7, 0xb8, 0xb9, 0xba, 0xc2, 0xc3,
++ 0xc4, 0xc5, 0xc6, 0xc7, 0xc8, 0xc9, 0xca, 0xd2,
++ 0xd3, 0xd4, 0xd5, 0xd6, 0xd7, 0xd8, 0xd9, 0xda,
++ 0xe2, 0xe3, 0xe4, 0xe5, 0xe6, 0xe7, 0xe8, 0xe9,
++ 0xea, 0xf2, 0xf3, 0xf4, 0xf5, 0xf6, 0xf7, 0xf8,
++ 0xf9, 0xfa };
++
++ if (cinfo->is_decompressor) {
++ dc_huff_tbl_ptrs = ((j_decompress_ptr)cinfo)->dc_huff_tbl_ptrs;
++ ac_huff_tbl_ptrs = ((j_decompress_ptr)cinfo)->ac_huff_tbl_ptrs;
++ } else {
++ dc_huff_tbl_ptrs = ((j_compress_ptr)cinfo)->dc_huff_tbl_ptrs;
++ ac_huff_tbl_ptrs = ((j_compress_ptr)cinfo)->ac_huff_tbl_ptrs;
++ }
++
++ add_huff_table(cinfo, &dc_huff_tbl_ptrs[0], bits_dc_luminance,
++ val_dc_luminance);
++ add_huff_table(cinfo, &ac_huff_tbl_ptrs[0], bits_ac_luminance,
++ val_ac_luminance);
++ add_huff_table(cinfo, &dc_huff_tbl_ptrs[1], bits_dc_chrominance,
++ val_dc_chrominance);
++ add_huff_table(cinfo, &ac_huff_tbl_ptrs[1], bits_ac_chrominance,
++ val_ac_chrominance);
++}
+Index: jdhuff.c
+===================================================================
+--- jdhuff.c (revision 1103)
++++ jdhuff.c (revision 1104)
+@@ -21,6 +21,7 @@
+ #include "jpeglib.h"
+ #include "jdhuff.h" /* Declarations shared with jdphuff.c */
+ #include "jpegcomp.h"
++#include "jstdhuff.c"
+
+
+ /*
+@@ -795,6 +796,12 @@
+ huff_entropy_ptr entropy;
+ int i;
+
++ /* Motion JPEG frames typically do not include the Huffman tables if they
++ are the default tables. Thus, if the tables are not set by the time
++ the Huffman decoder is initialized (usually within the body of
++ jpeg_start_decompress()), we set them to default values. */
++ std_huff_tables((j_common_ptr) cinfo);
++
+ entropy = (huff_entropy_ptr)
+ (*cinfo->mem->alloc_small) ((j_common_ptr) cinfo, JPOOL_IMAGE,
+ SIZEOF(huff_entropy_decoder));
diff --git a/abs/core/libjpeg-turbo/overrun.patch b/abs/core/libjpeg-turbo/overrun.patch
new file mode 100644
index 0000000..92f48c3
--- /dev/null
+++ b/abs/core/libjpeg-turbo/overrun.patch
@@ -0,0 +1,21 @@
+diff -Naur old/jchuff.c new/jchuff.c
+--- old/jchuff.c 2014-11-27 06:48:21.009442853 -1000
++++ new/jchuff.c 2014-11-27 06:48:46.289700004 -1000
+@@ -391,7 +391,16 @@
+ #endif
+
+
+-#define BUFSIZE (DCTSIZE2 * 2)
++/* Although it is exceedingly rare, it is possible for a Huffman-encoded
++ * coefficient block to be larger than the 128-byte unencoded block. For each
++ * of the 64 coefficients, PUT_BITS is invoked twice, and each invocation can
++ * theoretically store 16 bits (for a maximum of 2048 bits or 256 bytes per
++ * encoded block.) If, for instance, one artificially sets the AC
++ * coefficients to alternating values of 32767 and -32768 (using the JPEG
++ * scanning order-- 1, 8, 16, etc.), then this will produce an encoded block
++ * larger than 200 bytes.
++ */
++#define BUFSIZE (DCTSIZE2 * 4)
+
+ #define LOAD_BUFFER() { \
+ if (state->free_in_buffer < BUFSIZE) { \