summaryrefslogtreecommitdiffstats
path: root/abs/core/libmpc/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-10-23 18:17:40 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-10-23 18:19:39 (GMT)
commitadbcf19958300e9b6598990184c8815b945ba0ee (patch)
treef4283c850ac0ac202c17e78a637ee7ca8147621b /abs/core/libmpc/PKGBUILD
parent61a68250df10d29b624650948484898334ff22d0 (diff)
downloadlinhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.zip
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.gz
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.bz2
Removed old core and extra from repo. Renamed -testing to core/extra. This will setup the base for the testing branch.
Diffstat (limited to 'abs/core/libmpc/PKGBUILD')
-rw-r--r--abs/core/libmpc/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/abs/core/libmpc/PKGBUILD b/abs/core/libmpc/PKGBUILD
new file mode 100644
index 0000000..9aad761
--- /dev/null
+++ b/abs/core/libmpc/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id: PKGBUILD 82441 2010-06-11 06:42:48Z allan $
+# Maintainer: Allan McRae <allan@archlinux.org>
+
+pkgname=libmpc
+pkgver=0.8.2
+pkgrel=2
+pkgdesc="Library for the arithmetic of complex numbers with arbitrarily high precision"
+arch=('i686' 'x86_64')
+url="http://www.multiprecision.org"
+license=('LGPL')
+depends=('mpfr>=3.0.0')
+options=('!libtool')
+install=libmpc.install
+source=(http://www.multiprecision.org/mpc/download/mpc-${pkgver/_/-}.tar.gz)
+md5sums=('e98267ebd5648a39f881d66797122fb6')
+
+build() {
+ cd $srcdir/mpc-$pkgver
+ ./configure --prefix=/usr
+ make
+ make check
+}
+
+package() {
+ cd $srcdir/mpc-$pkgver
+ make DESTDIR=$pkgdir/ install
+ mv -f $pkgdir/usr/share/info/{mpc,libmpc}.info
+}