summaryrefslogtreecommitdiffstats
path: root/abs/core/libmpc/libmpc-0.9-configure_cflags_egrep_issue.patch
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 15:03:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 15:03:09 (GMT)
commite6e06e9055ca7dd75c2542678e5cdf0713dee03b (patch)
tree7ba731637f0b4b5e7f43671020ea164de19a8595 /abs/core/libmpc/libmpc-0.9-configure_cflags_egrep_issue.patch
parenteafc443f473bd647ca47fce47c0b48ea91662f76 (diff)
downloadlinhes_pkgbuild-e6e06e9055ca7dd75c2542678e5cdf0713dee03b.zip
linhes_pkgbuild-e6e06e9055ca7dd75c2542678e5cdf0713dee03b.tar.gz
linhes_pkgbuild-e6e06e9055ca7dd75c2542678e5cdf0713dee03b.tar.bz2
libmpc: 0.9
Diffstat (limited to 'abs/core/libmpc/libmpc-0.9-configure_cflags_egrep_issue.patch')
-rw-r--r--abs/core/libmpc/libmpc-0.9-configure_cflags_egrep_issue.patch63
1 files changed, 63 insertions, 0 deletions
diff --git a/abs/core/libmpc/libmpc-0.9-configure_cflags_egrep_issue.patch b/abs/core/libmpc/libmpc-0.9-configure_cflags_egrep_issue.patch
new file mode 100644
index 0000000..3bf3247
--- /dev/null
+++ b/abs/core/libmpc/libmpc-0.9-configure_cflags_egrep_issue.patch
@@ -0,0 +1,63 @@
+--- trunk/configure.ac 2011/02/21 12:18:31 932
++++ trunk/configure.ac 2011/02/21 16:41:09 936
+@@ -33,7 +33,7 @@
+ AC_CANONICAL_HOST
+ AC_CONFIG_MACRO_DIR([m4])
+
+-dnl Extra arguments to configure
++# Extra arguments to configure
+ AC_ARG_WITH([mpfr_include],
+ [AC_HELP_STRING([--with-mpfr-include=DIR],
+ [MPFR include directory])],
+@@ -85,18 +85,19 @@
+ )
+
+
+-dnl Setup CC and CFLAGS
++# Setup CC and CFLAGS
++AC_PROG_CC
++AC_LANG(C)
+
+-dnl Check for user specification of CC or CFLAGS
++# Set up LibTool
++AC_PROG_LIBTOOL
++
++# Check for user specification of CC or CFLAGS
+ if test -n "$CFLAGS" || test -n "$CC" ; then
+ user_redefine_cc=yes
+ fi
+
+-# Check for programs
+-AC_PROG_CC
+-AC_LANG(C)
+-
+-dnl Check GMP Header
++# Check GMP Header
+ AC_MSG_CHECKING(for gmp.h)
+ AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
+ #include "gmp.h"
+@@ -105,22 +106,19 @@
+ AC_MSG_ERROR([gmp.h can't be found, or is unusable.])
+ ])
+
+-dnl Check for GMP CFLAGS in gmp.h
++# Check for GMP CFLAGS in gmp.h
+ if test -z "$user_redefine_cc" ; then
+ MPC_GMP_CC_CFLAGS
+ fi
+
+
+-dnl Configs for Windows DLLs
++# Configs for Windows DLLs
+ case $host in
+ *-*-cygwin* | *-*-mingw* | *-*-pw32* | *-*-os2*)
+ MPC_WINDOWS
+ esac
+
+
+-dnl Finally set up LibTool
+-AC_PROG_LIBTOOL
+-
+ # Checks for header files.
+ AC_HEADER_STDC
+ AC_CHECK_HEADERS([complex.h locale.h inttypes.h stdint.h limits.h unistd.h sys/time.h])