summaryrefslogtreecommitdiffstats
path: root/abs/core/libnl1
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2013-01-23 23:45:45 (GMT)
committerJames Meyer <james.meyer@operamail.com>2013-01-23 23:45:45 (GMT)
commit879fd1c6e6a0fc060866f810956b00be2d1792cf (patch)
treeab2e1feabcc4112ff6d600dcc04935da07942f02 /abs/core/libnl1
parent608387a01077ddd0733a46e47cee06c304bf62e3 (diff)
downloadlinhes_pkgbuild-879fd1c6e6a0fc060866f810956b00be2d1792cf.zip
linhes_pkgbuild-879fd1c6e6a0fc060866f810956b00be2d1792cf.tar.gz
linhes_pkgbuild-879fd1c6e6a0fc060866f810956b00be2d1792cf.tar.bz2
libnl1: needed by ceton usb userspace program
refs #899
Diffstat (limited to 'abs/core/libnl1')
-rw-r--r--abs/core/libnl1/PKGBUILD28
-rw-r--r--abs/core/libnl1/fix-compilation.patch10
2 files changed, 38 insertions, 0 deletions
diff --git a/abs/core/libnl1/PKGBUILD b/abs/core/libnl1/PKGBUILD
new file mode 100644
index 0000000..7d0c36f
--- /dev/null
+++ b/abs/core/libnl1/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id$
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Contributor: William Rea <sillywilly@gmail.com>
+
+pkgname=libnl1
+pkgver=1.1
+pkgrel=1
+pkgdesc="Library for applications dealing with netlink sockets (Legacy version)"
+arch=('i686' 'x86_64')
+url="http://www.infradead.org/~tgr/libnl/"
+license=('GPL')
+depends=('glibc')
+source=("http://www.infradead.org/~tgr/libnl/files/libnl-${pkgver}.tar.gz"
+ 'fix-compilation.patch')
+md5sums=('ae970ccd9144e132b68664f98e7ceeb1'
+ 'e1f5e82c8aa1b3ad025c7b588178de1e')
+
+build() {
+ cd ${srcdir}/libnl-${pkgver}
+ patch -Np1 -i ${srcdir}/fix-compilation.patch
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${srcdir}/libnl-${pkgver}
+ make DESTDIR=${pkgdir} install
+}
diff --git a/abs/core/libnl1/fix-compilation.patch b/abs/core/libnl1/fix-compilation.patch
new file mode 100644
index 0000000..891562a
--- /dev/null
+++ b/abs/core/libnl1/fix-compilation.patch
@@ -0,0 +1,10 @@
+--- libnl-1.1.orig/include/netlink-local.h 2008-01-14 16:48:45.000000000 +0100
++++ libnl-1.1/include/netlink-local.h 2009-06-26 11:15:33.186011844 +0200
+@@ -26,6 +26,7 @@
+ #include <sys/socket.h>
+ #include <inttypes.h>
+ #include <assert.h>
++#include <limits.h>
+
+ #include <arpa/inet.h>
+ #include <netdb.h>