summaryrefslogtreecommitdiffstats
path: root/abs/core/libpcap
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 15:58:23 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 15:58:23 (GMT)
commit292d861de977bfc9db2b226219816585dc5e1f51 (patch)
tree1e294bb0c66f842609e3c124c966e7bed7a7343c /abs/core/libpcap
parent2e50d19952b91fbc625eded6976130f0cf5fd224 (diff)
downloadlinhes_pkgbuild-292d861de977bfc9db2b226219816585dc5e1f51.zip
linhes_pkgbuild-292d861de977bfc9db2b226219816585dc5e1f51.tar.gz
linhes_pkgbuild-292d861de977bfc9db2b226219816585dc5e1f51.tar.bz2
libpcag 1.3.0
Diffstat (limited to 'abs/core/libpcap')
-rw-r--r--abs/core/libpcap/PKGBUILD29
-rw-r--r--abs/core/libpcap/__changelog1
-rw-r--r--abs/core/libpcap/libnl32.patch19
3 files changed, 36 insertions, 13 deletions
diff --git a/abs/core/libpcap/PKGBUILD b/abs/core/libpcap/PKGBUILD
index d471be1..ddafe52 100644
--- a/abs/core/libpcap/PKGBUILD
+++ b/abs/core/libpcap/PKGBUILD
@@ -1,31 +1,33 @@
-# $Id: PKGBUILD 77149 2010-04-11 11:02:48Z thomas $
+# $Id: PKGBUILD 162746 2012-06-29 11:46:18Z thomas $
# Maintainer: Thomas Bächler <thomas@archlinux.org>
pkgname=libpcap
-pkgver=1.1.1
+pkgver=1.3.0
pkgrel=1
pkgdesc="A system-independent interface for user-level packet capture"
arch=('i686' 'x86_64')
url="http://www.tcpdump.org/"
license=('BSD')
-depends=('glibc' 'libnl')
+depends=('glibc' 'libnl' 'sh' 'libusbx')
makedepends=('flex')
-source=(http://www.tcpdump.org/release/libpcap-${pkgver}.tar.gz)
-sha256sums=('508cca15547e55d1318498b838456a21770c450beb2dc7d7d4a96d90816e5a85')
+source=(http://www.tcpdump.org/release/libpcap-${pkgver}.tar.gz{,.sig}
+ libnl32.patch)
build() {
cd ${srcdir}/${pkgname}-${pkgver}
- ./configure --prefix=/usr --enable-ipv6
- make || return 1
- make shared || return 1
+ patch -Np1 -i "${srcdir}/libnl32.patch"
+ autoreconf -f -i
+ ./configure --prefix=/usr --enable-ipv6 --with-libnl
+ make
}
+
package() {
cd ${srcdir}/${pkgname}-${pkgver}
-
install -d -m755 ${pkgdir}/usr/bin
- make DESTDIR=${pkgdir} install install-shared || return 1
-# ln -s libpcap.so.${pkgver} ${pkgdir}/usr/lib/libpcap.so.1
-# ln -s libpcap.so.${pkgver} ${pkgdir}/usr/lib/libpcap.so
+ make DESTDIR=${pkgdir} install
+ # remove static library
+ rm -rf ${pkgdir}/usr/lib/libpcap.a
+
# backwards compatibility, programs often look for net/bpf.h
mkdir -p ${pkgdir}/usr/include/net
cd ${pkgdir}/usr/include/net
@@ -34,3 +36,6 @@ package() {
#install the license
install -D -m644 ${srcdir}/$pkgname-$pkgver/LICENSE ${pkgdir}/usr/share/licenses/$pkgname/LICENSE
}
+md5sums=('f78455a92622b7a3c05c58b6ad1cec7e'
+ 'acf4f6ed8c7839dc935e807a2731316e'
+ 'd2c8c21d69d90d6370022583bfb29cf2')
diff --git a/abs/core/libpcap/__changelog b/abs/core/libpcap/__changelog
deleted file mode 100644
index 381637b..0000000
--- a/abs/core/libpcap/__changelog
+++ /dev/null
@@ -1 +0,0 @@
-PKGBUILD: comment out calls to create symlinks to libpcap.so...they already exist
diff --git a/abs/core/libpcap/libnl32.patch b/abs/core/libpcap/libnl32.patch
new file mode 100644
index 0000000..633fd00
--- /dev/null
+++ b/abs/core/libpcap/libnl32.patch
@@ -0,0 +1,19 @@
+diff -u -r libpcap-1.2.1/configure.in libpcap-1.2.1-libnl32/configure.in
+--- libpcap-1.2.1/configure.in 2012-01-02 01:47:37.000000000 +0100
++++ libpcap-1.2.1-libnl32/configure.in 2012-02-09 19:29:29.405603749 +0100
+@@ -433,12 +433,13 @@
+ #
+ # Try libnl 2.x first.
+ #
+- AC_CHECK_LIB(nl, nl_socket_alloc,
++ AC_CHECK_LIB(nl-3, nl_socket_alloc,
+ [
+ #
+ # Yes, we have libnl 2.x.
+ #
+- LIBS="-lnl-genl -lnl $LIBS"
++ LIBS="$(pkg-config --libs libnl-genl-3.0 libnl-3.0) $LIBS"
++ V_INCLS="$V_INCLS $(pkg-config --cflags libnl-genl-3.0 libnl-3.0)"
+ AC_DEFINE(HAVE_LIBNL,1,[if libnl exists])
+ AC_DEFINE(HAVE_LIBNL_2_x,1,[if libnl exists and is version 2.x])
+ ],