summaryrefslogtreecommitdiffstats
path: root/abs/core/libraw1394
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-10-23 18:17:40 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-10-23 18:19:39 (GMT)
commitadbcf19958300e9b6598990184c8815b945ba0ee (patch)
treef4283c850ac0ac202c17e78a637ee7ca8147621b /abs/core/libraw1394
parent61a68250df10d29b624650948484898334ff22d0 (diff)
downloadlinhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.zip
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.gz
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.bz2
Removed old core and extra from repo. Renamed -testing to core/extra. This will setup the base for the testing branch.
Diffstat (limited to 'abs/core/libraw1394')
-rw-r--r--abs/core/libraw1394/PKGBUILD19
-rw-r--r--abs/core/libraw1394/libraw1394.install18
2 files changed, 9 insertions, 28 deletions
diff --git a/abs/core/libraw1394/PKGBUILD b/abs/core/libraw1394/PKGBUILD
index b1065fd..6b6c4bb 100644
--- a/abs/core/libraw1394/PKGBUILD
+++ b/abs/core/libraw1394/PKGBUILD
@@ -1,24 +1,23 @@
-# $Id: PKGBUILD 13741 2008-09-28 13:27:16Z giovanni $
+# $Id: PKGBUILD 63209 2010-01-16 07:32:59Z tpowa $
# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
pkgname=libraw1394
-pkgver=2.0.2
-pkgrel=3
+pkgver=2.0.5
+pkgrel=1
arch=('i686' 'x86_64')
-license=('LGPL')
+license=('LGPL2.1')
pkgdesc="Provides an API to the Linux IEEE1394 (FireWire) driver"
depends=('glibc')
makedepends=('pkgconfig')
url="http://www.linux1394.org/"
options=(!libtool force)
-install=libraw1394.install
-source=(http://www.linux1394.org/dl/${pkgname}-${pkgver}.tar.gz)
-md5sums=('9fbbef5ea31101c4c28085db134fd448')
+source=(http://downloads.sourceforge.net/project/libraw1394/libraw1394/${pkgname}-${pkgver}.tar.gz)
build() {
- cd ${startdir}/src/${pkgname}-${pkgver}
- ./configure --prefix=/usr
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr || return 1
make || return 1
- make DESTDIR=${startdir}/pkg install
+ make DESTDIR="${pkgdir}" install || return 1
}
+md5sums=('1db64231c78540c32859b591cb8b40cf')
diff --git a/abs/core/libraw1394/libraw1394.install b/abs/core/libraw1394/libraw1394.install
deleted file mode 100644
index 33fb64c..0000000
--- a/abs/core/libraw1394/libraw1394.install
+++ /dev/null
@@ -1,18 +0,0 @@
-# arg 1: the new package version
-post_install() {
- ln -s /usr/lib/libraw1394.so.11.0.1 /usr/lib/libraw1394.so.8
-}
-# arg 1: the new package version
-# arg 2: the old package version
-post_upgrade() {
- /bin/true
-}
-
-# arg 1: the old package version
-post_remove() {
- rm -fr /usr/lib/libraw1394.so.8
-}
-
-op=$1
-shift
-$op $*