summaryrefslogtreecommitdiffstats
path: root/abs/core/librsvg
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 16:04:03 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 16:04:03 (GMT)
commit9b52b29dd1f40f1fffea8fe268ab833c2db8b293 (patch)
tree1969992186e6a9251a26e42950c7d913712ed346 /abs/core/librsvg
parentbe86e5b1da94cf073fc3b31e5efb110eeccb51d6 (diff)
downloadlinhes_pkgbuild-9b52b29dd1f40f1fffea8fe268ab833c2db8b293.zip
linhes_pkgbuild-9b52b29dd1f40f1fffea8fe268ab833c2db8b293.tar.gz
linhes_pkgbuild-9b52b29dd1f40f1fffea8fe268ab833c2db8b293.tar.bz2
librsvg: 2.36.1
Diffstat (limited to 'abs/core/librsvg')
-rw-r--r--abs/core/librsvg/PKGBUILD29
-rw-r--r--abs/core/librsvg/librsvg.install2
2 files changed, 14 insertions, 17 deletions
diff --git a/abs/core/librsvg/PKGBUILD b/abs/core/librsvg/PKGBUILD
index 41cbf51..284f405 100644
--- a/abs/core/librsvg/PKGBUILD
+++ b/abs/core/librsvg/PKGBUILD
@@ -1,31 +1,28 @@
-# $Id: PKGBUILD 99478 2010-11-14 19:57:09Z ibiru $
+# $Id: PKGBUILD 156916 2012-04-23 09:09:00Z ibiru $
# Maintainer: Jan de Groot <jgc@archlinux.org>
pkgname=librsvg
-pkgver=2.32.1
+pkgver=2.36.1
pkgrel=1
-pkgdesc="SAX-based renderer for SVG files into a GdkPixbuf"
+pkgdesc="A SVG viewing library"
arch=(i686 x86_64)
license=('LGPL')
-depends=('gtk2>=2.22.0' 'libcroco>=0.6.2')
-makedepends=('intltool' 'gtk-doc')
-optdepends=('python2: rsvg commandline utility')
-options=('!libtool')
+depends=('gdk-pixbuf2' 'pango' 'libcroco')
+makedepends=('intltool' 'gtk2' 'gtk3' 'gobject-introspection')
+optdepends=('gtk3: for rsvg-view-3')
+options=('!libtool' '!emptydirs')
url="http://librsvg.sourceforge.net/"
install=librsvg.install
-source=(http://ftp.gnome.org/pub/gnome/sources/${pkgname}/2.32/${pkgname}-${pkgver}.tar.bz2)
-sha256sums=('91b98051f352fab8a6257688d6b2fd665b4648ed66144861f2f853ccf876d334')
+source=(http://ftp.gnome.org/pub/gnome/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz)
+sha256sums=('786b95e1a091375c5ef2997a21c69ff24d7077afeff18197355f54d9dcbcd8c5')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- sed -i 's|#!/usr/bin/env python|#!/usr/bin/env python2|' rsvg.in
- ./configure --prefix=/usr --libexecdir=/usr/lib/${pkgname} \
- --with-croco --disable-static \
- --with-svgz --enable-gtk-theme
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr --disable-static
make
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
}
diff --git a/abs/core/librsvg/librsvg.install b/abs/core/librsvg/librsvg.install
index 4d48b07..8852ebf 100644
--- a/abs/core/librsvg/librsvg.install
+++ b/abs/core/librsvg/librsvg.install
@@ -1,5 +1,5 @@
post_install() {
- usr/bin/gdk-pixbuf-query-loaders --update-cache
+ gdk-pixbuf-query-loaders --update-cache
}
post_upgrade() {