summaryrefslogtreecommitdiffstats
path: root/abs/core/libssh2
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 16:04:53 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 16:04:53 (GMT)
commit463536a962ced0cdfc83cfd401bb55e8e1baa5bb (patch)
tree4aff876c11922cef5731a325cc0b96c6f6995f98 /abs/core/libssh2
parent2703c0f66fd357e0dcd67d7a96e83aa2480c4ff9 (diff)
downloadlinhes_pkgbuild-463536a962ced0cdfc83cfd401bb55e8e1baa5bb.zip
linhes_pkgbuild-463536a962ced0cdfc83cfd401bb55e8e1baa5bb.tar.gz
linhes_pkgbuild-463536a962ced0cdfc83cfd401bb55e8e1baa5bb.tar.bz2
libssh2 1.4.2
-new
Diffstat (limited to 'abs/core/libssh2')
-rw-r--r--abs/core/libssh2/PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/abs/core/libssh2/PKGBUILD b/abs/core/libssh2/PKGBUILD
new file mode 100644
index 0000000..520b900
--- /dev/null
+++ b/abs/core/libssh2/PKGBUILD
@@ -0,0 +1,35 @@
+# $Id: PKGBUILD 159788 2012-05-27 02:25:20Z dreisner $
+# Maintainer: Dave Reisner <dreisner@archlinux.org>
+# Contributor: Angel Velasquez <angvp@archlinux.org>
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: ice-man <icemanf@gmail.com>
+
+pkgname=libssh2
+pkgver=1.4.2
+pkgrel=1
+pkgdesc="A library implementing the SSH2 protocol as defined by Internet Drafts"
+url="http://www.libssh2.org/"
+arch=('i686' 'x86_64')
+license=('BSD')
+depends=('openssl')
+makedepends=('zlib')
+provides=('libssh2.so')
+options=('!libtool')
+source=("http://www.libssh2.org/download/$pkgname-$pkgver.tar.gz"{,.asc})
+md5sums=('42e2b3796ac07fc1dbafc7abcc002cd3'
+ '872cfb1d61dbd5acd0481ab030e8f130')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}