summaryrefslogtreecommitdiffstats
path: root/abs/core/libtheora
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-10 03:43:31 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-10 03:43:31 (GMT)
commit010767e44afff890ce9ad23518045f202ce46a03 (patch)
tree02454d3d0f4e26f0c60a5046186291740e279ee2 /abs/core/libtheora
parent001863024fe91e8ce106bde5ce0aae5641d6b54a (diff)
downloadlinhes_pkgbuild-010767e44afff890ce9ad23518045f202ce46a03.zip
linhes_pkgbuild-010767e44afff890ce9ad23518045f202ce46a03.tar.gz
linhes_pkgbuild-010767e44afff890ce9ad23518045f202ce46a03.tar.bz2
lintheora: update to latest
Diffstat (limited to 'abs/core/libtheora')
-rw-r--r--abs/core/libtheora/PKGBUILD24
1 files changed, 13 insertions, 11 deletions
diff --git a/abs/core/libtheora/PKGBUILD b/abs/core/libtheora/PKGBUILD
index b0ee1ac..1592aa5 100644
--- a/abs/core/libtheora/PKGBUILD
+++ b/abs/core/libtheora/PKGBUILD
@@ -1,26 +1,28 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# $Id: PKGBUILD 57638 2009-11-01 07:56:06Z eric $
# Maintainer: Tom Killian <tom@archlinux.org>
# Committer: dorphell <dorphell@archlinux.org>
pkgname=libtheora
-pkgver=1.0beta1
+pkgver=1.1.1
pkgrel=1
pkgdesc="An open video codec developed by the Xiph.org"
arch=('i686' 'x86_64')
+url="http://www.xiph.org"
+license=('BSD')
depends=('libogg')
makedepends=('libvorbis')
-url=http://www.xiph.org
-license=('custom')
+options=('!libtool')
source=(http://downloads.xiph.org/releases/theora/libtheora-${pkgver}.tar.bz2)
+md5sums=('292ab65cedd5021d6b7ddd117e07cd8e')
+sha1sums=('8dcaa8e61cd86eb1244467c0b64b9ddac04ae262')
build() {
- cd ${startdir}/src/libtheora-${pkgver}
- ./configure --prefix=/usr --enable-shared
+ cd "${srcdir}/libtheora-${pkgver}"
+ ./configure --prefix=/usr --enable-shared --disable-static || return 1
make || return 1
- make DESTDIR=${startdir}/pkg install
+ make DESTDIR="${pkgdir}" install || return 1
- for file in LICENSE COPYING ; do
- install -D $file $startdir/pkg/usr/share/licenses/libtheora/$file
- done
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 LICENSE COPYING "${pkgdir}/usr/share/licenses/${pkgname}/" || return 1
}
-md5sums=('e2ff1996c5a9fadd0df1025aa10bc35e')
+