summaryrefslogtreecommitdiffstats
path: root/abs/core/libusbx
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 16:08:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 16:08:09 (GMT)
commit92c8ef68ec9d323a2ee6768da6b845e000391577 (patch)
treef1e59ef7190e44f2c36fb61e7feac0eca2907cad /abs/core/libusbx
parent3bf0a84f2d236f0d87f77823310c9df98d04d537 (diff)
downloadlinhes_pkgbuild-92c8ef68ec9d323a2ee6768da6b845e000391577.zip
linhes_pkgbuild-92c8ef68ec9d323a2ee6768da6b845e000391577.tar.gz
linhes_pkgbuild-92c8ef68ec9d323a2ee6768da6b845e000391577.tar.bz2
libusbx 1.0.12
Diffstat (limited to 'abs/core/libusbx')
-rw-r--r--abs/core/libusbx/PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/abs/core/libusbx/PKGBUILD b/abs/core/libusbx/PKGBUILD
new file mode 100644
index 0000000..2c2795f
--- /dev/null
+++ b/abs/core/libusbx/PKGBUILD
@@ -0,0 +1,32 @@
+# $Id: PKGBUILD 162758 2012-06-29 16:50:44Z tpowa $
+# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
+pkgname=libusbx
+pkgver=1.0.12
+pkgrel=2
+depends=('glibc')
+pkgdesc="Library that provides generic access to USB device"
+arch=(i686 x86_64)
+url="http://libusbx.org"
+license=('LGPL')
+source=(http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.bz2)
+options=(!libtool)
+replaces=('libusb1' 'libusb')
+provides=("libusb=$pkgver")
+conflicts=("libusb")
+md5sums=('c41352ac755c7992edfcbb2ea4ad1349')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr --disable-static
+ make
+}
+
+check() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make check
+}
+
+package () {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}