summaryrefslogtreecommitdiffstats
path: root/abs/core/libvdpau
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 16:08:32 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 16:08:32 (GMT)
commitaa565195d10bc2f5a96a2ed97a9d616443c1d636 (patch)
tree91410908322503ca3618dcd9ea6fd3afd6f90675 /abs/core/libvdpau
parent92c8ef68ec9d323a2ee6768da6b845e000391577 (diff)
downloadlinhes_pkgbuild-aa565195d10bc2f5a96a2ed97a9d616443c1d636.zip
linhes_pkgbuild-aa565195d10bc2f5a96a2ed97a9d616443c1d636.tar.gz
linhes_pkgbuild-aa565195d10bc2f5a96a2ed97a9d616443c1d636.tar.bz2
libvdpau: .4.1
Diffstat (limited to 'abs/core/libvdpau')
-rw-r--r--abs/core/libvdpau/PKGBUILD23
1 files changed, 12 insertions, 11 deletions
diff --git a/abs/core/libvdpau/PKGBUILD b/abs/core/libvdpau/PKGBUILD
index 283eb43..bb012a8 100644
--- a/abs/core/libvdpau/PKGBUILD
+++ b/abs/core/libvdpau/PKGBUILD
@@ -1,29 +1,30 @@
-# $Id: $
+# $Id: PKGBUILD 143891 2011-11-30 19:04:39Z andrea $
# Maintainer: Jan de Groot <jgc@archlinux.org>
pkgname=libvdpau
pkgver=0.4.1
pkgrel=2
-pkgdesc="NVIDIA VDPAU library"
-arch=('i686' 'x86_64')
-url=http://cgit.freedesktop.org/~aplattner/libvdpau
-depends=('gcc-libs>=4.3.3')
+pkgdesc="Nvidia VDPAU library"
+arch=(i686 x86_64)
+url='http://cgit.freedesktop.org/~aplattner/libvdpau'
+depends=('gcc-libs')
conflicts=('nvidia-utils<190.42-2')
-options=('!libtool' 'force')
+options=('!libtool')
license=('custom')
source=(http://people.freedesktop.org/~aplattner/vdpau/${pkgname}-${pkgver}.tar.gz)
makedepends=('libx11')
+sha256sums=('061b6f86c64912f79851bfefcac4f77b401e9a939dbbb7b1ec795bc7d5aaf59b')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- ./configure --prefix=/usr || return 1
- make || return 1
+ ./configure --prefix=/usr
+ make
}
+
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install || return 1
+ make DESTDIR="${pkgdir}" install
install -d -m755 "${pkgdir}/usr/share/licenses/${pkgname}"
- install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/" || return 1
+ install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"
}
-md5sums=('8e1f0639bea4e4a842aee93ab64406cc')