summaryrefslogtreecommitdiffstats
path: root/abs/core/libvorbis
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-12 21:58:14 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-12 21:58:14 (GMT)
commit284c262fc85db9ffdbb68e50bd12ac1f8cbe4597 (patch)
tree48fb92365aba249ce9bc9442426a0bbaf693cb2e /abs/core/libvorbis
parentdb5b09675fdd843f31a2d997ed28c58b42deb3ad (diff)
downloadlinhes_pkgbuild-284c262fc85db9ffdbb68e50bd12ac1f8cbe4597.zip
linhes_pkgbuild-284c262fc85db9ffdbb68e50bd12ac1f8cbe4597.tar.gz
linhes_pkgbuild-284c262fc85db9ffdbb68e50bd12ac1f8cbe4597.tar.bz2
libvorbis: update to latest
Diffstat (limited to 'abs/core/libvorbis')
-rw-r--r--abs/core/libvorbis/PKGBUILD30
1 files changed, 18 insertions, 12 deletions
diff --git a/abs/core/libvorbis/PKGBUILD b/abs/core/libvorbis/PKGBUILD
index c655b95..6d65a11 100644
--- a/abs/core/libvorbis/PKGBUILD
+++ b/abs/core/libvorbis/PKGBUILD
@@ -1,24 +1,30 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
-# Maintainer: dorphell <dorphell@archlinux.org>
+# $Id: PKGBUILD 77086 2010-04-10 16:22:41Z andrea $
+# Maintainer: Tobias Kieslich <tobias@archlinux.org>
+# Contributor: dorphell <dorphell@archlinux.org>
# Contributor: John Proctor <jproctor@prium.net>
pkgname=libvorbis
-pkgver=1.2.0
+pkgver=1.3.1
pkgrel=1
pkgdesc="Vorbis codec library"
-arch=(i686 x86_64)
+arch=('i686' 'x86_64')
license=('custom')
url="http://www.xiph.org/ogg/vorbis/"
-depends=('glibc' 'libogg')
-source=(http://downloads.xiph.org/releases/vorbis/$pkgname-$pkgver.tar.gz)
-md5sums=('478646358c49f34aedcce58948793619')
-
+depends=('libogg')
+options=('!libtool')
+source=(http://downloads.xiph.org/releases/vorbis/${pkgname}-${pkgver}.tar.gz)
+md5sums=('016e523fac70bdd786258a9d15fd36e9')
build() {
- cd $startdir/src/${pkgname}-${pkgver}
+ cd ${srcdir}/${pkgname}-${pkgver}
#-march=i686 optimizes too much, strip it out
- CFLAGS=${CFLAGS/-march=$CARCH} ./configure --prefix=/usr --disable-static
+ CFLAGS=${CFLAGS/-march=$CARCH} ./configure --prefix=/usr --disable-static || return 1
make || return 1
- make DESTDIR=$startdir/pkg install
- install -Dm644 COPYING $startdir/pkg/usr/share/licenses/$pkgname/COPYING
}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install || return 1
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/$pkgname/LICENSE" || return 1
+}
+