summaryrefslogtreecommitdiffstats
path: root/abs/core/libvorbis
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 16:09:08 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 16:09:08 (GMT)
commit48a36b747fff594cb8e8db478ee44ca8774537e0 (patch)
tree687b933493f0cc56809abacfc8ef18cc4bfdddec /abs/core/libvorbis
parent5d965474ae29e3c0b454f21be96d512974e8f6f9 (diff)
downloadlinhes_pkgbuild-48a36b747fff594cb8e8db478ee44ca8774537e0.zip
linhes_pkgbuild-48a36b747fff594cb8e8db478ee44ca8774537e0.tar.gz
linhes_pkgbuild-48a36b747fff594cb8e8db478ee44ca8774537e0.tar.bz2
libvorbis 1.3.3
Diffstat (limited to 'abs/core/libvorbis')
-rw-r--r--abs/core/libvorbis/PKGBUILD28
1 files changed, 16 insertions, 12 deletions
diff --git a/abs/core/libvorbis/PKGBUILD b/abs/core/libvorbis/PKGBUILD
index 6d65a11..20b4270 100644
--- a/abs/core/libvorbis/PKGBUILD
+++ b/abs/core/libvorbis/PKGBUILD
@@ -1,30 +1,34 @@
-# $Id: PKGBUILD 77086 2010-04-10 16:22:41Z andrea $
+# $Id: PKGBUILD 149459 2012-02-08 04:00:58Z eric $
# Maintainer: Tobias Kieslich <tobias@archlinux.org>
# Contributor: dorphell <dorphell@archlinux.org>
# Contributor: John Proctor <jproctor@prium.net>
pkgname=libvorbis
-pkgver=1.3.1
+pkgver=1.3.3
pkgrel=1
pkgdesc="Vorbis codec library"
arch=('i686' 'x86_64')
-license=('custom')
-url="http://www.xiph.org/ogg/vorbis/"
+url="http://www.xiph.org/vorbis/"
+license=('BSD')
depends=('libogg')
options=('!libtool')
source=(http://downloads.xiph.org/releases/vorbis/${pkgname}-${pkgver}.tar.gz)
-md5sums=('016e523fac70bdd786258a9d15fd36e9')
+md5sums=('6b1a36f0d72332fae5130688e65efe1f')
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd "${srcdir}/${pkgname}-${pkgver}"
#-march=i686 optimizes too much, strip it out
- CFLAGS=${CFLAGS/-march=$CARCH} ./configure --prefix=/usr --disable-static || return 1
- make || return 1
+ CFLAGS=${CFLAGS/-march=$CARCH} LIBS+="-lm" ./configure --prefix=/usr --disable-static
+ make
}
-package() {
- cd ${srcdir}/${pkgname}-${pkgver}
- make DESTDIR="${pkgdir}" install || return 1
- install -Dm644 COPYING "${pkgdir}/usr/share/licenses/$pkgname/LICENSE" || return 1
+check() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make -j1 check
}
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
+}