summaryrefslogtreecommitdiffstats
path: root/abs/core/libxcb
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
commit7b29169fff9e7c624890c5edffe85def8a293136 (patch)
tree47753889faa3a2063b66d1c7e7681e703eb1b39a /abs/core/libxcb
parentc491dea779dac29afff3578bf8245943817c2339 (diff)
downloadlinhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.zip
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.gz
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.bz2
LinHES 6.01.00
Diffstat (limited to 'abs/core/libxcb')
-rw-r--r--abs/core/libxcb/PKGBUILD35
-rw-r--r--abs/core/libxcb/libxcb-1.1-no-pthread-stubs.patch12
-rw-r--r--abs/core/libxcb/libxcb-1.1-sloppy-lock.patch12
3 files changed, 43 insertions, 16 deletions
diff --git a/abs/core/libxcb/PKGBUILD b/abs/core/libxcb/PKGBUILD
index b1eadee..59982e9 100644
--- a/abs/core/libxcb/PKGBUILD
+++ b/abs/core/libxcb/PKGBUILD
@@ -1,29 +1,32 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# $Id: PKGBUILD 27498 2009-02-22 09:23:59Z andyrtr $
# Maintainer: Alexander Baldeck <alexander@archlinux.org>
# Contributor: Jan de Groot <jgc@archlinux.org>
pkgname=libxcb
-pkgver=1.1
+pkgver=1.2
pkgrel=1
pkgdesc="X11 client-side library"
arch=(i686 x86_64)
url="http://xcb.freedesktop.org/"
-depends=('xcb-proto>=1.1' 'libxdmcp' 'libxau')
-makedepends=('pkgconfig' 'libxslt' 'libpthread-stubs')
+depends=('xcb-proto>=1.4' 'libxdmcp' 'libxau')
+makedepends=('pkgconfig' 'libxslt' 'python')
+conflicts=('libx11<1.1.99.2')
options=('!libtool')
license=('custom')
-source=(${url}/dist/${pkgname}-${pkgver}.tar.bz2)
+source=(${url}/dist/${pkgname}-${pkgver}.tar.bz2
+ libxcb-1.1-no-pthread-stubs.patch)
+md5sums=('ae32b7846a7d83f5ec542a5431117564'
+ 'a53f09ab3ec5cbfc1b0848bd137c535a')
build() {
- cd ${startdir}/src/${pkgname}-${pkgver}
- ./configure --prefix=/usr \
- --build=${CHOST} --host=${CHOST}
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -Np1 -i "${srcdir}/libxcb-1.1-no-pthread-stubs.patch" || return 1
+ libtoolize --force --copy || return 1
+ aclocal || return 1
+ autoconf || return 1
+ automake --add-missing || return 1
+ ./configure --prefix=/usr --enable-xinput || return 1
make || return 1
- make DESTDIR=${startdir}/pkg install || return 1
- # Remove pthread-stubs dependency from pc files,
- # the stubs package doesn't provide any libs since our libc is complete.
- sed -i -e 's/pthread-stubs//' ${startdir}/pkg/usr/lib/pkgconfig/*.pc
-
- install -m644 -D ${startdir}/src/${pkgname}-${pkgver}/COPYING \
- ${startdir}/pkg/usr/share/licenses/${pkgname}/COPYING
+ make DESTDIR="${pkgdir}" install || return 1
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/" || return 1
}
-md5sums=('9310b02433273d75d42f10da3c7455aa')
diff --git a/abs/core/libxcb/libxcb-1.1-no-pthread-stubs.patch b/abs/core/libxcb/libxcb-1.1-no-pthread-stubs.patch
new file mode 100644
index 0000000..67a09f2
--- /dev/null
+++ b/abs/core/libxcb/libxcb-1.1-no-pthread-stubs.patch
@@ -0,0 +1,12 @@
+diff -up libxcb-1.1/configure.ac.pthread-stubs libxcb-1.1/configure.ac
+--- libxcb-1.1/configure.ac.pthread-stubs 2007-11-04 18:17:11.000000000 -0500
++++ libxcb-1.1/configure.ac 2007-11-12 10:27:06.000000000 -0500
+@@ -31,7 +31,7 @@ AC_SUBST(HTML_CHECK_RESULT)
+
+ # Checks for pkg-config packages
+ PKG_CHECK_MODULES(XCBPROTO, xcb-proto >= 1.1)
+-NEEDED="pthread-stubs xau >= 0.99.2"
++NEEDED="xau >= 0.99.2"
+ PKG_CHECK_MODULES(NEEDED, $NEEDED)
+
+ have_xdmcp="no"
diff --git a/abs/core/libxcb/libxcb-1.1-sloppy-lock.patch b/abs/core/libxcb/libxcb-1.1-sloppy-lock.patch
new file mode 100644
index 0000000..130890e
--- /dev/null
+++ b/abs/core/libxcb/libxcb-1.1-sloppy-lock.patch
@@ -0,0 +1,12 @@
+diff -up libxcb-1.1/src/xcb_conn.c.jx libxcb-1.1/src/xcb_conn.c
+--- libxcb-1.1/src/xcb_conn.c.jx 2007-10-28 16:11:18.000000000 -0400
++++ libxcb-1.1/src/xcb_conn.c 2008-04-22 11:58:05.000000000 -0400
+@@ -63,7 +63,7 @@ static int _xcb_xlib_init(_xcb_xlib *xli
+ {
+ xlib->lock = 0;
+ #ifndef NDEBUG
+- xlib->sloppy_lock = (getenv("LIBXCB_ALLOW_SLOPPY_LOCK") != 0);
++ xlib->sloppy_lock = 1;
+ #endif
+ pthread_cond_init(&xlib->cond, 0);
+ return 1;