summaryrefslogtreecommitdiffstats
path: root/abs/core/libxcb
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-15 22:14:18 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-15 22:14:18 (GMT)
commit92a7891867f0ea535076b479e32378d85e917e5f (patch)
tree910e785859ea1273150be77c8317ac550f5b23b7 /abs/core/libxcb
parentd0333c6ef9284d3f49c32bb4f016544c02270af5 (diff)
downloadlinhes_pkgbuild-92a7891867f0ea535076b479e32378d85e917e5f.zip
linhes_pkgbuild-92a7891867f0ea535076b479e32378d85e917e5f.tar.gz
linhes_pkgbuild-92a7891867f0ea535076b479e32378d85e917e5f.tar.bz2
libxcb: upgrade for libx11
Diffstat (limited to 'abs/core/libxcb')
-rw-r--r--abs/core/libxcb/PKGBUILD32
1 files changed, 18 insertions, 14 deletions
diff --git a/abs/core/libxcb/PKGBUILD b/abs/core/libxcb/PKGBUILD
index cbe31bd..e1b20ae 100644
--- a/abs/core/libxcb/PKGBUILD
+++ b/abs/core/libxcb/PKGBUILD
@@ -1,32 +1,36 @@
-# $Id: PKGBUILD 79958 2010-05-09 18:41:21Z jgc $
-# Maintainer: Alexander Baldeck <alexander@archlinux.org>
-# Contributor: Jan de Groot <jgc@archlinux.org>
+# $Id: PKGBUILD 88380 2010-08-23 08:02:28Z jgc $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Contributor: Alexander Baldeck <alexander@archlinux.org>
+
pkgname=libxcb
-pkgver=1.6
+pkgver=1.7
pkgrel=1
pkgdesc="X11 client-side library"
arch=(i686 x86_64)
url="http://xcb.freedesktop.org/"
depends=('xcb-proto>=1.6' 'libxdmcp' 'libxau')
-makedepends=('pkgconfig' 'libxslt' 'python')
+makedepends=('pkgconfig' 'libxslt' 'python2')
conflicts=('libx11<1.1.99.2')
options=('!libtool')
license=('custom')
source=(${url}/dist/${pkgname}-${pkgver}.tar.bz2
libxcb-1.1-no-pthread-stubs.patch)
-sha1sums=('b0a6fec4c02ec876f32bbd4b64ffe8a25f0da518'
+sha1sums=('7540f0587907bce421914f0ddb813810cb2f36f8'
'3455e84642283bc91c8313af319002a20bbcbdf4')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- patch -Np1 -i "${srcdir}/libxcb-1.1-no-pthread-stubs.patch" || return 1
- libtoolize --force --copy || return 1
- aclocal || return 1
- autoconf || return 1
- automake --add-missing || return 1
- ./configure --prefix=/usr --enable-xinput || return 1
+ patch -Np1 -i "${srcdir}/libxcb-1.1-no-pthread-stubs.patch"
+ libtoolize --force --copy
+ aclocal
+ autoconf
+ automake --add-missing
+ ./configure --prefix=/usr --enable-xinput
make || return 1
- make DESTDIR="${pkgdir}" install || return 1
+}
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
- install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/" || return 1
+ install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"
}