summaryrefslogtreecommitdiffstats
path: root/abs/core/libxcb
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 16:10:16 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 16:10:16 (GMT)
commita719cc6dbb5fb2954df57bf926c0d05f94cef1f1 (patch)
treec12a12063e9157e4e2fa9768d0cfcb9bcf02a3b1 /abs/core/libxcb
parenta17647e9bccec4e353f21d46350697008c2add4e (diff)
downloadlinhes_pkgbuild-a719cc6dbb5fb2954df57bf926c0d05f94cef1f1.zip
linhes_pkgbuild-a719cc6dbb5fb2954df57bf926c0d05f94cef1f1.tar.gz
linhes_pkgbuild-a719cc6dbb5fb2954df57bf926c0d05f94cef1f1.tar.bz2
libxcp 1.8.1
Diffstat (limited to 'abs/core/libxcb')
-rw-r--r--abs/core/libxcb/PKGBUILD34
-rw-r--r--abs/core/libxcb/libxcb-1.1-no-pthread-stubs.patch9
2 files changed, 19 insertions, 24 deletions
diff --git a/abs/core/libxcb/PKGBUILD b/abs/core/libxcb/PKGBUILD
index e1b20ae..2bbe1b9 100644
--- a/abs/core/libxcb/PKGBUILD
+++ b/abs/core/libxcb/PKGBUILD
@@ -1,36 +1,32 @@
-# $Id: PKGBUILD 88380 2010-08-23 08:02:28Z jgc $
+# $Id: PKGBUILD 153294 2012-03-12 20:52:27Z andyrtr $
# Maintainer: Jan de Groot <jgc@archlinux.org>
# Contributor: Alexander Baldeck <alexander@archlinux.org>
pkgname=libxcb
-pkgver=1.7
+pkgver=1.8.1
pkgrel=1
pkgdesc="X11 client-side library"
arch=(i686 x86_64)
url="http://xcb.freedesktop.org/"
-depends=('xcb-proto>=1.6' 'libxdmcp' 'libxau')
+depends=('xcb-proto>=1.7' 'libxdmcp' 'libxau')
makedepends=('pkgconfig' 'libxslt' 'python2')
-conflicts=('libx11<1.1.99.2')
options=('!libtool')
license=('custom')
-source=(${url}/dist/${pkgname}-${pkgver}.tar.bz2
+source=($url/dist/$pkgname-$pkgver.tar.bz2
libxcb-1.1-no-pthread-stubs.patch)
-sha1sums=('7540f0587907bce421914f0ddb813810cb2f36f8'
- '3455e84642283bc91c8313af319002a20bbcbdf4')
+sha1sums=('98199b6054750a06cddd4e77baa4354af547ce6f'
+ 'd2df03ddf3e949c10c2c185256b0eb7fa02837ab')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- patch -Np1 -i "${srcdir}/libxcb-1.1-no-pthread-stubs.patch"
- libtoolize --force --copy
- aclocal
- autoconf
- automake --add-missing
- ./configure --prefix=/usr --enable-xinput
- make || return 1
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -Np1 -i "$srcdir/libxcb-1.1-no-pthread-stubs.patch"
+ PYTHON=/usr/bin/python2 ./autogen.sh --prefix=/usr --enable-xinput
+ make
}
+
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
- install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
- install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ install -m755 -d "$pkgdir/usr/share/licenses/$pkgname"
+ install -m644 COPYING "$pkgdir/usr/share/licenses/$pkgname"
}
diff --git a/abs/core/libxcb/libxcb-1.1-no-pthread-stubs.patch b/abs/core/libxcb/libxcb-1.1-no-pthread-stubs.patch
index f17de1b..8e8162f 100644
--- a/abs/core/libxcb/libxcb-1.1-no-pthread-stubs.patch
+++ b/abs/core/libxcb/libxcb-1.1-no-pthread-stubs.patch
@@ -1,10 +1,9 @@
-diff -up libxcb-1.1/configure.ac.pthread-stubs libxcb-1.1/configure.ac
---- libxcb-1.1/configure.ac.pthread-stubs 2007-11-04 18:17:11.000000000 -0500
-+++ libxcb-1.1/configure.ac 2007-11-12 10:27:06.000000000 -0500
-@@ -31,7 +31,7 @@ AC_SUBST(HTML_CHECK_RESULT)
+--- libxcb-1.8.1/configure.ac 2012-03-09 15:38:38.000000000 +0100
++++ libxcb-1.8.1/configure.ac.new 2012-03-09 16:50:40.107109896 +0100
+@@ -35,7 +35,7 @@
# Checks for pkg-config packages
- PKG_CHECK_MODULES(XCBPROTO, xcb-proto >= 1.6)
+ PKG_CHECK_MODULES(XCBPROTO, xcb-proto >= 1.7)
-NEEDED="pthread-stubs xau >= 0.99.2"
+NEEDED="xau >= 0.99.2"
PKG_CHECK_MODULES(NEEDED, $NEEDED)