summaryrefslogtreecommitdiffstats
path: root/abs/core/libxcomposite/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 19:13:01 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 19:13:01 (GMT)
commit71ac83dbf7f36d10f39f3a3fe907b674d1abcb62 (patch)
treed7ce3c5d0b4f63e9838ae48201c1dc55fd857ce2 /abs/core/libxcomposite/PKGBUILD
parent22ea84ac6f7d6bee05c12e3bff8672fbad753ea3 (diff)
downloadlinhes_pkgbuild-71ac83dbf7f36d10f39f3a3fe907b674d1abcb62.zip
linhes_pkgbuild-71ac83dbf7f36d10f39f3a3fe907b674d1abcb62.tar.gz
linhes_pkgbuild-71ac83dbf7f36d10f39f3a3fe907b674d1abcb62.tar.bz2
xorg update part2
libs
Diffstat (limited to 'abs/core/libxcomposite/PKGBUILD')
-rw-r--r--abs/core/libxcomposite/PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/abs/core/libxcomposite/PKGBUILD b/abs/core/libxcomposite/PKGBUILD
index 854af09..23cec88 100644
--- a/abs/core/libxcomposite/PKGBUILD
+++ b/abs/core/libxcomposite/PKGBUILD
@@ -1,23 +1,27 @@
-# $Id: PKGBUILD 97802 2010-11-01 22:21:28Z jgc $
+# $Id: PKGBUILD 151410 2012-02-26 10:37:09Z pierre $
# Maintainer: Jan de Groot <jgc@archlinux.org>
pkgname=libxcomposite
pkgver=0.4.3
-pkgrel=1
+pkgrel=2
pkgdesc="X11 Composite extension library"
-arch=(i686 x86_64)
+arch=('i686' 'x86_64')
url="http://xorg.freedesktop.org/"
license=('custom')
depends=('libxfixes' 'compositeproto')
makedepends=('xorg-util-macros')
-options=(!libtool)
-source=(${url}/releases/individual/lib/libXcomposite-${pkgver}.tar.bz2)
+options=('!libtool')
+source=("${url}/releases/individual/lib/libXcomposite-${pkgver}.tar.bz2")
sha1sums=('081b26b556d55e20d7956c80a2ea2854962aecec')
build() {
cd "${srcdir}/libXcomposite-${pkgver}"
./configure --prefix=/usr --sysconfdir=/etc --disable-static
make
+}
+
+package() {
+ cd "${srcdir}/libXcomposite-${pkgver}"
make DESTDIR="${pkgdir}" install
install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"